summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-03-24 22:58:18 +0100
committerLars Wendler <polynomial-c@gentoo.org>2020-03-24 23:01:26 +0100
commit7150af5e6ccbe61ea9873c9c7911eeaf18a0c033 (patch)
treee70dbebb1663c8c80c1d86e923627099dbaba0e5 /sys-fs/fuse/fuse-3.9.1.ebuild
parentsys-devel/clang-runtime: Bump to 10.0.0 (diff)
downloadgentoo-7150af5e6ccbe61ea9873c9c7911eeaf18a0c033.tar.gz
gentoo-7150af5e6ccbe61ea9873c9c7911eeaf18a0c033.tar.bz2
gentoo-7150af5e6ccbe61ea9873c9c7911eeaf18a0c033.zip
sys-fs/fuse: Bump to version 3.9.1
Package-Manager: Portage-2.3.95, Repoman-2.3.21 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-fs/fuse/fuse-3.9.1.ebuild')
-rw-r--r--sys-fs/fuse/fuse-3.9.1.ebuild78
1 files changed, 78 insertions, 0 deletions
diff --git a/sys-fs/fuse/fuse-3.9.1.ebuild b/sys-fs/fuse/fuse-3.9.1.ebuild
new file mode 100644
index 000000000000..947ec7caa8e5
--- /dev/null
+++ b/sys-fs/fuse/fuse-3.9.1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit meson multilib-minimal flag-o-matic udev python-any-r1
+
+DESCRIPTION="An interface for filesystems implemented in userspace"
+HOMEPAGE="https://github.com/libfuse/libfuse"
+SRC_URI="https://github.com/libfuse/libfuse/releases/download/${P}/${P}.tar.xz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="+suid test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="virtual/pkgconfig
+ test? (
+ ${PYTHON_DEPS}
+ $(python_gen_any_dep 'dev-python/pytest[${PYTHON_USEDEP}]')
+ )"
+RDEPEND=">=sys-fs/fuse-common-3.3.0-r1"
+
+DOCS=( AUTHORS ChangeLog.rst README.md doc/README.NFS doc/kernel.txt )
+
+python_check_deps() {
+ has_version "dev-python/pytest[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ # lto not supported yet -- https://github.com/libfuse/libfuse/issues/198
+ filter-flags '-flto*'
+
+ # passthough_ll is broken on systems with 32-bit pointers
+ cat /dev/null > example/meson.build || die
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Duseroot=false
+ -Dudevrulesdir="${EPREFIX}$(get_udevdir)/rules.d"
+ )
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ eninja
+}
+
+multilib_src_test() {
+ ${EPYTHON} -m pytest test || die
+}
+
+multilib_src_install() {
+ DESTDIR="${D}" eninja install
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ # installed via fuse-common
+ rm -r "${ED}"/{etc,$(get_udevdir)} || die
+
+ # useroot=false prevents the build system from doing this.
+ use suid && fperms u+s /usr/bin/fusermount3
+
+ # manually install man pages to respect compression
+ rm -r "${ED}"/usr/share/man || die
+ doman doc/{fusermount3.1,mount.fuse3.8}
+}