summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2022-08-04 13:55:05 -0400
committerMike Gilbert <floppym@gentoo.org>2022-08-04 13:55:46 -0400
commitbd4e049b8809027727fc0f34f6ae30206d40781b (patch)
treef8dd31a7090f0bf412b75e91b65e54f98f99a156 /sys-fs/btrfs-progs
parentsys-apps/man-db: disable color groff output only when USE=manpager (diff)
downloadgentoo-bd4e049b8809027727fc0f34f6ae30206d40781b.tar.gz
gentoo-bd4e049b8809027727fc0f34f6ae30206d40781b.tar.bz2
gentoo-bd4e049b8809027727fc0f34f6ae30206d40781b.zip
sys-fs/btrfs-progs: fix build with glibc-2.36
Closes: https://bugs.gentoo.org/863638 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-fs/btrfs-progs')
-rw-r--r--sys-fs/btrfs-progs/btrfs-progs-5.18.1-r1.ebuild3
-rw-r--r--sys-fs/btrfs-progs/files/btrfs-progs-5.18.1-glibc-2.36.patch31
2 files changed, 34 insertions, 0 deletions
diff --git a/sys-fs/btrfs-progs/btrfs-progs-5.18.1-r1.ebuild b/sys-fs/btrfs-progs/btrfs-progs-5.18.1-r1.ebuild
index 76f2afe1fe01..0ba3477e685f 100644
--- a/sys-fs/btrfs-progs/btrfs-progs-5.18.1-r1.ebuild
+++ b/sys-fs/btrfs-progs/btrfs-progs-5.18.1-r1.ebuild
@@ -87,6 +87,9 @@ pkg_setup() {
}
src_prepare() {
+ local PATCHES=(
+ "${FILESDIR}/btrfs-progs-5.18.1-glibc-2.36.patch"
+ )
default
if [[ ${PV} == 9999 ]]; then
AT_M4DIR="m4" eautoreconf
diff --git a/sys-fs/btrfs-progs/files/btrfs-progs-5.18.1-glibc-2.36.patch b/sys-fs/btrfs-progs/files/btrfs-progs-5.18.1-glibc-2.36.patch
new file mode 100644
index 000000000000..52671ea6c357
--- /dev/null
+++ b/sys-fs/btrfs-progs/files/btrfs-progs-5.18.1-glibc-2.36.patch
@@ -0,0 +1,31 @@
+https://github.com/kdave/btrfs-progs/commit/46eb32a019834b0a49ae9744db1a921aaa6a3d63
+
+From 46eb32a019834b0a49ae9744db1a921aaa6a3d63 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Mon, 25 Jul 2022 11:58:35 -0700
+Subject: [PATCH] btrfs-progs: use linux mount.h instead of sys/mount.h
+
+This file includes linux/fs.h which includes linux/mount.h and with
+glibc 2.36 linux/mount.h and glibc mount.h are not compatible [1]
+therefore try to avoid including both headers
+
+[1] https://sourceware.org/glibc/wiki/Release/2.36
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+Signed-off-by: David Sterba <dsterba@suse.com>
+---
+ common/device-utils.c | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/common/device-utils.c b/common/device-utils.c
+index 617b67462..25a4fb8c4 100644
+--- a/common/device-utils.c
++++ b/common/device-utils.c
+@@ -15,7 +15,6 @@
+ */
+
+ #include <sys/ioctl.h>
+-#include <sys/mount.h>
+ #include <sys/statfs.h>
+ #include <sys/types.h>
+ #include <stdio.h>