summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-04-23 22:51:03 +0200
committerDavid Seifert <soap@gentoo.org>2017-04-23 23:00:59 +0200
commitb0db4186ca9a9921ddad8d1c60bb349e7106a531 (patch)
tree20852450fd00d97b01c42c4b42247c4d4d60256f /sys-boot
parentnet-wireless/wifi-radar: [QA] Add missing python metadata variables (diff)
downloadgentoo-b0db4186ca9a9921ddad8d1c60bb349e7106a531.tar.gz
gentoo-b0db4186ca9a9921ddad8d1c60bb349e7106a531.tar.bz2
gentoo-b0db4186ca9a9921ddad8d1c60bb349e7106a531.zip
sys-boot/udk: [QA] Add missing python metadata variables
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/udk/udk-2015.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/sys-boot/udk/udk-2015.ebuild b/sys-boot/udk/udk-2015.ebuild
index 8061f63ed8c7..0d0ea384e540 100644
--- a/sys-boot/udk/udk-2015.ebuild
+++ b/sys-boot/udk/udk-2015.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -8,21 +8,23 @@ PYTHON_REQ_USE="sqlite"
inherit flag-o-matic multiprocessing python-single-r1 toolchain-funcs versionator
+MY_V="${PN^^}$(get_version_component_range 1)"
+
DESCRIPTION="Tianocore UEFI Development kit"
HOMEPAGE="http://www.tianocore.org/edk2/"
-MY_V="${PN^^}$(get_version_component_range 1)"
SRC_URI="https://github.com/tianocore/${PN}/releases/download/${MY_V}/${MY_V}.Complete.MyWorkSpace.zip"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc examples"
-
-DEPEND="app-arch/unzip
- dev-lang/nasm
- ${PYTHON_DEPS}"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-lang/nasm"
+
S="${WORKDIR}/MyWorkSpace"
pkg_setup() {