summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2022-11-23 12:56:04 -0500
committerMike Gilbert <floppym@gentoo.org>2022-11-23 12:59:52 -0500
commit30b6bd9e494ab9f4fbd893b2eaf372628de7b2c7 (patch)
tree8b63b614d1ec61c10e9dacaa9dfefc7f902b61ae /sys-apps
parentpackage.mask: Last rite more m-needed packages (diff)
downloadgentoo-30b6bd9e494ab9f4fbd893b2eaf372628de7b2c7.tar.gz
gentoo-30b6bd9e494ab9f4fbd893b2eaf372628de7b2c7.tar.bz2
gentoo-30b6bd9e494ab9f4fbd893b2eaf372628de7b2c7.zip
sys-apps/less: add 612
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/less/Manifest1
-rw-r--r--sys-apps/less/less-612.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/sys-apps/less/Manifest b/sys-apps/less/Manifest
index d2513503ead9..ce044d0eb507 100644
--- a/sys-apps/less/Manifest
+++ b/sys-apps/less/Manifest
@@ -1,2 +1,3 @@
DIST less-590.tar.gz 352574 BLAKE2B 0f640f1b6b4d4925c4904ee77460e8becd2dae168fe5c1483bf6a9cfabe9eb0abdc4d4811507ba88a2b4cff6c238158bd8b4463b63d3d7863b44ce8538d32adb SHA512 426fa5840fd43c17bd5a452ad35ad24f2d6684623c6914403fd0059af62266bf2138e6828c7d73a1cef26a736c0d2b8ed4ab180eea8297281dae79a4228eb903
DIST less-608.tar.gz 362346 BLAKE2B 988940745fef1222c43b0bf4edec7cc7206ded0ac5d89d3faf4dab706a249913581c2fe7aa6063cf3d717176ed07b69299d3e791ba8a60358483fe9d1bf7f7c6 SHA512 7945b7f88921832ebb1b45fba8cbb449ee0133342796b654a52c146dfff3d84db18724ee84e53349eeea6017a0ebe2d8eb5366210275981dde7bb7190118fa66
+DIST less-612-gentoo.tar.gz 368093 BLAKE2B 35120badac25ed4def0da06f93036ec45a9c3be55a585baabd6bb98b0c016ee849142121423286a0af95f62fcf6f0fc69a6bdec32c5eb80ded6be59a4ca16b49 SHA512 97fc7e9074b4a164e089e8e9cbdba951e8833d79e1650fc3787986e4f81efb272299db7bf3961c7da8d9f33ce3458549f4223c248aea502d5abd195bc13f1b17
diff --git a/sys-apps/less/less-612.ebuild b/sys-apps/less/less-612.ebuild
new file mode 100644
index 000000000000..91b4db0d77e0
--- /dev/null
+++ b/sys-apps/less/less-612.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Excellent text file viewer"
+HOMEPAGE="http://www.greenwoodsoftware.com/less/"
+#SRC_URI="http://www.greenwoodsoftware.com/less/${P}.tar.gz"
+SRC_URI="https://dev.gentoo.org/~floppym/dist/${P}-gentoo.tar.gz"
+
+LICENSE="|| ( GPL-3 BSD-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="pcre"
+
+DEPEND=">=app-misc/editor-wrapper-3
+ >=sys-libs/ncurses-5.2:0=
+ pcre? ( dev-libs/libpcre2 )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local myeconfargs=(
+ --with-regex=$(usex pcre pcre2 posix)
+ --with-editor="${EPREFIX}"/usr/libexec/editor
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ newbin "${FILESDIR}"/lesspipe-r1.sh lesspipe
+ newenvd "${FILESDIR}"/less.envd 70less
+}
+
+pkg_preinst() {
+ if has_version "<${CATEGORY}/${PN}-483-r1" ; then
+ elog "The lesspipe.sh symlink has been dropped. If you are still setting"
+ elog "LESSOPEN to that, you will need to update it to '|lesspipe %s'."
+ elog "Colorization support has been dropped. If you want that, check out"
+ elog "the new app-text/lesspipe package."
+ fi
+}