summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-11-23 21:39:33 +0000
committerSam James <sam@gentoo.org>2024-11-23 21:54:08 +0000
commit1fd71dc9367a5dd87c6516bca7f9f4d131e8a7ef (patch)
treebdbbb5494f42b1fcacd0251218c125d095fe5cb3 /sys-apps
parentdev-util/diffoscope: drop 272, 277 (diff)
downloadgentoo-1fd71dc9367a5dd87c6516bca7f9f4d131e8a7ef.tar.gz
gentoo-1fd71dc9367a5dd87c6516bca7f9f4d131e8a7ef.tar.bz2
gentoo-1fd71dc9367a5dd87c6516bca7f9f4d131e8a7ef.zip
sys-apps/moar: add 1.29.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/moar/Manifest2
-rw-r--r--sys-apps/moar/moar-1.29.0.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/sys-apps/moar/Manifest b/sys-apps/moar/Manifest
index 3059716b10ad..eb69d64e368e 100644
--- a/sys-apps/moar/Manifest
+++ b/sys-apps/moar/Manifest
@@ -6,3 +6,5 @@ DIST moar-1.27.1-deps.tar.xz 1228028 BLAKE2B f8895cef15f6ab0eb5dcf826d86deb7dc2c
DIST moar-1.27.1.tar.gz 2812825 BLAKE2B 11998da52d8eebf0a2b1e9e82af5e78b5c559efdcc033dabc8d98dc9e324795c481e51dd63ef5eb7f46c544d60215708a967a5a47f2f87e974fc02f4cab78690 SHA512 6363bbb7399af16f844d61a630b192f866a2f9dd9a9f34caee14c7d704c52f193b3c0643053892b0483dbe0378bd87ed40bae5915bf366a877115b060d64d4b9
DIST moar-1.27.2-deps.tar.xz 1350592 BLAKE2B fc352d2f2b4a6faecdac05306306ba9c6b18c95a8844c1e9e37e0e9e7edb6ce04ef616bd1c627c688c71ab4236c3282c9bd4944347fd3bb0385f96dd7e92aab5 SHA512 e6de09efc97a682bebc6a8f21366a8982c1e211f74e0af80768e14302497b23a37863b8895a7e8fe6aa59cffd4114f57ad9db6ea6cf6cbfc18bfe0225ad8f4ff
DIST moar-1.27.2.tar.gz 2843838 BLAKE2B 600b070ac47a002cb96f4b87bc5f48a9d6ad5920ef17ba3100f30ca9852884476f41b07d38d98820e553ad0cfc28a679e55e986dfcba633f4fe89beba72ddd49 SHA512 f6ab70e929bfcec575f7f2d6e31ad6fd723355f68bc327d4ee59707b58617e635d089e501bd86cdca5d2c09c7db21fdedb7fab79e0456a5f806ab848ae0aa99b
+DIST moar-1.29.0-deps.tar.xz 1359500 BLAKE2B 302b176f2b22878a6a1eb0e5d57eeb83adf0b3dd790a070d969b4b840741700e4143d9abd7138d556cb7fa04b72412c52e8d4560cb8f925f5e6625633cbd1d4e SHA512 317df040f8541548bfec2d27557cf34a547cea60a3a921860fa50e099c792fd4a2b6822fadc7b0b4d395f7d7f338bc7cb39ef2f267a8a4df27e4d554a8b34b36
+DIST moar-1.29.0.tar.gz 2846285 BLAKE2B 4afbe74849985ac702b5847ebe640f074ea7603eff5d0ed6a04b3716373e0f73cb040c4869a469b8b36ebd964a0ed059ae3dd43d45d532753796b8478192f23f SHA512 a9d4944533aed9deeb2e87572147e522b65273e0eb0b0d04253d2d22d9e6f7c7dbf9ffa045a6e70f1d5f4b37e7e8a301f63f2a080742af90f4db2bdb20a04e18
diff --git a/sys-apps/moar/moar-1.29.0.ebuild b/sys-apps/moar/moar-1.29.0.ebuild
new file mode 100644
index 000000000000..928e03d26244
--- /dev/null
+++ b/sys-apps/moar/moar-1.29.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-env go-module
+
+DESCRIPTION="Pager designed to do the right thing without any configuration"
+HOMEPAGE="https://github.com/walles/moar"
+SRC_URI="https://github.com/walles/moar/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="BSD-2 BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# moarvm: https://github.com/walles/moar/issues/143
+RDEPEND="!dev-lang/moarvm"
+BDEPEND="
+ test? (
+ app-arch/bzip2
+ app-arch/xz-utils
+ )
+"
+
+src_unpack() {
+ default
+
+ if [[ -d "${WORKDIR}"/vendor ]] ; then
+ mv "${WORKDIR}"/vendor "${S}"/vendor || die
+ fi
+ go-env_set_compile_environment
+}
+
+src_compile() {
+ # https://github.com/walles/moar/blob/master/build.sh#L28
+ ego build -ldflags="-w -X main.versionString=${PV}" -o moar
+}
+
+src_test() {
+ # From test.sh (we don't run that because it has some linting etc)
+ ego test -timeout 20s ./...
+}
+
+src_install() {
+ dobin moar
+ doman moar.1
+ einstalldocs
+}