summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarty E. Plummer <hanetzer@startmail.com>2018-04-20 04:27:50 -0500
committerDavid Seifert <soap@gentoo.org>2018-04-20 22:01:02 +0200
commit15c1627d6beed77de7213991cfc047a2a73b9468 (patch)
treec447dd6a0f3a46f52306cee3d749e0f162f45d6b /sys-apps/udevil
parentnet-irc/epic5: epatch->PATCHES=() (diff)
downloadgentoo-15c1627d6beed77de7213991cfc047a2a73b9468.tar.gz
gentoo-15c1627d6beed77de7213991cfc047a2a73b9468.tar.bz2
gentoo-15c1627d6beed77de7213991cfc047a2a73b9468.zip
sys-apps/udevil: epatch->PATCHES=()
Also dropped unneeded eutils, in favor of epatch in the -r1 ebuild and nothing in the -r2 -r3 ebuilds. Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'sys-apps/udevil')
-rw-r--r--sys-apps/udevil/files/udevil-0.4.3-flags.patch4
-rw-r--r--sys-apps/udevil/files/udevil-0.4.4-stat.patch4
-rw-r--r--sys-apps/udevil/udevil-0.4.4-r1.ebuild6
-rw-r--r--sys-apps/udevil/udevil-0.4.4-r2.ebuild17
-rw-r--r--sys-apps/udevil/udevil-0.4.4-r3.ebuild17
5 files changed, 27 insertions, 21 deletions
diff --git a/sys-apps/udevil/files/udevil-0.4.3-flags.patch b/sys-apps/udevil/files/udevil-0.4.3-flags.patch
index 166a4357e9f3..524cdfff9900 100644
--- a/sys-apps/udevil/files/udevil-0.4.3-flags.patch
+++ b/sys-apps/udevil/files/udevil-0.4.3-flags.patch
@@ -4,8 +4,8 @@ Subject: build system
respect flags where possible
---- configure.ac
-+++ configure.ac
+--- a/configure.ac
++++ b/configure.ac
@@ -18,26 +18,6 @@
diff --git a/sys-apps/udevil/files/udevil-0.4.4-stat.patch b/sys-apps/udevil/files/udevil-0.4.4-stat.patch
index 22e41d467821..427a6f1f670d 100644
--- a/sys-apps/udevil/files/udevil-0.4.4-stat.patch
+++ b/sys-apps/udevil/files/udevil-0.4.4-stat.patch
@@ -1,6 +1,6 @@
Fixes bug #552072. Thanks Helmut Jarausch.
---- src/device-info.h
-+++ src/device-info.h
+--- a/src/device-info.h
++++ b/src/device-info.h
@@ -14,6 +14,7 @@
#include <libudev.h>
#include <fcntl.h>
diff --git a/sys-apps/udevil/udevil-0.4.4-r1.ebuild b/sys-apps/udevil/udevil-0.4.4-r1.ebuild
index 9f3cd58b0b13..73596bdd436e 100644
--- a/sys-apps/udevil/udevil-0.4.4-r1.ebuild
+++ b/sys-apps/udevil/udevil-0.4.4-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-inherit eutils autotools user
+inherit autotools epatch user
DESCRIPTION="mount and unmount removable devices without a password"
HOMEPAGE="https://ignorantguru.github.com/udevil/"
@@ -31,7 +31,7 @@ pkg_setup(){
src_prepare() {
# This works for 0.4.4 too, no sense copying the patch
epatch "${FILESDIR}"/${PN}-0.4.3-flags.patch
- epatch "${FILESDIR}"/${P}-stat.patch
+ epatch "${FILESDIR}"/${PN}-0.4.4-stat.patch
eautoreconf
}
diff --git a/sys-apps/udevil/udevil-0.4.4-r2.ebuild b/sys-apps/udevil/udevil-0.4.4-r2.ebuild
index c93bc7b9dcc2..a75cf290506c 100644
--- a/sys-apps/udevil/udevil-0.4.4-r2.ebuild
+++ b/sys-apps/udevil/udevil-0.4.4-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit eutils autotools user
+inherit autotools user
DESCRIPTION="mount and unmount removable devices without a password"
HOMEPAGE="https://ignorantguru.github.com/udevil/"
@@ -28,12 +28,15 @@ pkg_setup(){
enewgroup plugdev
}
-src_prepare() {
+PATCHES=(
# This works for 0.4.4 too, no sense copying the patch
- epatch "${FILESDIR}"/${PN}-0.4.3-flags.patch
- epatch "${FILESDIR}"/${P}-stat.patch
- epatch "${FILESDIR}"/${P}-include-sysmacros.patch
- eapply_user
+ "${FILESDIR}"/${PN}-0.4.3-flags.patch
+ "${FILESDIR}"/${PN}-0.4.4-stat.patch
+ "${FILESDIR}"/${PN}-0.4.4-include-sysmacros.patch
+)
+
+src_prepare() {
+ default
eautoreconf
}
diff --git a/sys-apps/udevil/udevil-0.4.4-r3.ebuild b/sys-apps/udevil/udevil-0.4.4-r3.ebuild
index fc14c4677245..0dede83db0ee 100644
--- a/sys-apps/udevil/udevil-0.4.4-r3.ebuild
+++ b/sys-apps/udevil/udevil-0.4.4-r3.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit eutils autotools user
+inherit autotools user
DESCRIPTION="mount and unmount removable devices without a password"
HOMEPAGE="https://ignorantguru.github.com/udevil/"
@@ -28,12 +28,15 @@ pkg_setup(){
enewgroup plugdev
}
-src_prepare() {
+PATCHES=(
# This works for 0.4.4 too, no sense copying the patch
- epatch "${FILESDIR}"/${PN}-0.4.3-flags.patch
- epatch "${FILESDIR}"/${P}-stat.patch
- epatch "${FILESDIR}"/${P}-include-sysmacros-r1.patch
- eapply_user
+ "${FILESDIR}"/${PN}-0.4.3-flags.patch
+ "${FILESDIR}"/${PN}-0.4.4-stat.patch
+ "${FILESDIR}"/${PN}-0.4.4-include-sysmacros.patch
+)
+
+src_prepare() {
+ default
eautoreconf
}