summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/salinfo/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/salinfo/files')
-rw-r--r--sys-apps/salinfo/files/salinfo-1.2-build.patch47
1 files changed, 47 insertions, 0 deletions
diff --git a/sys-apps/salinfo/files/salinfo-1.2-build.patch b/sys-apps/salinfo/files/salinfo-1.2-build.patch
new file mode 100644
index 000000000000..848b363939af
--- /dev/null
+++ b/sys-apps/salinfo/files/salinfo-1.2-build.patch
@@ -0,0 +1,47 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,3 +1,4 @@
++prefix = $(DESTDIR)
+ mandir := /usr/share/man
+ sbindir := /usr/sbin
+ logdir := /var/log/salinfo
+@@ -5,7 +6,7 @@ initdir := /etc/rc.d/init.d
+ sysconfigdir := /etc/sysconfig
+ logrotate := /etc/logrotate.d
+
+-CFLAGS += -Wall -g -O2 $(EXTRA_CFLAGS)
++CFLAGS += -Wall $(EXTRA_CFLAGS)
+ export CFLAGS
+
+ ifneq ($(VPATH),)
+--- a/sal.h
++++ b/sal.h
+@@ -27,6 +27,8 @@
+ * Keith Owens <kaos@sgi.com>
+ */
+
++#include <asm/fpu.h>
++
+ #include "efi.h"
+ #include "pal.h"
+
+--- a/salinfo_decode.c
++++ b/salinfo_decode.c
+@@ -303,7 +303,7 @@ log_dropped_records(void)
+ snprintf(line, sizeof(line), ", %d %s",
+ dropped_all[i]->dropped, dropped_all[i]->name);
+ dropped_all[i]->dropped = 0;
+- strncat(log, line, sizeof(log));
++ strncat(log, line, sizeof(log) - strlen(log));
+ }
+ }
+ syslog(LOG_NOTICE, "%s", log);
+@@ -424,7 +424,7 @@ talk_to_sal (void)
+ int fd;
+ char filename[PATH_MAX];
+ snprintf(filename, sizeof(filename), "%s/%s/.check", directory, rd[i]);
+- if ((fd = open(filename, O_WRONLY|O_CREAT|O_TRUNC)) < 0) {
++ if ((fd = open(filename, O_WRONLY|O_CREAT|O_TRUNC, 0644)) < 0) {
+ perror(filename);
+ goto out;
+ }