summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-08-04 13:24:09 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-08-04 13:24:59 +0200
commit67c06d8d8628aa72e4a61a3795e141f536469f1b (patch)
tree6f17632c441fbb601c02d7f705d8aef7f7664f43 /sys-apps/most
parentRevert "sys-apps/most: Bump to version 5.1.0" (diff)
downloadgentoo-67c06d8d8628aa72e4a61a3795e141f536469f1b.tar.gz
gentoo-67c06d8d8628aa72e4a61a3795e141f536469f1b.tar.bz2
gentoo-67c06d8d8628aa72e4a61a3795e141f536469f1b.zip
sys-apps/most: Bump to version 5.1.0
Closes: https://bugs.gentoo.org/691414 Package-Manager: Portage-2.3.70, Repoman-2.3.16 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-apps/most')
-rw-r--r--sys-apps/most/Manifest1
-rw-r--r--sys-apps/most/most-5.1.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/sys-apps/most/Manifest b/sys-apps/most/Manifest
index 3bf53b5ce982..7d3eff66a3e0 100644
--- a/sys-apps/most/Manifest
+++ b/sys-apps/most/Manifest
@@ -1 +1,2 @@
DIST most-5.0.0a.tar.bz2 131130 BLAKE2B f516b7cd1b37ca274dc8472a258390cde437f44ac320a257ab94cb97e918d574f61e961457809941a3eefa761a62e8f45bd60392e5b95dc60cedc6c1d9f56baf SHA512 0c101777250a15ed9cbe0bfbaa17d0ac5ef973a7e0730d096bd931ba578dbcbd4f244305c99a50bc8fd8aa1937b621a97a6452b3821fee7d72f33a02da278e5d
+DIST most-5.1.0.tar.gz 162172 BLAKE2B a3c0f3d85e7c4f4a014c174efb0d3d22b0fc2758e403ddccc74308399eeec616800e16db33554f0ca53fba674efba9dd93d51ed0c3f887b2c24fd3dd2335387c SHA512 cbc090283bbaafb8ffee9d6d1abc7b49cd58d54b742cf8dc86274351dee6398d1f24841bd1631ac40f861ad9e23569646133d3297317d9d514a7a38dd74533d2
diff --git a/sys-apps/most/most-5.1.0.ebuild b/sys-apps/most/most-5.1.0.ebuild
new file mode 100644
index 000000000000..bba1f93cc8f4
--- /dev/null
+++ b/sys-apps/most/most-5.1.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Paging program that displays, one windowful at a time, the contents of a file"
+HOMEPAGE="https://www.jedsoft.org/most/"
+SRC_URI="https://www.jedsoft.org/releases/${PN}/${P}.tar.gz
+ https://www.jedsoft.org/releases/${PN}/old/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+RDEPEND=">=sys-libs/slang-2.1.3"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-5.0.0a-donot-hardcode-path.patch
+)
+
+src_prepare() {
+ default
+ # Do not strip by default
+ sed -e '/\$(INSTALL)/s@ -s@@' -i src/Makefile.in || die
+}
+
+src_configure() {
+ unset ARCH
+ econf
+}
+
+src_install() {
+ emake DESTDIR="${D}" DOC_DIR="${EPREFIX}/usr/share/doc/${PF}" \
+ install
+}