summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-08-25 09:14:57 +0100
committerSam James <sam@gentoo.org>2022-08-25 09:20:29 +0100
commit794f2e908450fead67d97d28599acf3b0bb0993c (patch)
tree8bb5824379d6a1391cc876a7168160bd10dfbc05 /sys-apps/man-pages
parentdev-lang/python: Remove old (diff)
downloadgentoo-794f2e908450fead67d97d28599acf3b0bb0993c.tar.gz
gentoo-794f2e908450fead67d97d28599acf3b0bb0993c.tar.bz2
gentoo-794f2e908450fead67d97d28599acf3b0bb0993c.zip
sys-apps/man-pages: add 6.0_rc1, 9999 (unkeyworded)
The man-pages repo gets a lot of activity and correctness fixes, but also useful especially for new glibc & kernel features. Add an unkeyworded live ebuild to make it easier to get these fixes for testing. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/man-pages')
-rw-r--r--sys-apps/man-pages/Manifest1
-rw-r--r--sys-apps/man-pages/man-pages-6.0_rc1.ebuild83
-rw-r--r--sys-apps/man-pages/man-pages-9999.ebuild83
3 files changed, 167 insertions, 0 deletions
diff --git a/sys-apps/man-pages/Manifest b/sys-apps/man-pages/Manifest
index 9067470d5b1c..bd2e2ab38be7 100644
--- a/sys-apps/man-pages/Manifest
+++ b/sys-apps/man-pages/Manifest
@@ -1,3 +1,4 @@
DIST man-pages-5.12.tar.xz 1778220 BLAKE2B 347c5ef63cb80134018f322f810545354ccc7afdb8acb62f83e3b06ef15d7fbe6c0c68db37f52ce9727682a856a7810a5e64f1dcbe1cc11b22f83fb0273f7add SHA512 455794ed6e3bf20649f78b464300d5c1adad5000668a82a1194c1af8bdcbd064e4d930696cbe534481368d6526c7cda69927e958b9a868d95891202476fb4608
DIST man-pages-5.13.tar.xz 1788980 BLAKE2B 7cca88b7f201d177b087893f60e6a87fd3ed8c78a183bd6ebcd0c28961f5f5d24aa2ba9d3a1d9cec4e0fc9cc0b26489c91e991a2d4420c28e1f61b850b882752 SHA512 a68c0bd5f078aff2f13f962060863e5d30734c1c562e8e9e3d5eda5a329b18ad3e9b4ebb883d31cacfc0a476f91fccb8dd4257598acd75d09dd21351893d3499
+DIST man-pages-6.0-rc1.tar.gz 2636606 BLAKE2B adeaa325669631125fe55fd140abe25309b287c03a377aa665e39b4279241fc1e711199493498e97c03c8af9c5a3370a47991f88d7c602e7fc54e5f6ef61ff55 SHA512 61be0a14e5ffb9c89bdbdb3a83967c65a6fae15a6f46f5c2e7304205646bf8ab6d10f954a4ea003f3d75bc2775fcb0a88b5cd6ad15e6beed3dd56a25f395342e
DIST man-pages-gentoo-2.tar.bz2 5141 BLAKE2B c5c7956ab47c8a473e258b1902d5d19d9eb2e9d01786e907d9c3ba691c2a506834ed96cd1f54e8d8415e65d4fea0056659537f0faffe68fcbed33aa728a5e61e SHA512 6e6524b8ad6f1b8c9b147665ee32af49e05603dac61d433acd6b4f1164adef27cd542898f272b07d8659725013dac59c7f34a858968cc054a4785c945e14a770
diff --git a/sys-apps/man-pages/man-pages-6.0_rc1.ebuild b/sys-apps/man-pages/man-pages-6.0_rc1.ebuild
new file mode 100644
index 000000000000..22c1987a858c
--- /dev/null
+++ b/sys-apps/man-pages/man-pages-6.0_rc1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+GENTOO_PATCH=2
+
+DESCRIPTION="A somewhat comprehensive collection of Linux man pages"
+HOMEPAGE="https://www.kernel.org/doc/man-pages/"
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://git.kernel.org/pub/scm/docs/man-pages/man-pages.git"
+ inherit git-r3
+elif [[ ${PV} == *_rc* ]] ; then
+ MY_P=${PN}-${PV/_/-}
+
+ SRC_URI="https://git.kernel.org/pub/scm/docs/man-pages/man-pages.git/snapshot/${MY_P}.tar.gz"
+ S="${WORKDIR}"/${MY_P}
+else
+ SRC_URI="
+ https://www.kernel.org/pub/linux/docs/man-pages/Archive/${P}.tar.xz
+ https://www.kernel.org/pub/linux/docs/man-pages/${P}.tar.xz
+ "
+
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+SRC_URI+="
+ mirror://gentoo/man-pages-gentoo-${GENTOO_PATCH}.tar.bz2
+ https://dev.gentoo.org/~cardoe/files/man-pages-gentoo-${GENTOO_PATCH}.tar.bz2
+"
+
+LICENSE="man-pages GPL-2+ BSD"
+SLOT="0"
+IUSE_L10N=" de es fr it ja nl pl pt-BR ro ru zh-CN"
+IUSE="${IUSE_L10N// / l10n_}"
+RESTRICT="binchecks"
+
+# Block packages that used to install colliding man pages:
+# bug #341953, bug #548900, bug #612640, bug #617462
+RDEPEND="
+ virtual/man
+ !<sys-apps/keyutils-1.5.9-r4
+ !<dev-libs/libbsd-0.8.3-r1
+"
+PDEPEND="
+ l10n_de? ( app-i18n/man-pages-l10n[l10n_de(-)] )
+ l10n_es? ( app-i18n/man-pages-l10n[l10n_es(-)] )
+ l10n_fr? ( app-i18n/man-pages-l10n[l10n_fr(-)] )
+ l10n_it? ( app-i18n/man-pages-l10n[l10n_it(-)] )
+ l10n_ja? ( app-i18n/man-pages-ja )
+ l10n_nl? ( app-i18n/man-pages-l10n[l10n_nl(-)] )
+ l10n_pl? ( app-i18n/man-pages-l10n[l10n_pl(-)] )
+ l10n_pt-BR? ( app-i18n/man-pages-l10n[l10n_pt-BR(-)] )
+ l10n_ro? ( app-i18n/man-pages-l10n[l10n_ro(-)] )
+ l10n_ru? ( app-i18n/man-pages-ru )
+ l10n_zh-CN? ( app-i18n/man-pages-zh_CN )
+ sys-apps/man-pages-posix
+"
+
+src_unpack() {
+ default
+
+ git-r3_src_unpack
+}
+
+src_prepare() {
+ default
+
+ # passwd.5 installed by sys-apps/shadow, bug #776787
+ rm man5/passwd.5 || die
+}
+
+src_compile() { :; }
+
+src_install() {
+ emake install prefix="${EPREFIX}"/usr DESTDIR="${D}"
+ dodoc man-pages-*.Announce README Changes*
+
+ # Override with Gentoo specific or additional Gentoo pages
+ cd "${WORKDIR}"/man-pages-gentoo || die
+ doman */*
+ dodoc README.Gentoo
+}
diff --git a/sys-apps/man-pages/man-pages-9999.ebuild b/sys-apps/man-pages/man-pages-9999.ebuild
new file mode 100644
index 000000000000..22c1987a858c
--- /dev/null
+++ b/sys-apps/man-pages/man-pages-9999.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+GENTOO_PATCH=2
+
+DESCRIPTION="A somewhat comprehensive collection of Linux man pages"
+HOMEPAGE="https://www.kernel.org/doc/man-pages/"
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://git.kernel.org/pub/scm/docs/man-pages/man-pages.git"
+ inherit git-r3
+elif [[ ${PV} == *_rc* ]] ; then
+ MY_P=${PN}-${PV/_/-}
+
+ SRC_URI="https://git.kernel.org/pub/scm/docs/man-pages/man-pages.git/snapshot/${MY_P}.tar.gz"
+ S="${WORKDIR}"/${MY_P}
+else
+ SRC_URI="
+ https://www.kernel.org/pub/linux/docs/man-pages/Archive/${P}.tar.xz
+ https://www.kernel.org/pub/linux/docs/man-pages/${P}.tar.xz
+ "
+
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+SRC_URI+="
+ mirror://gentoo/man-pages-gentoo-${GENTOO_PATCH}.tar.bz2
+ https://dev.gentoo.org/~cardoe/files/man-pages-gentoo-${GENTOO_PATCH}.tar.bz2
+"
+
+LICENSE="man-pages GPL-2+ BSD"
+SLOT="0"
+IUSE_L10N=" de es fr it ja nl pl pt-BR ro ru zh-CN"
+IUSE="${IUSE_L10N// / l10n_}"
+RESTRICT="binchecks"
+
+# Block packages that used to install colliding man pages:
+# bug #341953, bug #548900, bug #612640, bug #617462
+RDEPEND="
+ virtual/man
+ !<sys-apps/keyutils-1.5.9-r4
+ !<dev-libs/libbsd-0.8.3-r1
+"
+PDEPEND="
+ l10n_de? ( app-i18n/man-pages-l10n[l10n_de(-)] )
+ l10n_es? ( app-i18n/man-pages-l10n[l10n_es(-)] )
+ l10n_fr? ( app-i18n/man-pages-l10n[l10n_fr(-)] )
+ l10n_it? ( app-i18n/man-pages-l10n[l10n_it(-)] )
+ l10n_ja? ( app-i18n/man-pages-ja )
+ l10n_nl? ( app-i18n/man-pages-l10n[l10n_nl(-)] )
+ l10n_pl? ( app-i18n/man-pages-l10n[l10n_pl(-)] )
+ l10n_pt-BR? ( app-i18n/man-pages-l10n[l10n_pt-BR(-)] )
+ l10n_ro? ( app-i18n/man-pages-l10n[l10n_ro(-)] )
+ l10n_ru? ( app-i18n/man-pages-ru )
+ l10n_zh-CN? ( app-i18n/man-pages-zh_CN )
+ sys-apps/man-pages-posix
+"
+
+src_unpack() {
+ default
+
+ git-r3_src_unpack
+}
+
+src_prepare() {
+ default
+
+ # passwd.5 installed by sys-apps/shadow, bug #776787
+ rm man5/passwd.5 || die
+}
+
+src_compile() { :; }
+
+src_install() {
+ emake install prefix="${EPREFIX}"/usr DESTDIR="${D}"
+ dodoc man-pages-*.Announce README Changes*
+
+ # Override with Gentoo specific or additional Gentoo pages
+ cd "${WORKDIR}"/man-pages-gentoo || die
+ doman */*
+ dodoc README.Gentoo
+}