summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-12-07 02:45:03 +0000
committerSam James <sam@gentoo.org>2024-12-07 02:54:50 +0000
commit3377b06bc005482cca923a66440216e3d3b41ef8 (patch)
treed002e817785a5d76493b6e85e053ea48e9e6116b /sys-apps/hwdata
parentsys-apps/hwdata: drop 0.375, 0.376, 0.382 (diff)
downloadgentoo-3377b06bc005482cca923a66440216e3d3b41ef8.tar.gz
gentoo-3377b06bc005482cca923a66440216e3d3b41ef8.tar.bz2
gentoo-3377b06bc005482cca923a66440216e3d3b41ef8.zip
sys-apps/hwdata: add 0.390
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/hwdata')
-rw-r--r--sys-apps/hwdata/Manifest1
-rw-r--r--sys-apps/hwdata/hwdata-0.390.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/sys-apps/hwdata/Manifest b/sys-apps/hwdata/Manifest
index 58528f60b010..0bf19c726354 100644
--- a/sys-apps/hwdata/Manifest
+++ b/sys-apps/hwdata/Manifest
@@ -1 +1,2 @@
DIST hwdata-0.383.tar.gz 2430035 BLAKE2B 7f53f08fa6df5d4dd2eb5a92b419914a0fd04a74285d5af0d879fe9b30b768f24c526225b3d700201a53eccabee49ae84958bb6605bc0265483bdf1801dfbffc SHA512 9a11e0d8cc6788c6a54c87956afb19853f5214c1d2deb77cc7c6155687a9621b83d54533a8e475decad82aaad84581ee410d16b7db20e666f62a003a76a62618
+DIST hwdata-0.390.tar.gz 2473831 BLAKE2B 45a8d5468d82dd3b3f42e290183bdd1dbd2e23ec926f780a54b21484263b7d9ea789b10fd9d6f1b9e741d160823b4816e6b6a470e0930dbc830c7a820ae514de SHA512 c9cbe0e41001a0d61b164d6544e57d66be7b4230434d2c395d182f41f96e6c3831e443c933f5a29bd0a2fefabbfc232a9efa772d04b89972da5d4d2eb7882443
diff --git a/sys-apps/hwdata/hwdata-0.390.ebuild b/sys-apps/hwdata/hwdata-0.390.ebuild
new file mode 100644
index 000000000000..9e6adae7a4b1
--- /dev/null
+++ b/sys-apps/hwdata/hwdata-0.390.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit edo
+
+DESCRIPTION="Hardware identification and configuration data"
+HOMEPAGE="https://github.com/vcrhonek/hwdata"
+SRC_URI="https://github.com/vcrhonek/hwdata/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RESTRICT="test"
+
+src_configure() {
+ # configure is not compatible with econf
+ local conf=(
+ ./configure
+ --prefix="${EPREFIX}/usr"
+ --libdir="${EPREFIX}/lib"
+ --datadir="${EPREFIX}/usr/share"
+ )
+
+ edo "${conf[@]}"
+}