summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2018-04-27 04:13:09 -0400
committerMike Frysinger <vapier@gentoo.org>2018-05-07 00:47:11 -0400
commit9e40b37deb8eb2e80cb85ae8ff212540af62b8c7 (patch)
treeaac5dcdf25a0f174efb643615e470cd8c1e4fd41 /sys-apps/cpuid/cpuid-20180419.ebuild
parentdev-ruby/capybara: add 3.0.3 (diff)
downloadgentoo-9e40b37deb8eb2e80cb85ae8ff212540af62b8c7.tar.gz
gentoo-9e40b37deb8eb2e80cb85ae8ff212540af62b8c7.tar.bz2
gentoo-9e40b37deb8eb2e80cb85ae8ff212540af62b8c7.zip
sys-apps/cpuid: version bump to 20180419
Diffstat (limited to 'sys-apps/cpuid/cpuid-20180419.ebuild')
-rw-r--r--sys-apps/cpuid/cpuid-20180419.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-apps/cpuid/cpuid-20180419.ebuild b/sys-apps/cpuid/cpuid-20180419.ebuild
new file mode 100644
index 000000000000..b4c973068b48
--- /dev/null
+++ b/sys-apps/cpuid/cpuid-20180419.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Utility to get detailed information about the CPU(s) using the CPUID instruction"
+HOMEPAGE="http://www.etallen.com/cpuid.html"
+SRC_URI="http://www.etallen.com/${PN}/${P}.src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ app-arch/gzip
+ dev-lang/perl"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-20170122-Makefile.patch
+ "${FILESDIR}"/${PN}-20170122-missing-include-sysmacros.patch
+)
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ emake BUILDROOT="${ED}" install
+ einstalldocs
+}