summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2021-09-17 15:29:47 +0200
committerSam James <sam@gentoo.org>2021-09-18 04:04:08 +0100
commit5010e7702f719436b5f75dac7b9c4bf54325d98d (patch)
tree22ecff24fe7b5cb93908825a2eb7ef717429709b /sys-apps/busybox
parentmedia-gfx/gimp: UI bug fix 2.10.26 -> 2.10.28 (diff)
downloadgentoo-5010e7702f719436b5f75dac7b9c4bf54325d98d.tar.gz
gentoo-5010e7702f719436b5f75dac7b9c4bf54325d98d.tar.bz2
gentoo-5010e7702f719436b5f75dac7b9c4bf54325d98d.zip
sys-apps/busybox: Do not overwrite existing files with make-symlinks
- Turns out previous fix did not work correctly, so let's pass 'echo n' to cp to stop it from overwriting existing files Fixes: 50b3efe86028e0e7d184d3a5c4a36c11f3388b6f Signed-off-by: Jakov Smolić <jsmolic@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/22317 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/busybox')
-rw-r--r--sys-apps/busybox/busybox-1.34.0-r1.ebuild (renamed from sys-apps/busybox/busybox-1.34.0.ebuild)2
-rw-r--r--sys-apps/busybox/busybox-9999.ebuild2
2 files changed, 2 insertions, 2 deletions
diff --git a/sys-apps/busybox/busybox-1.34.0.ebuild b/sys-apps/busybox/busybox-1.34.0-r1.ebuild
index 7b556bbba975..731b645a8e40 100644
--- a/sys-apps/busybox/busybox-1.34.0.ebuild
+++ b/sys-apps/busybox/busybox-1.34.0-r1.ebuild
@@ -337,7 +337,7 @@ pkg_postinst() {
cd "${T}" || die
mkdir _install
tar xf busybox-links.tar -C _install || die
- false | cp -vpPR _install/* "${ROOT}"/ || die "copying links for ${x} failed"
+ echo n | cp -ivpPR _install/* "${ROOT}"/ || die "copying links for ${x} failed"
fi
if use sep-usr ; then
diff --git a/sys-apps/busybox/busybox-9999.ebuild b/sys-apps/busybox/busybox-9999.ebuild
index 8297592e5309..46cfa6711249 100644
--- a/sys-apps/busybox/busybox-9999.ebuild
+++ b/sys-apps/busybox/busybox-9999.ebuild
@@ -336,7 +336,7 @@ pkg_postinst() {
cd "${T}" || die
mkdir _install
tar xf busybox-links.tar -C _install || die
- false | cp -vpPR _install/* "${ROOT}"/ || die "copying links for ${x} failed"
+ echo n | cp -ivpPR _install/* "${ROOT}"/ || die "copying links for ${x} failed"
fi
if use sep-usr ; then