summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-08-07 10:50:05 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-08-07 10:58:17 +0200
commit6bc87db73ed1c21e6fb9bd1be3c727815ddf6686 (patch)
tree0d2366ef73bfdd4f7a85fcd1271a206f5d12b2b8 /sci-misc
parentdev-python/pyxDamerauLevenshtein: Bump to 1.7.1 (diff)
downloadgentoo-6bc87db73ed1c21e6fb9bd1be3c727815ddf6686.tar.gz
gentoo-6bc87db73ed1c21e6fb9bd1be3c727815ddf6686.tar.bz2
gentoo-6bc87db73ed1c21e6fb9bd1be3c727815ddf6686.zip
sci-misc/jupyterlab-desktop-bin: add 3.4.4.1
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/jupyterlab-desktop-bin/Manifest1
-rw-r--r--sci-misc/jupyterlab-desktop-bin/jupyterlab-desktop-bin-3.4.4.1.ebuild116
2 files changed, 117 insertions, 0 deletions
diff --git a/sci-misc/jupyterlab-desktop-bin/Manifest b/sci-misc/jupyterlab-desktop-bin/Manifest
index 948f06fc5faf..0ad85ece09e0 100644
--- a/sci-misc/jupyterlab-desktop-bin/Manifest
+++ b/sci-misc/jupyterlab-desktop-bin/Manifest
@@ -1 +1,2 @@
DIST jupyterlab-desktop-bin-3.3.4.2.rpm 317104304 BLAKE2B d983738b3f0e8bf25014e5c4dca2eb0ccfd5be238d2376a3703a2f5347687d1737b97fed8cf5a8937a1b2258bc26bb6fb4311624fbd76d690c88f74569b4c2d3 SHA512 d444865a2a51d10d27ffb8f98f137151eaccc8901dadbdb34794fd705cc395b33ee789ad921fa03300ff31657805e51a61656f3ece35c98843737d751512637c
+DIST jupyterlab-desktop-bin-3.4.4.1.rpm 318510660 BLAKE2B ddbe9786082546bcefd39f7aa9cf631d5dd830c0771e1eca84838829433503dd37a1445e232a4a9c9332a256a294034a6538b3115b105063a2c26698f40a0c07 SHA512 5556e75fbedf8e152811b1164364dbc4d99fbfb6cd41ced81d479673f5705dade6d15240bc5096338de0056970fffc32444aa78c93bb1b66b44bc266a7254d8d
diff --git a/sci-misc/jupyterlab-desktop-bin/jupyterlab-desktop-bin-3.4.4.1.ebuild b/sci-misc/jupyterlab-desktop-bin/jupyterlab-desktop-bin-3.4.4.1.ebuild
new file mode 100644
index 000000000000..fb775790888d
--- /dev/null
+++ b/sci-misc/jupyterlab-desktop-bin/jupyterlab-desktop-bin-3.4.4.1.ebuild
@@ -0,0 +1,116 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CHROMIUM_LANGS="
+ am ar bg bn ca cs da de el en-GB en-US es es-419 et fa fi fil fr gu he hi
+ hr hu id it ja kn ko lt lv ml mr ms nb nl pl pt-BR pt-PT ro ru sk sl sr sv
+ sw ta te th tr uk vi zh-CN zh-TW
+"
+
+inherit chromium-2 desktop rpm xdg
+
+DESCRIPTION="JupyterLab desktop application, based on Electron"
+HOMEPAGE="https://jupyter.org/"
+SRC_URI="https://github.com/jupyterlab/${PN%%-bin}/releases/download/v$(ver_rs 3 -)/JupyterLab-Setup-Fedora.rpm -> ${P}.rpm"
+S="${WORKDIR}"
+
+KEYWORDS="-* ~amd64"
+# Electron bundles a bunch of things
+LICENSE="
+ MIT BSD BSD-2 BSD-4 AFL-2.1 Apache-2.0 Ms-PL GPL-2 LGPL-2.1 APSL-2
+ unRAR OFL CC-BY-SA-3.0 MPL-2.0 android public-domain all-rights-reserved
+"
+SLOT="0"
+RESTRICT="bindist mirror"
+
+RDEPEND="
+ app-accessibility/at-spi2-atk
+ app-accessibility/at-spi2-core
+ dev-libs/atk
+ dev-libs/expat
+ dev-libs/glib
+ dev-libs/nspr
+ dev-libs/nss
+ dev-python/jupyterlab
+ media-libs/alsa-lib
+ media-libs/mesa
+ net-print/cups
+ sys-apps/dbus
+ sys-libs/glibc
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:3
+ x11-libs/libdrm
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libxkbcommon
+ x11-libs/libXrandr
+ x11-libs/libxshmfence
+ x11-libs/pango
+"
+
+QA_PREBUILT="opt/JupyterLab/*"
+
+pkg_pretend() {
+ chromium_suid_sandbox_check_kernel_config
+}
+
+src_prepare() {
+ default
+ # cleanup languages
+ pushd "opt/JupyterLab/locales" || die
+ chromium_remove_language_paks
+ popd || die
+}
+
+src_configure() {
+ chromium_suid_sandbox_check_kernel_config
+ default
+}
+
+src_install() {
+ for size in {16,32,48,64,128,256,512}; do
+ doicon -s ${size} "usr/share/icons/hicolor/${size}x${size}/apps/jupyterlab-desktop.png"
+ done
+
+ domenu usr/share/applications/jupyterlab-desktop.desktop
+
+ local DESTDIR="/opt/JupyterLab"
+ pushd "opt/JupyterLab" || die
+
+ exeinto "${DESTDIR}"
+ doexe chrome-sandbox chrome_crashpad_handler jupyterlab-desktop *.so*
+
+ exeinto "${DESTDIR}/swiftshader"
+ doexe swiftshader/*.so*
+
+ insinto "${DESTDIR}"
+ doins *.pak *.bin *.json *.dat
+ insopts -m0755
+ doins -r locales resources
+
+ # Chrome-sandbox requires the setuid bit to be specifically set.
+ # see https://github.com/electron/electron/issues/17972
+ fperms 4755 "${DESTDIR}"/chrome-sandbox
+
+ dosym "${DESTDIR}"/jupyterlab-desktop /opt/bin/jupyterlab-desktop
+ popd || die
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ elog ""
+ elog "On initial startup you will be prompted to select the python environment of"
+ elog "your choice. Either select a specific python version, e.g. /usr/bin/pythonX.Y,"
+ elog "or choose /usr/bin/python to follow the system wide setting in"
+ elog "/etc/python-exec/python-exec.conf."
+ elog "Please note that only python environments corresponding to the enabled"
+ elog "PYTHON_TARGETS on dev-python/jupyterlab will work."
+ elog ""
+}