summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-07-25 22:21:23 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-07-30 23:30:59 +0200
commitfe37f36c668553ac3676d4c6901b77602340447c (patch)
treef77e2cf1421ac7ef16240d403b600d65d4bc5085 /sci-mathematics
parentdev-embedded/xa: adjust patch (diff)
downloadgentoo-fe37f36c668553ac3676d4c6901b77602340447c.tar.gz
gentoo-fe37f36c668553ac3676d4c6901b77602340447c.tar.bz2
gentoo-fe37f36c668553ac3676d4c6901b77602340447c.zip
sci-mathematics/rkward: add 0.8.0
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/rkward/Manifest1
-rw-r--r--sci-mathematics/rkward/files/rkward-0.8.0-unbundle-kdsingleapplication.patch57
-rw-r--r--sci-mathematics/rkward/rkward-0.8.0.ebuild62
3 files changed, 120 insertions, 0 deletions
diff --git a/sci-mathematics/rkward/Manifest b/sci-mathematics/rkward/Manifest
index dcf538f32e0b..d341b86d2513 100644
--- a/sci-mathematics/rkward/Manifest
+++ b/sci-mathematics/rkward/Manifest
@@ -1 +1,2 @@
DIST rkward-0.7.5.tar.gz 7682442 BLAKE2B b3c79dbc51585c646e88549d82b0a68a3246219b069d641f71beb25f2ac855d0c7a0e44e1cdba3da112ee94479584768ebd45fc37afb83fbd95de51bcc3f5a31 SHA512 247ee50fbebb9b74a1c03d6ef99dded18a1b3cf18286a6d2afcaa8ff7472cc3cb735db0a876926625aff4674906956f7a0c001a46d0dfd328a93e8c7af9f6c6b
+DIST rkward-0.8.0.tar.gz 8614382 BLAKE2B e44dd1c9ae5df02160ac47a14409a2fbf88dbc085369af22e64c80a59740f25305129e166402e944f85978cabde4d273a08f7f473eb46fdb31145ff8d886f46a SHA512 07070189e05fe1bdd65372fb3f90c027c693b93e3dc80a17bc30f90c983ca0bc777f30ea81ef99343ebdc90f463f47721d03f26d116145567c8ef6ca4ffdff27
diff --git a/sci-mathematics/rkward/files/rkward-0.8.0-unbundle-kdsingleapplication.patch b/sci-mathematics/rkward/files/rkward-0.8.0-unbundle-kdsingleapplication.patch
new file mode 100644
index 000000000000..0340987c517b
--- /dev/null
+++ b/sci-mathematics/rkward/files/rkward-0.8.0-unbundle-kdsingleapplication.patch
@@ -0,0 +1,57 @@
+From 997c8a7280fe0f99a29465f67b56fd001cdac4e1 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Mon, 22 Jul 2024 22:20:26 +0200
+Subject: [PATCH] Make it possible to build against system kdsingleapplication
+
+Bundling must be avoided wherever possible.
+
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+---
+ CMakeLists.txt | 10 +++++++++-
+ rkward/main.cpp | 2 +-
+ 2 files changed, 10 insertions(+), 2 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 3b9833164..1af6cd172 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -26,6 +26,15 @@ FIND_PACKAGE(Qt6 6.6 CONFIG REQUIRED COMPONENTS Widgets Core Xml Network Qml Pri
+ FIND_PACKAGE(KF6 6.0.0 REQUIRED COMPONENTS CoreAddons DocTools I18n XmlGui TextEditor WidgetsAddons Parts Config Notifications WindowSystem Archive BreezeIcons OPTIONAL_COMPONENTS Crash)
+ FIND_PACKAGE(Gettext REQUIRED)
+
++FIND_PACKAGE(KDSingleApplication-qt6 1.1.0 QUIET)
++if(KDSingleApplication-qt6_FOUND)
++ message(STATUS "Using system KDSingleApplication")
++else()
++ message(STATUS "Using bundled KDSingleApplication")
++ add_subdirectory(3rdparty/KDSingleApplication)
++ add_definitions(-DKDSINGLEAPPLICATION_STATIC_BUILD)
++endif()
++
+ IF(FORCE_PRETTY_MAKEFILE)
+ SET(CMAKE_VERBOSE_MAKEFILE OFF)
+ ENDIF(FORCE_PRETTY_MAKEFILE)
+@@ -37,7 +46,6 @@ remove_definitions(-DQT_NO_CAST_FROM_ASCII) # TODO remove to compley to KDECompi
+ #uncomment the line below to save ~250-350kB in object size
+ #ADD_DEFINITIONS(-DRKWARD_NO_TRACE)
+
+-ADD_SUBDIRECTORY(3rdparty/KDSingleApplication)
+ ADD_SUBDIRECTORY(rkward)
+ ADD_SUBDIRECTORY(doc)
+ ADD_SUBDIRECTORY(tests)
+diff --git a/rkward/main.cpp b/rkward/main.cpp
+index 2804e99d8..df959ba82 100644
+--- a/rkward/main.cpp
++++ b/rkward/main.cpp
+@@ -72,7 +72,7 @@ SPDX-License-Identifier: GPL-2.0-or-later
+ #include "rbackend/rksessionvars.h"
+ #include "windows/rkdebugmessagewindow.h"
+ #include "misc/rkcommonfunctions.h"
+-#include "../3rdparty/KDSingleApplication/kdsingleapplication.h"
++#include "kdsingleapplication.h"
+ #include "misc/rkcommandlineargs.h"
+
+ #ifdef Q_OS_WIN
+--
+GitLab
+
diff --git a/sci-mathematics/rkward/rkward-0.8.0.ebuild b/sci-mathematics/rkward/rkward-0.8.0.ebuild
new file mode 100644
index 000000000000..a6333ecdd210
--- /dev/null
+++ b/sci-mathematics/rkward/rkward-0.8.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="forceoptional"
+KFMIN=6.3.0
+QTMIN=6.6.2
+inherit ecm kde.org optfeature
+
+DESCRIPTION="IDE for the R-project"
+HOMEPAGE="https://rkward.kde.org/"
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ SRC_URI="mirror://kde/stable/${PN}/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~amd64-linux"
+fi
+
+LICENSE="GPL-2+ LGPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ dev-lang/R
+ dev-libs/kdsingleapplication[qt6(+)]
+ >=dev-qt/qt5compat-${QTMIN}:6
+ >=dev-qt/qtbase-${QTMIN}:6[dbus,gui,network,widgets,xml]
+ >=dev-qt/qtdeclarative-${QTMIN}:6
+ >=dev-qt/qtwebengine-${QTMIN}:6[widgets]
+ >=kde-frameworks/breeze-icons-${KFMIN}:6
+ >=kde-frameworks/karchive-${KFMIN}:6
+ >=kde-frameworks/kcompletion-${KFMIN}:6
+ >=kde-frameworks/kconfig-${KFMIN}:6
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/kcrash-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kio-${KFMIN}:6
+ >=kde-frameworks/kjobwidgets-${KFMIN}:6
+ >=kde-frameworks/knotifications-${KFMIN}:6
+ >=kde-frameworks/kparts-${KFMIN}:6
+ >=kde-frameworks/kservice-${KFMIN}:6
+ >=kde-frameworks/ktexteditor-${KFMIN}:6
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:6
+ >=kde-frameworks/kwindowsystem-${KFMIN}:6
+ >=kde-frameworks/kxmlgui-${KFMIN}:6
+"
+RDEPEND="${DEPEND}
+ !${CATEGORY}/${PN}:5
+"
+BDEPEND="sys-devel/gettext"
+
+PATCHES=( "${FILESDIR}/${P}-unbundle-kdsingleapplication.patch" )
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "kate plugins support" "kde-apps/kate-addons:6"
+ optfeature "prendering (or previewing) R markdown (.Rmd) files" "app-text/pandoc"
+ optfeature "managing citations while writing articles" "app-text/kbibtex"
+ fi
+ ecm_pkg_postinst
+}