summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2022-08-22 10:29:09 -0400
committerMichael Orlitzky <mjo@gentoo.org>2022-08-22 11:05:31 -0400
commitb0cc66b092a7d098bb79736221c9612ddfc80a45 (patch)
tree502ea925867c5a5c30f2fae7045cc485d56c277e /sci-mathematics
parentapp-text/zotero-bin: add 6.0.13 (diff)
downloadgentoo-b0cc66b092a7d098bb79736221c9612ddfc80a45.tar.gz
gentoo-b0cc66b092a7d098bb79736221c9612ddfc80a45.tar.bz2
gentoo-b0cc66b092a7d098bb79736221c9612ddfc80a45.zip
sci-mathematics/primesieve: add 8.0
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/primesieve/Manifest1
-rw-r--r--sci-mathematics/primesieve/primesieve-8.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/sci-mathematics/primesieve/Manifest b/sci-mathematics/primesieve/Manifest
index cd41bbd1bc6f..092315e4d777 100644
--- a/sci-mathematics/primesieve/Manifest
+++ b/sci-mathematics/primesieve/Manifest
@@ -1 +1,2 @@
DIST primesieve-7.9.tar.gz 111361 BLAKE2B 8e227bd04a89dd5e8ea5dc5e79afa1c5254216863086fd6c3712fb45767ee7e5e23e72d166ada17295e56479e0c0e1ae7f215b72e124e5234a79fb20f340cb3f SHA512 fcfc3445e5becd555b66743f6d73dd4a0cbb48b1d4a3d0d22043261f1861e0631bdeb8702b1f942110f8b327a01173b231accd1f7595600308709832bbbafc06
+DIST primesieve-8.0.tar.gz 119635 BLAKE2B e769cfe35752e809cf1611b3a9034bc79d16311c73d5065880cbec9c8179a2149ee9a3a6e277466691c44adf07781e1c7f9aa53f140714c4c9d408b24df17848 SHA512 213785c89868f224091fe76a74b98a896c374a7a96e2bdb44b07f4c6288bd50e22d9a563382fb512e71a1ad366d8b94e74fcc8b5f58bb94c85b4d435fbb6a571
diff --git a/sci-mathematics/primesieve/primesieve-8.0.ebuild b/sci-mathematics/primesieve/primesieve-8.0.ebuild
new file mode 100644
index 000000000000..9a6ef5573027
--- /dev/null
+++ b/sci-mathematics/primesieve/primesieve-8.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="CLI and library for quickly generating prime numbers"
+HOMEPAGE="https://github.com/kimwalisch/primesieve"
+SRC_URI="https://github.com/kimwalisch/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD-2"
+SLOT="0/10" # subslot is first component of libprimesieve.so version
+KEYWORDS="~amd64"
+IUSE="doc +executable test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="doc? ( app-doc/doxygen app-text/texlive media-gfx/graphviz )"
+DEPEND=""
+RDEPEND=""
+
+DOCS=(
+ ChangeLog
+ README.md
+ doc/ALGORITHMS.md
+ doc/CPP_API.md
+ doc/C_API.md
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_DOC="$(usex doc)"
+ -DBUILD_PRIMESIEVE="$(usex executable)"
+ -DBUILD_STATIC_LIBS="OFF"
+ -DBUILD_TESTS="$(usex test)"
+ )
+
+ if use doc; then
+ DOCS+=(
+ "${BUILD_DIR}/doc/html"
+ "${BUILD_DIR}/doc/latex/refman.pdf"
+ )
+ fi
+
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ use doc && cmake_build doc
+}