summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/cdd+
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/cdd+')
-rw-r--r--sci-libs/cdd+/Manifest1
-rw-r--r--sci-libs/cdd+/cdd+-077a.ebuild39
-rw-r--r--sci-libs/cdd+/files/cdd+-077a-gentoo.patch43
-rw-r--r--sci-libs/cdd+/files/cdd+-077a-headers.patch69
-rw-r--r--sci-libs/cdd+/metadata.xml10
5 files changed, 162 insertions, 0 deletions
diff --git a/sci-libs/cdd+/Manifest b/sci-libs/cdd+/Manifest
new file mode 100644
index 000000000000..30c21c9c6815
--- /dev/null
+++ b/sci-libs/cdd+/Manifest
@@ -0,0 +1 @@
+DIST cdd+-077a.tar.gz 186771 SHA256 bace5c6c62fc48938b04a7b80fc55935e1bfe56cfb0b80f803842173a40ad616 SHA512 cb151274adec502420e5e931d2f248d62b26d5797f7d55f6db9c947f8e9d715a864c88ad08ad2cd74ada237789de5ca3c49dc04dc55e63d4101f07cc1685ab12 WHIRLPOOL a36abf5d5654a786844543f78126d60ec9c0326966570674e63f02251aa2fce72a640eda5ad1893cd5b3e7592f53f0fbd96887107d4e53fcf15100e8a6bea73d
diff --git a/sci-libs/cdd+/cdd+-077a.ebuild b/sci-libs/cdd+/cdd+-077a.ebuild
new file mode 100644
index 000000000000..19dd12c7ac28
--- /dev/null
+++ b/sci-libs/cdd+/cdd+-077a.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="Another implementation of the double description method"
+HOMEPAGE="http://www.ifor.math.ethz.ch/~fukuda/cdd_home/"
+SRC_URI="ftp://ftp.ifor.math.ethz.ch/pub/fukuda/cdd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-libs/gmp:0="
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-headers.patch \
+ "${FILESDIR}"/${P}-gentoo.patch
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
+ GMPLIBDIR="${EPREFIX}/usr/$(get_libdir)" \
+ GMPINCLUDE="${EPREFIX}/usr/include" \
+ all
+
+}
+
+src_install() {
+ dobin cddr+ cddf+
+}
diff --git a/sci-libs/cdd+/files/cdd+-077a-gentoo.patch b/sci-libs/cdd+/files/cdd+-077a-gentoo.patch
new file mode 100644
index 000000000000..efe6d7035e99
--- /dev/null
+++ b/sci-libs/cdd+/files/cdd+-077a-gentoo.patch
@@ -0,0 +1,43 @@
+--- makefile.orig 2010-01-19 20:22:59.000000000 +0100
++++ makefile 2010-01-19 20:52:01.000000000 +0100
+@@ -6,21 +6,21 @@
+ #CC = /bin/cc
+
+ # Location of gnu c++ library.
+-#LIBDIR = /usr/lib
+-LIBDIR = /usr/local/lib
++LIBDIR = /usr/lib
++#LIBDIR = /usr/local/lib
+
+ # Location of gnu gmp library libgmp.a
+-#GMPLIBDIR = /usr/lib
+-GMPLIBDIR = /usr/local/lib
++GMPLIBDIR = /usr/lib
++#GMPLIBDIR = /usr/local/lib
+
+ # Location of gnu gmp-library include file gmp.h
+-#GMPINCLUDEDIR = /usr/include
+-GMPINCLUDEDIR = /usr/local/include
++GMPINCLUDEDIR = /usr/include
++#GMPINCLUDEDIR = /usr/local/include
+
+ # Compiler optimization/debug options
+ #OPTFLAGS = -g -static -O
+ #OPTFLAGS = -g -static -pg -O
+-OPTFLAGS = -O3
++#OPTFLAGS = -O3
+
+ ########## You shouldn't have to change anything after this point ##########
+
+@@ -29,9 +29,8 @@
+ RATOBJ = gmp_init.o Integer.o Rational.o
+ RATEXE = cddr+
+
+-CFLAGS = $(OPTFLAGS) -I$(INCLUDEDIR) -I$(GMPINCLUDEDIR) -I. $(GMPFLAG)
+-
+-LDFLAGS = -L$(LIBDIR) -L$(GMPLIBDIR)
++CFLAGS += -I$(INCLUDEDIR) -I$(GMPINCLUDEDIR) -I. $(GMPFLAG)
++LDFLAGS += -L$(LIBDIR) -L$(GMPLIBDIR)
+
+ LIBS = -lstdc++ -l$(RATLIB)
+
diff --git a/sci-libs/cdd+/files/cdd+-077a-headers.patch b/sci-libs/cdd+/files/cdd+-077a-headers.patch
new file mode 100644
index 000000000000..c6ceb93bfaad
--- /dev/null
+++ b/sci-libs/cdd+/files/cdd+-077a-headers.patch
@@ -0,0 +1,69 @@
+Index: Integer.h
+===================================================================
+RCS file: /home/imocvs/cdd+/Integer.h,v
+retrieving revision 1.1.1.1
+diff -u -p -r1.1.1.1 Integer.h
+--- Integer.h 2008/12/15 01:19:52 1.1.1.1
++++ Integer.h 2008/12/15 01:24:04
+@@ -23,6 +23,7 @@
+ #include <gmp_init.h>
+ #include <cctype>
+ #include <limits>
++#include <climits>
+
+ class Integer; class Rational;
+
+Index: Rational.cc
+===================================================================
+RCS file: /home/imocvs/cdd+/Rational.cc,v
+retrieving revision 1.1.1.1
+diff -u -p -r1.1.1.1 Rational.cc
+--- Rational.cc 2008/12/15 01:19:52 1.1.1.1
++++ Rational.cc 2008/12/15 01:25:14
+@@ -17,6 +17,7 @@
+
+ #include <cctype>
+ #include "Rational.h"
++#include <cstring>
+
+ Rational& Rational::set(const char* s) throw (gmp_error)
+ {
+Index: Rational.h
+===================================================================
+RCS file: /home/imocvs/cdd+/Rational.h,v
+retrieving revision 1.1.1.1
+diff -u -p -r1.1.1.1 Rational.h
+--- Rational.h 2008/12/15 01:19:52 1.1.1.1
++++ Rational.h 2008/12/15 01:27:08
+@@ -17,6 +17,7 @@
+ #define _POLYMAKE_GMP_RATIONAL_H "$Project: polymake $$Id$
+
+ #include <Integer.h>
++#include <cstring>
+
+ #if __GNU_MP_VERSION < 4
+ #define _tmp_little_Integer(x) \
+@@ -1178,7 +1179,7 @@ std::basic_ostream<char, Traits>& operat
+ Integer::little_buffer buf(s);
+ numerator(a).putstr(os.flags(), buf);
+ if (show_den) {
+- char *den_buf=buf+strlen(buf);
++ char *den_buf=buf+std::strlen(buf);
+ *den_buf++ = '/';
+ denominator(a).putstr(os.flags(), den_buf);
+ }
+Index: gmp_init.cc
+===================================================================
+RCS file: /home/imocvs/cdd+/gmp_init.cc,v
+retrieving revision 1.1.1.1
+diff -u -p -r1.1.1.1 gmp_init.cc
+--- gmp_init.cc 2008/12/15 01:19:52 1.1.1.1
++++ gmp_init.cc 2008/12/15 01:23:45
+@@ -16,6 +16,7 @@
+ #ident "$Project: polymake $$Id$
+
+ #include <memory>
++#include <cstring>
+ #include "gmp_init.h"
+
+ #if defined(__GNUC__)
diff --git a/sci-libs/cdd+/metadata.xml b/sci-libs/cdd+/metadata.xml
new file mode 100644
index 000000000000..3444aa87b903
--- /dev/null
+++ b/sci-libs/cdd+/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-mathematics</herd>
+ <longdescription>
+ The program cdd+ is a C++ implementation of the Double Description Method of Motzkin et al. for generating all
+ vertices (i.e. extreme points) and extreme rays of a general convex polyhedron in R^d given by a system of linear
+ inequalities: P = { x : A x &lt;= b } where A is an m x d real matrix and b is a real m dimensional vector.
+ </longdescription>
+</pkgmetadata>