summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2024-07-10 13:57:22 -0300
committerPacho Ramos <pacho@gentoo.org>2025-01-25 17:48:30 +0100
commit157af34344e72893a3425b09042cdf4c78c74a30 (patch)
tree2bde955ab96acd592b23b9b1d31180937ca0d7cb /sci-geosciences
parentgnome-extra/evolution-ews: drop 3.50.2 (diff)
downloadgentoo-157af34344e72893a3425b09042cdf4c78c74a30.tar.gz
gentoo-157af34344e72893a3425b09042cdf4c78c74a30.tar.bz2
gentoo-157af34344e72893a3425b09042cdf4c78c74a30.zip
sci-geosciences/gnome-maps: Bump to 47.3
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/38609 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/gnome-maps/Manifest1
-rw-r--r--sci-geosciences/gnome-maps/gnome-maps-47.3.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/sci-geosciences/gnome-maps/Manifest b/sci-geosciences/gnome-maps/Manifest
index ba98876cbaf2..fab551a5fdd1 100644
--- a/sci-geosciences/gnome-maps/Manifest
+++ b/sci-geosciences/gnome-maps/Manifest
@@ -1,2 +1,3 @@
DIST gnome-maps-45.5.tar.xz 3141872 BLAKE2B 3064a7ba2e96eaca7c5ad3a66874eb05bde1e675076003f3470ab5bb3bab04525e83e09a2239524247e1963af768d3e36512cbe3bc4dfe05dd951570b4488567 SHA512 cfcf616c331b8feebd79e31585a7f6f0aa05d3cf48713930635585a7d069996ec8c739b6bc1528b649d01c59307a39402d46a27c5e773d1e6b9b6a46362af35b
DIST gnome-maps-46.11.tar.xz 3195792 BLAKE2B 6942a3801e738e981c7b462f23363c92e164c7cea55b650b9ef65fdc623e8bf279c11ef459af2ba91bc077288dff86d54fef9f3bfb1e00832bdffdc2f076f783 SHA512 c34f4535af6db93eca7ed7b7be0778bbfdae53aba1a32ec4882a84d82eeff6d82a365ef4ac18b3f55a829e044d680869827c5b897ddeb12b16a17d08f50f9ba1
+DIST gnome-maps-47.3.tar.xz 3272236 BLAKE2B 4f74b5ad7b7302d79c9d1b1198b5d6f9b6a31c56c01310f0e37ada4645af93909a3015ed6c4a3d7c22a8a25624bc470a54645d8d1e33f4b3c89752a9ec056bf1 SHA512 009d967fd671a3542c76262a7ed9cd10f2afd2d1242c6f7a863377b78b395e9906edc488ef9808f075a239266fd0c6325fd2ed6e6c081243b3d9e7a3e53e9a09
diff --git a/sci-geosciences/gnome-maps/gnome-maps-47.3.ebuild b/sci-geosciences/gnome-maps/gnome-maps-47.3.ebuild
new file mode 100644
index 000000000000..6e5722c445c4
--- /dev/null
+++ b/sci-geosciences/gnome-maps/gnome-maps-47.3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="A map application for GNOME"
+HOMEPAGE="https://apps.gnome.org/Maps/"
+
+LICENSE="CC0-1.0 GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+# Pure introspection dependencies found by grepping imports in ${S}
+RDEPEND="
+ >=dev-libs/glib-2.66.0:2
+ >=dev-libs/gjs-1.69.2
+ >=dev-libs/gobject-introspection-0.10.1:=
+ >=gui-libs/gtk-4.10:4[introspection]
+ >=app-misc/geoclue-0.12.99:2.0[introspection]
+ >=gui-libs/libadwaita-1.5:1[introspection]
+ >=dev-libs/libgweather-4.2.0:4=[introspection]
+ >=sci-geosciences/geocode-glib-3.15.2:2[introspection]
+ dev-libs/libportal:=[introspection]
+ >=media-libs/libshumate-1.2_alpha:1.0=[introspection]
+ dev-libs/libxml2:2
+ >=net-libs/rest-0.9.1:1.0[introspection]
+ >=gnome-base/librsvg-2.0
+ >=dev-libs/json-glib-1.0
+
+ app-crypt/libsecret[introspection]
+ media-libs/graphene[introspection]
+ net-libs/libsoup:3.0[introspection]
+ x11-libs/pango[introspection]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}