summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-geosciences/geocode-glib
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-geosciences/geocode-glib')
-rw-r--r--sci-geosciences/geocode-glib/Manifest2
-rw-r--r--sci-geosciences/geocode-glib/geocode-glib-3.14.0.ebuild47
-rw-r--r--sci-geosciences/geocode-glib/geocode-glib-3.16.2.ebuild49
-rw-r--r--sci-geosciences/geocode-glib/metadata.xml9
4 files changed, 107 insertions, 0 deletions
diff --git a/sci-geosciences/geocode-glib/Manifest b/sci-geosciences/geocode-glib/Manifest
new file mode 100644
index 000000000000..503ec2d35e3d
--- /dev/null
+++ b/sci-geosciences/geocode-glib/Manifest
@@ -0,0 +1,2 @@
+DIST geocode-glib-3.14.0.tar.xz 352308 SHA256 a19b21a92b8cbfa29a5ae6616c2fdca8567e97480f7bb5c955905f6ae1c72010 SHA512 39cce731930b21ea351e3c032757bdec0b97ac014ae4b04997b70cfa64438bec980964cbbaa32e2bfb4c5524b9799261475594d07208c87c692b33c0cd531aa4 WHIRLPOOL 00b7f6bccd9c96ef19c1cfd66eb7f6045763a79543d042e02fbb49c2c4a506afaf3d86e961bf5cd2591012fb0df8b246694fb2a47a8a759761153dbc707da19d
+DIST geocode-glib-3.16.2.tar.xz 355424 SHA256 a551ffdbd793d54a14e709c9d02e82dde3abc14eed8065abad92275a43fe2c97 SHA512 847dc7069beafd61eb3a6f1c1ca86f2ede14ed76d018a4c2ecd75989539293bfb98795b9bb181b457c36406039ab96b678c35ccbba41e16739f96d414aa68ebe WHIRLPOOL 9597e66fcb265736b16b9b1a623d0b53797477f966b05a773f53316189888446a1b492fc5c239334500ecca6a2c443f3ac477825e04a74132d826e7dbd7b5bf9
diff --git a/sci-geosciences/geocode-glib/geocode-glib-3.14.0.ebuild b/sci-geosciences/geocode-glib/geocode-glib-3.14.0.ebuild
new file mode 100644
index 000000000000..353ae17207ca
--- /dev/null
+++ b/sci-geosciences/geocode-glib/geocode-glib-3.14.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no" # --enable-debug does not do anything useful
+
+inherit gnome2
+
+DESCRIPTION="GLib geocoding library that uses the Yahoo! Place Finder service"
+HOMEPAGE="http://git.gnome.org/browse/geocode-glib"
+
+# FIXME: should be slot 1.0 but upstream failed at renaming the libs
+# and some files conflict from previous releases.
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86"
+IUSE="+introspection test"
+
+RDEPEND="
+ >=dev-libs/glib-2.34:2
+ >=dev-libs/json-glib-0.99.2[introspection?]
+ gnome-base/gvfs[http]
+ net-libs/libsoup:2.4[introspection?]
+ introspection? (
+ >=dev-libs/gobject-introspection-0.6.3
+ net-libs/libsoup-gnome:2.4[introspection] )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.13
+ >=sys-devel/gettext-0.18
+ virtual/pkgconfig
+ test? ( sys-apps/dbus )
+"
+# eautoreconf requires:
+# dev-libs/gobject-introspection-common
+# gnome-base/gnome-common
+
+RESTRICT="test" # Need network #424719
+
+src_test() {
+ export GVFS_DISABLE_FUSE=1
+ export GIO_USE_VFS=gvfs
+ ewarn "Tests require network access to http://where.yahooapis.com"
+ dbus-launch emake check || die "tests failed"
+}
diff --git a/sci-geosciences/geocode-glib/geocode-glib-3.16.2.ebuild b/sci-geosciences/geocode-glib/geocode-glib-3.16.2.ebuild
new file mode 100644
index 000000000000..4788a04672ea
--- /dev/null
+++ b/sci-geosciences/geocode-glib/geocode-glib-3.16.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no" # --enable-debug does not do anything useful
+
+inherit gnome2
+
+DESCRIPTION="GLib geocoding library that uses the Yahoo! Place Finder service"
+HOMEPAGE="http://git.gnome.org/browse/geocode-glib"
+
+# FIXME: should be slot 1.0 but upstream failed at renaming the libs
+# and some files conflict from previous releases.
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+introspection test"
+
+RDEPEND="
+ >=dev-libs/glib-2.34:2
+ >=dev-libs/json-glib-0.99.2[introspection?]
+ gnome-base/gvfs[http]
+ net-libs/libsoup:2.4[introspection?]
+ introspection? (
+ >=dev-libs/gobject-introspection-0.6.3
+ net-libs/libsoup-gnome:2.4[introspection] )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.13
+ >=sys-devel/gettext-0.18
+ virtual/pkgconfig
+ test? ( sys-apps/dbus )
+"
+# eautoreconf requires:
+# dev-libs/gobject-introspection-common
+# gnome-base/gnome-common
+
+# FIXME: need network #424719, recheck
+# need various locales to be present
+RESTRICT="test"
+
+src_test() {
+ export GVFS_DISABLE_FUSE=1
+ export GIO_USE_VFS=gvfs
+ ewarn "Tests require network access to http://where.yahooapis.com"
+ dbus-launch emake check || die "tests failed"
+}
diff --git a/sci-geosciences/geocode-glib/metadata.xml b/sci-geosciences/geocode-glib/metadata.xml
new file mode 100644
index 000000000000..0b6b5da045eb
--- /dev/null
+++ b/sci-geosciences/geocode-glib/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+<use>
+ <flag name="introspection">Use <pkg>dev-libs/gobject-introspection</pkg>
+ for introspection</flag>
+</use>
+</pkgmetadata>