summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-15 15:47:49 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-15 16:03:52 +0200
commit673d602fa0469af10478c8090c69a00fdfef9b40 (patch)
tree25b7e520f3040184ea807aec84ef32c36944b03e /sci-chemistry/coot/files
parentsci-libs/coot-data: Version Bump (diff)
downloadgentoo-673d602fa0469af10478c8090c69a00fdfef9b40.tar.gz
gentoo-673d602fa0469af10478c8090c69a00fdfef9b40.tar.bz2
gentoo-673d602fa0469af10478c8090c69a00fdfef9b40.zip
sci-chemistry/coot: Version Bump
Package-Manager: portage-2.2.20.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sci-chemistry/coot/files')
-rw-r--r--sci-chemistry/coot/files/coot-0.8.2-desktop.patch21
-rw-r--r--sci-chemistry/coot/files/coot-0.8.2-libguile.patch29
-rw-r--r--sci-chemistry/coot/files/coot-0.8.2-libtool.patch39
-rw-r--r--sci-chemistry/coot/files/coot-0.8.2-sandbox-icons.patch16
4 files changed, 105 insertions, 0 deletions
diff --git a/sci-chemistry/coot/files/coot-0.8.2-desktop.patch b/sci-chemistry/coot/files/coot-0.8.2-desktop.patch
new file mode 100644
index 000000000000..c264dd5a7628
--- /dev/null
+++ b/sci-chemistry/coot/files/coot-0.8.2-desktop.patch
@@ -0,0 +1,21 @@
+ coot.desktop | 7 +++----
+ 1 file changed, 3 insertions(+), 4 deletions(-)
+
+diff --git a/coot.desktop b/coot.desktop
+index 74aecf3..8668018 100644
+--- a/coot.desktop
++++ b/coot.desktop
+@@ -1,10 +1,9 @@
+ [Desktop Entry]
+ Type=Application
+-Encoding=UTF-8
+ Name=Coot
+ Comment=Macromolecular model builder
+ Exec=coot
+-Icon=coot.png
++Icon=coot
+ Terminal=true
+-Categories=Science;Graphics
+-MimeType=chemical/x-pdb;chemical/x-mmcif;chemical/x-mdl-molfile
++Categories=Science;Graphics;
++MimeType=chemical/x-pdb;chemical/x-mmcif;chemical/x-mdl-molfile;
diff --git a/sci-chemistry/coot/files/coot-0.8.2-libguile.patch b/sci-chemistry/coot/files/coot-0.8.2-libguile.patch
new file mode 100644
index 000000000000..cbaccefb2947
--- /dev/null
+++ b/sci-chemistry/coot/files/coot-0.8.2-libguile.patch
@@ -0,0 +1,29 @@
+ src/graphics-info-modelling.cc | 1 +
+ src/graphics-info.cc | 2 ++
+ 2 files changed, 3 insertions(+)
+
+diff --git a/src/graphics-info-modelling.cc b/src/graphics-info-modelling.cc
+index 05a63ad..4b7d129 100644
+--- a/src/graphics-info-modelling.cc
++++ b/src/graphics-info-modelling.cc
+@@ -102,6 +102,7 @@
+
+ #include "utils/coot-utils.hh"
+
++#include <libguile.h>
+
+ // Idealize the geometry without considering the map.
+ //
+diff --git a/src/graphics-info.cc b/src/graphics-info.cc
+index e2f9d52..76b6769 100644
+--- a/src/graphics-info.cc
++++ b/src/graphics-info.cc
+@@ -92,6 +92,8 @@
+ #include "cc-interface-scripting.hh"
+ #endif
+
++#include <libguile.h>
++
+ // A few non-class members - should be somewhere else, I guess.
+ //
+ void initialize_graphics_molecules() {
diff --git a/sci-chemistry/coot/files/coot-0.8.2-libtool.patch b/sci-chemistry/coot/files/coot-0.8.2-libtool.patch
new file mode 100644
index 000000000000..10c43ad55594
--- /dev/null
+++ b/sci-chemistry/coot/files/coot-0.8.2-libtool.patch
@@ -0,0 +1,39 @@
+ configure.ac | 2 +-
+ lbg/Makefile.am | 11 -----------
+ 2 files changed, 1 insertion(+), 12 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 73d6ed7..b04dcd6 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -69,7 +69,7 @@ AC_LIB_PREPARE_MULTILIB
+
+ AC_SUBST(COOT_STDTYPES)
+
+-EXPORT_DYNAMIC_FLAG_SPEC=$export_dynamic_flag_spec
++eval EXPORT_DYNAMIC_FLAG_SPEC=\"$export_dynamic_flag_spec\"
+ AC_SUBST(EXPORT_DYNAMIC_FLAG_SPEC)
+
+
+diff --git a/lbg/Makefile.am b/lbg/Makefile.am
+index 1277afe..a79ebe0 100644
+--- a/lbg/Makefile.am
++++ b/lbg/Makefile.am
+@@ -43,17 +43,6 @@ pkginclude_HEADERS = lbg.hh wmolecule.hh flev-annotations.hh graphics-c-interfa
+ lbg-drag-and-drop.hh qed-interface.hh alerts.hh pi-stacking.hh
+ pkgincludedir = $(includedir)/coot/lbg
+
+-# 20140521
+-# lidia_LDFLAGS = -Wl,--export-dynamic
+-#
+-# Now we use EXPORT_DYNAMIC_FLAG_SPEC which usually evaluates to ${wl}--export-dynamic
+-# (but not for MacOSX, where it Does The Right Thing (hopefully)).
+-# We manually set the value of wl here, but maybe the Right Thing To Do for that is
+-# run (eval) $($LIBTOOL --config | grep ^wl). How do I do that here though?
+-# I don't understand. Maybe the setting of wl should be done in configure? But then
+-# I have to force the output of libtool. Bleugh. Hmm...
+-# Anyway, thankyou Gary Vaughan.
+-wl=-Wl,
+ lidia_LDFLAGS = $(EXPORT_DYNAMIC_FLAG_SPEC)
+
+ # res spec output operator means we include libcoot-coord-utils
diff --git a/sci-chemistry/coot/files/coot-0.8.2-sandbox-icons.patch b/sci-chemistry/coot/files/coot-0.8.2-sandbox-icons.patch
new file mode 100644
index 000000000000..2a9ff2d7177c
--- /dev/null
+++ b/sci-chemistry/coot/files/coot-0.8.2-sandbox-icons.patch
@@ -0,0 +1,16 @@
+ pixmaps/icons/Makefile.am | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/pixmaps/icons/Makefile.am b/pixmaps/icons/Makefile.am
+index 0c183ae..dddc11a 100644
+--- a/pixmaps/icons/Makefile.am
++++ b/pixmaps/icons/Makefile.am
+@@ -11,6 +11,6 @@ install-data-local:
+ CONTEXT=` echo $$icon | cut -d_ -f2`; \
+ SIZE=` echo $$icon | cut -d_ -f3`; \
+ ICONFILE=`echo $$icon | cut -d_ -f4`; \
+- mkdir -p $(datadir)/icons/$$THEME/$$SIZE/$$CONTEXT; \
+- $(INSTALL_DATA) $(srcdir)/$$icon $(datadir)/icons/$$THEME/$$SIZE/$$CONTEXT/$$ICONFILE; \
++ mkdir -p $(DESTDIR)$(datadir)/icons/$$THEME/$$SIZE/$$CONTEXT; \
++ $(INSTALL_DATA) $(srcdir)/$$icon $(DESTDIR)$(datadir)/icons/$$THEME/$$SIZE/$$CONTEXT/$$ICONFILE; \
+ done;