summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2020-02-13 13:55:45 -0500
committerRick Farina <zerochaos@gentoo.org>2020-02-13 13:55:56 -0500
commita460ecf5f4c7aa8b59149d553774ff95284b9c30 (patch)
treedc029bb88cb355e93558851d7f6a73dfa2d8233a /net-wireless/wpa_supplicant
parentsys-libs/libcxx: Remove stale <pkg/> ref (diff)
downloadgentoo-a460ecf5f4c7aa8b59149d553774ff95284b9c30.tar.gz
gentoo-a460ecf5f4c7aa8b59149d553774ff95284b9c30.tar.bz2
gentoo-a460ecf5f4c7aa8b59149d553774ff95284b9c30.zip
net-wireless/wpa_supplicant: fix bug #692846
also disable more things properly when the use flag isn't set also harmonize release and live ebuilds also fix multiple QA warnings Package-Manager: Portage-2.3.88, Repoman-2.3.20 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'net-wireless/wpa_supplicant')
-rw-r--r--net-wireless/wpa_supplicant/metadata.xml5
-rw-r--r--net-wireless/wpa_supplicant/wpa_supplicant-2.9-r2.ebuild (renamed from net-wireless/wpa_supplicant/wpa_supplicant-2.9-r1.ebuild)48
-rw-r--r--net-wireless/wpa_supplicant/wpa_supplicant-9999.ebuild32
3 files changed, 56 insertions, 29 deletions
diff --git a/net-wireless/wpa_supplicant/metadata.xml b/net-wireless/wpa_supplicant/metadata.xml
index a52a722509e2..743ca1d2c5b8 100644
--- a/net-wireless/wpa_supplicant/metadata.xml
+++ b/net-wireless/wpa_supplicant/metadata.xml
@@ -7,12 +7,15 @@
</maintainer>
<use>
<flag name="ap">Add support for access point mode</flag>
+ <flag name="broadcom-sta">Flag to help users disable features not supported by broadcom-sta driver</flag>
<flag name="eap-sim">Add support for EAP-SIM authentication algorithm</flag>
- <flag name="eapol_test">Build and install eapol_test binary</flag>
+ <flag name="eapol-test">Build and install eapol_test binary</flag>
<flag name="fasteap">Add support for FAST-EAP authentication algorithm</flag>
<flag name="fils">Add support for Fast Initial Link Setup (802.11ai)</flag>
<flag name="hs2-0">Add support for 802.11u and Passpoint for HotSpot 2.0</flag>
<flag name="macsec">Add support for wired macsec</flag>
+ <flag name="mbo">Add support Multiband Operation</flag>
+ <flag name="mesh">Add support for mesh mode</flag>
<flag name="p2p">Add support for Wi-Fi Direct mode</flag>
<flag name="ps3">Add support for ps3 hypervisor driven gelic wifi</flag>
<flag name="privsep">Enable wpa_priv privledge separation binary</flag>
diff --git a/net-wireless/wpa_supplicant/wpa_supplicant-2.9-r1.ebuild b/net-wireless/wpa_supplicant/wpa_supplicant-2.9-r2.ebuild
index 8cfb6d7ecd1e..0c3b8ae72bc9 100644
--- a/net-wireless/wpa_supplicant/wpa_supplicant-2.9-r1.ebuild
+++ b/net-wireless/wpa_supplicant/wpa_supplicant-2.9-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit eutils qmake-utils systemd toolchain-funcs readme.gentoo-r1
+inherit eutils qmake-utils systemd toolchain-funcs readme.gentoo-r1 desktop
DESCRIPTION="IEEE 802.1X/WPA supplicant for secure wireless transfers"
HOMEPAGE="https://w1.fi/wpa_supplicant/"
@@ -18,7 +18,7 @@ else
fi
SLOT="0"
-IUSE="ap bindist dbus eap-sim eapol_test fasteap +fils +hs2-0 libressl macsec p2p privsep ps3 qt5 readline selinux smartcard tdls uncommon-eap-types wimax wps kernel_linux kernel_FreeBSD"
+IUSE="ap bindist broadcom-sta dbus eap-sim eapol-test fasteap +fils +hs2-0 libressl macsec +mbo +mesh p2p privsep ps3 qt5 readline selinux smartcard tdls uncommon-eap-types wimax wps kernel_linux kernel_FreeBSD"
# CONFIG_PRIVSEP=y does not have sufficient support for the new driver
# interface functions used for MACsec, so this combination cannot be used
@@ -26,6 +26,7 @@ IUSE="ap bindist dbus eap-sim eapol_test fasteap +fils +hs2-0 libressl macsec p2
REQUIRED_USE="
macsec? ( !privsep )
privsep? ( !macsec )
+ broadcom-sta? ( !fils !mesh !mbo )
"
CDEPEND="dbus? ( sys-apps/dbus )
@@ -150,7 +151,6 @@ src_configure() {
Kconfig_style_config TLSV11
Kconfig_style_config TLSV12
Kconfig_style_config GETRANDOM
- Kconfig_style_config MBO
# Basic authentication methods
# NOTE: we don't set GPSK or SAKE as they conflict
@@ -160,6 +160,8 @@ src_configure() {
Kconfig_style_config EAP_OTP
Kconfig_style_config EAP_PAX
Kconfig_style_config EAP_PSK
+ Kconfig_style_config EAP_TLV
+ Kconfig_style_config EAP_EXE
Kconfig_style_config IEEE8021X_EAPOL
Kconfig_style_config PKCS12
Kconfig_style_config PEERKEY
@@ -184,7 +186,7 @@ src_configure() {
Kconfig_style_config CTRL_IFACE_DBUS_INTRO n
fi
- if use eapol_test ; then
+ if use eapol-test ; then
Kconfig_style_config EAPOL_TEST
fi
@@ -197,6 +199,12 @@ src_configure() {
Kconfig_style_config HS20
fi
+ if use mbo ; then
+ Kconfig_style_config MBO
+ else
+ Kconfig_style_config MBO n
+ fi
+
if use uncommon-eap-types; then
Kconfig_style_config EAP_GPSK
Kconfig_style_config EAP_SAKE
@@ -233,16 +241,17 @@ src_configure() {
Kconfig_style_config FILS
Kconfig_style_config FILS_SK_PFS
fi
- # Enabling mesh networks.
- Kconfig_style_config MESH
+ if use mesh; then
+ Kconfig_style_config MESH
+ else
+ Kconfig_style_config MESH n
+ fi
#WPA3
Kconfig_style_config OWE
Kconfig_style_config SAE
Kconfig_style_config DPP
- Kconfig_style_config SUITEB192
- fi
- if ! use bindist && ! use libressl; then
Kconfig_style_config SUITEB
+ Kconfig_style_config SUITEB192
fi
if use smartcard ; then
@@ -295,12 +304,20 @@ src_configure() {
Kconfig_style_config WPS_NFC
else
Kconfig_style_config WPS n
+ Kconfig_style_config WPS2 n
+ Kconfig_style_config WPS_UFD n
+ Kconfig_style_config WPS_ER n
+ Kconfig_style_config WPS_UPNP n
+ Kconfig_style_config WPS_NFC n
fi
# Wi-Fi Direct (WiDi)
if use p2p ; then
Kconfig_style_config P2P
Kconfig_style_config WIFI_DISPLAY
+ else
+ Kconfig_style_config P2P n
+ Kconfig_style_config WIFI_DISPLAY n
fi
# Access Point Mode
@@ -355,7 +372,7 @@ src_compile() {
emake -C "${S}"/wpa_gui-qt4
fi
- if use eapol_test ; then
+ if use eapol-test ; then
emake eapol_test
fi
}
@@ -414,7 +431,7 @@ src_install() {
systemd_dounit systemd/wpa_supplicant.service
fi
- if use eapol_test ; then
+ if use eapol-test ; then
dobin eapol_test
fi
@@ -438,11 +455,6 @@ pkg_postinst() {
ewarn "This is incredibly undesirable"
fi
fi
- if use libressl; then
- ewarn "Libressl doesn't support SUITEB (part of WPA3)"
- ewarn "but it does support SUITEB192 (the upgraded strength version of the same)"
- ewarn "You probably don't care. Patches welcome"
- fi
# Mea culpa, feel free to remove that after some time --mgorny.
local fn
diff --git a/net-wireless/wpa_supplicant/wpa_supplicant-9999.ebuild b/net-wireless/wpa_supplicant/wpa_supplicant-9999.ebuild
index f73f675d9fde..3cb7b352a50f 100644
--- a/net-wireless/wpa_supplicant/wpa_supplicant-9999.ebuild
+++ b/net-wireless/wpa_supplicant/wpa_supplicant-9999.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit eutils qmake-utils systemd toolchain-funcs readme.gentoo-r1
+inherit eutils qmake-utils systemd toolchain-funcs readme.gentoo-r1 desktop
DESCRIPTION="IEEE 802.1X/WPA supplicant for secure wireless transfers"
HOMEPAGE="https://w1.fi/wpa_supplicant/"
@@ -18,7 +18,7 @@ else
fi
SLOT="0"
-IUSE="ap bindist dbus eap-sim eapol_test fasteap +fils +hs2-0 libressl macsec p2p privsep ps3 qt5 readline selinux smartcard tdls uncommon-eap-types wimax wps kernel_linux kernel_FreeBSD"
+IUSE="ap bindist broadcom-sta dbus eap-sim eapol-test fasteap +fils +hs2-0 libressl macsec +mbo +mesh p2p privsep ps3 qt5 readline selinux smartcard tdls uncommon-eap-types wimax wps kernel_linux kernel_FreeBSD"
# CONFIG_PRIVSEP=y does not have sufficient support for the new driver
# interface functions used for MACsec, so this combination cannot be used
@@ -26,6 +26,7 @@ IUSE="ap bindist dbus eap-sim eapol_test fasteap +fils +hs2-0 libressl macsec p2
REQUIRED_USE="
macsec? ( !privsep )
privsep? ( !macsec )
+ broadcom-sta? ( !fils !mesh !mbo )
"
CDEPEND="dbus? ( sys-apps/dbus )
@@ -147,7 +148,6 @@ src_configure() {
Kconfig_style_config TLSV11
Kconfig_style_config TLSV12
Kconfig_style_config GETRANDOM
- Kconfig_style_config MBO
# Basic authentication methods
# NOTE: we don't set GPSK or SAKE as they conflict
@@ -183,7 +183,7 @@ src_configure() {
Kconfig_style_config CTRL_IFACE_DBUS_INTRO n
fi
- if use eapol_test ; then
+ if use eapol-test ; then
Kconfig_style_config EAPOL_TEST
fi
@@ -196,6 +196,12 @@ src_configure() {
Kconfig_style_config HS20
fi
+ if use mbo ; then
+ Kconfig_style_config MBO
+ else
+ Kconfig_style_config MBO n
+ fi
+
if use uncommon-eap-types; then
Kconfig_style_config EAP_GPSK
Kconfig_style_config EAP_SAKE
@@ -232,8 +238,11 @@ src_configure() {
Kconfig_style_config FILS
Kconfig_style_config FILS_SK_PFS
fi
- # Enabling mesh networks.
- Kconfig_style_config MESH
+ if use mesh; then
+ Kconfig_style_config MESH
+ else
+ Kconfig_style_config MESH n
+ fi
#WPA3
Kconfig_style_config OWE
Kconfig_style_config SAE
@@ -303,6 +312,9 @@ src_configure() {
if use p2p ; then
Kconfig_style_config P2P
Kconfig_style_config WIFI_DISPLAY
+ else
+ Kconfig_style_config P2P n
+ Kconfig_style_config WIFI_DISPLAY n
fi
# Access Point Mode
@@ -357,7 +369,7 @@ src_compile() {
emake -C "${S}"/wpa_gui-qt4
fi
- if use eapol_test ; then
+ if use eapol-test ; then
emake eapol_test
fi
}
@@ -397,7 +409,7 @@ src_install() {
into /usr
dobin wpa_gui-qt4/wpa_gui
doicon wpa_gui-qt4/icons/wpa_gui.svg
- make_desktop_entry wpa_gui "WPA Supplicant Administration GUI" "wpa_gui" "Qt;Network;"
+ domenu wpa_gui-qt4/wpa_gui.desktop
else
rm "${ED}"/usr/share/man/man8/wpa_gui.8
fi
@@ -416,7 +428,7 @@ src_install() {
systemd_dounit systemd/wpa_supplicant.service
fi
- if use eapol_test ; then
+ if use eapol-test ; then
dobin eapol_test
fi