summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-11-06 04:37:36 +0000
committerSam James <sam@gentoo.org>2021-11-06 04:37:36 +0000
commit94d7465f40784afb9ac634314540a327a69a443a (patch)
treee9fbd8f07e9889c8e8183431a14e471362147e84 /net-vpn/openvpn
parentnet-dialup/lrzsz: use 'emake', not 'make' (diff)
downloadgentoo-94d7465f40784afb9ac634314540a327a69a443a.tar.gz
gentoo-94d7465f40784afb9ac634314540a327a69a443a.tar.bz2
gentoo-94d7465f40784afb9ac634314540a327a69a443a.zip
net-vpn/openvpn: use 'emake', not 'make'
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-vpn/openvpn')
-rw-r--r--net-vpn/openvpn/openvpn-2.5.2-r2.ebuild14
-rw-r--r--net-vpn/openvpn/openvpn-9999.ebuild15
2 files changed, 21 insertions, 8 deletions
diff --git a/net-vpn/openvpn/openvpn-2.5.2-r2.ebuild b/net-vpn/openvpn/openvpn-2.5.2-r2.ebuild
index e09e6ac634dc..f3520516410b 100644
--- a/net-vpn/openvpn/openvpn-2.5.2-r2.ebuild
+++ b/net-vpn/openvpn/openvpn-2.5.2-r2.ebuild
@@ -72,6 +72,7 @@ pkg_setup() {
src_prepare() {
default
+
eautoreconf
}
@@ -83,6 +84,7 @@ src_configure() {
$(use_enable pkcs11)
)
fi
+
myeconfargs+=(
$(use_enable inotify async-push)
--with-crypto-library=$(usex mbedtls mbedtls openssl)
@@ -94,6 +96,7 @@ src_configure() {
$(use_enable down-root plugin-down-root)
$(use_enable systemd)
)
+
SYSTEMD_UNIT_DIR=$(systemd_get_systemunitdir) \
TMPFILES_DIR="/usr/lib/tmpfiles.d" \
IPROUTE=$(usex iproute2 '/bin/ip' '') \
@@ -103,9 +106,12 @@ src_configure() {
src_test() {
local -x RUN_SUDO=false
- make check || die "top-level tests failed"
+ elog "Running top-level tests"
+ emake check
+
pushd tests/unit_tests &>/dev/null || die
- make check || die "unit tests failed"
+ elog "Running unit tests"
+ emake check
popd &>/dev/null || die
}
@@ -142,12 +148,12 @@ src_install() {
pkg_postinst() {
tmpfiles_process openvpn.conf
- if use x64-macos; then
+ if use x64-macos ; then
elog "You might want to install tuntaposx for TAP interface support:"
elog "http://tuntaposx.sourceforge.net"
fi
- if systemd_is_booted || has_version sys-apps/systemd; then
+ if systemd_is_booted || has_version sys-apps/systemd ; then
elog "In order to use OpenVPN with systemd please use the correct systemd service file."
elog ""
elog "server:"
diff --git a/net-vpn/openvpn/openvpn-9999.ebuild b/net-vpn/openvpn/openvpn-9999.ebuild
index d5d643edb2fb..1dfab6f2d9f7 100644
--- a/net-vpn/openvpn/openvpn-9999.ebuild
+++ b/net-vpn/openvpn/openvpn-9999.ebuild
@@ -15,7 +15,7 @@ if [[ ${PV} == "9999" ]]; then
inherit git-r3
else
SRC_URI="https://build.openvpn.net/downloads/releases/${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
fi
LICENSE="GPL-2"
@@ -72,6 +72,7 @@ pkg_setup() {
src_prepare() {
default
+
eautoreconf
}
@@ -83,6 +84,7 @@ src_configure() {
$(use_enable pkcs11)
)
fi
+
myeconfargs+=(
$(use_enable inotify async-push)
--with-crypto-library=$(usex mbedtls mbedtls openssl)
@@ -94,6 +96,7 @@ src_configure() {
$(use_enable down-root plugin-down-root)
$(use_enable systemd)
)
+
SYSTEMD_UNIT_DIR=$(systemd_get_systemunitdir) \
TMPFILES_DIR="/usr/lib/tmpfiles.d" \
IPROUTE=$(usex iproute2 '/bin/ip' '') \
@@ -103,9 +106,12 @@ src_configure() {
src_test() {
local -x RUN_SUDO=false
- make check || die "top-level tests failed"
+ elog "Running top-level tests"
+ emake check
+
pushd tests/unit_tests &>/dev/null || die
- make check || die "unit tests failed"
+ elog "Running unit tests"
+ emake check
popd &>/dev/null || die
}
@@ -129,7 +135,8 @@ src_install() {
# install examples, controlled by the respective useflag
if use examples ; then
- # dodoc does not supportly support directory traversal, #15193
+ # (is the below comment relevant anymore?)
+ ## dodoc does not supportly support directory traversal, #15193
docinto examples
dodoc -r sample contrib
fi