summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-p2p/nap
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-p2p/nap')
-rw-r--r--net-p2p/nap/Manifest1
-rw-r--r--net-p2p/nap/metadata.xml5
-rw-r--r--net-p2p/nap/nap-1.5.4-r1.ebuild34
3 files changed, 40 insertions, 0 deletions
diff --git a/net-p2p/nap/Manifest b/net-p2p/nap/Manifest
new file mode 100644
index 000000000000..df6dd76d6a07
--- /dev/null
+++ b/net-p2p/nap/Manifest
@@ -0,0 +1 @@
+DIST nap-1.5.4.tar.gz 321353 SHA256 55c7527951fb9408a133b4c3302df6096de6bc4e0511b3654d820ce455694db2 SHA512 dcb0db523f7e3eeb910b6cfd9768a562b0b383ea33a236a144e0b3299c2cd9e89c15165a8e28525bc1d94d84f2b8c5d41ec54102f1f2ce3aca2cdc022c81944d WHIRLPOOL fa04300bca97d82478da861c9bc071eabbf5adffdc454ba31b915680669e477d74aec4d1ccd894dc15922f5efc268759d34ceff2177ffd7a34f8e11e70736161
diff --git a/net-p2p/nap/metadata.xml b/net-p2p/nap/metadata.xml
new file mode 100644
index 000000000000..aa0f3664825f
--- /dev/null
+++ b/net-p2p/nap/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-p2p</herd>
+</pkgmetadata>
diff --git a/net-p2p/nap/nap-1.5.4-r1.ebuild b/net-p2p/nap/nap-1.5.4-r1.ebuild
new file mode 100644
index 000000000000..5d4a33524d83
--- /dev/null
+++ b/net-p2p/nap/nap-1.5.4-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+DESCRIPTION="Console Napster/OpenNap client"
+HOMEPAGE="http://www.mathstat.dal.ca/~selinger/nap/"
+SRC_URI="http://www.mathstat.dal.ca/~selinger/nap/dist/${P}.tar.gz"
+
+LICENSE="nap GPL-2+ LGPL-2+"
+SLOT="0"
+KEYWORDS="ppc x86"
+IUSE=""
+RESTRICT="bindist"
+
+src_unpack() {
+ unpack ${A}
+
+ # Install the docs in the right dir
+ sed -i -e "s~\$(prefix)/doc/nap~\$(prefix)/share/doc/${P}~g" \
+ "${S}"/doc/Makefile.in
+}
+
+src_compile() {
+ ./configure --prefix="${D}"/usr --mandir="${D}"/usr/share/man || die "configure problem"
+ emake CC="$(tc-getCC)" || die "compile problem"
+}
+
+src_install() {
+ emake install || die "install problem"
+
+ dodoc AUTHORS COPYRIGHT ChangeLog NEWS README
+}