summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-nds/adtool
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-nds/adtool')
-rw-r--r--net-nds/adtool/Manifest1
-rw-r--r--net-nds/adtool/adtool-1.3.3.ebuild34
-rw-r--r--net-nds/adtool/files/adtool-1.3.3-bfr-overflow.patch18
-rw-r--r--net-nds/adtool/metadata.xml10
4 files changed, 63 insertions, 0 deletions
diff --git a/net-nds/adtool/Manifest b/net-nds/adtool/Manifest
new file mode 100644
index 000000000000..74f57e0cd866
--- /dev/null
+++ b/net-nds/adtool/Manifest
@@ -0,0 +1 @@
+DIST adtool-1.3.3.tar.gz 334767 SHA256 9658ed2a4869304a094b0dc73d994940271f7ff64e481093893bf25c95bc95ab SHA512 800a9fd19481b2c986991c27674e24b40bd6f4d58d7cbcf94532acb88f6c36de1f18d4165d6a2dcffd7d5baeac86aaf6f0ff1ef1b46d93ffc28b826b3d857251 WHIRLPOOL f5d36bf4cd62abfe2488b27b9cc08d439d199d3b9e81693c517334ef9937de362f235c9d0c1604bbcc08c54d223de24282ef508d7e615f47be3f3508e1ae1e59
diff --git a/net-nds/adtool/adtool-1.3.3.ebuild b/net-nds/adtool/adtool-1.3.3.ebuild
new file mode 100644
index 000000000000..39c805f9e9dc
--- /dev/null
+++ b/net-nds/adtool/adtool-1.3.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils
+
+DESCRIPTION="Utility for Active Directory administration"
+HOMEPAGE="http://gp2x.org/adtool/"
+SRC_URI="http://gp2x.org/adtool/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="ssl"
+
+DEPEND="
+ net-nds/openldap
+ ssl? ( dev-libs/openssl )"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-bfr-overflow.patch )
+
+src_prepare() {
+ # automake-1.13
+ mv configure.{in,ac} || die
+ sed \
+ -e '/libactive_directory.a/s:@top_srcdir@:@top_builddir@:' \
+ -i src/tools/Makefile.am || die
+ autotools-utils_src_prepare
+}
diff --git a/net-nds/adtool/files/adtool-1.3.3-bfr-overflow.patch b/net-nds/adtool/files/adtool-1.3.3-bfr-overflow.patch
new file mode 100644
index 000000000000..f4e7ef0be88b
--- /dev/null
+++ b/net-nds/adtool/files/adtool-1.3.3-bfr-overflow.patch
@@ -0,0 +1,18 @@
+ src/lib/active_directory.c | 4 ++--
+ 1 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/lib/active_directory.c b/src/lib/active_directory.c
+index 1eacf5f..d4e1ca6 100644
+--- a/src/lib/active_directory.c
++++ b/src/lib/active_directory.c
+@@ -172,8 +172,8 @@ char *dn2domain(char *dn) {
+ exp_dn=ldap_explode_dn(dn, 0);
+ for(i=0; exp_dn[i]!=NULL; i++) {
+ if(!strncasecmp("dc=", exp_dn[i], 3)) {
+- strncat(dc, exp_dn[i]+3, 1024);
+- strncat(dc, ".", 1024);
++ strncat(dc, exp_dn[i]+3, 1024 - 1);
++ strncat(dc, ".", 1024 - 1);
+ }
+ }
+ ldap_value_free(exp_dn);
diff --git a/net-nds/adtool/metadata.xml b/net-nds/adtool/metadata.xml
new file mode 100644
index 000000000000..25e348aacfc8
--- /dev/null
+++ b/net-nds/adtool/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+adtool is a unix command line utility for Active Directory administration, through ldap repository management.
+</longdescription>
+</pkgmetadata>