summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-10-07 02:17:36 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-10-07 02:33:12 -0400
commitc396b61cbc93c78290a0bbd6ec6cc788b2e5f79d (patch)
tree177b90de18965057a5f4dd46cc7172b47e86ea57 /net-misc/rinetd
parentdev-libs/libstroke: fix build with upcoming clang16 (diff)
downloadgentoo-c396b61cbc93c78290a0bbd6ec6cc788b2e5f79d.tar.gz
gentoo-c396b61cbc93c78290a0bbd6ec6cc788b2e5f79d.tar.bz2
gentoo-c396b61cbc93c78290a0bbd6ec6cc788b2e5f79d.zip
net-misc/rinetd: EAPI6->8, remove dead urls, fix license
wrt sed, removing lets implicit rules do their thing and no need to insert variables also move html file in html/ technically license still need GPL-2 due to init script Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'net-misc/rinetd')
-rw-r--r--net-misc/rinetd/rinetd-0.62-r2.ebuild29
1 files changed, 17 insertions, 12 deletions
diff --git a/net-misc/rinetd/rinetd-0.62-r2.ebuild b/net-misc/rinetd/rinetd-0.62-r2.ebuild
index 527f67d7834f..d1db674c0bc7 100644
--- a/net-misc/rinetd/rinetd-0.62-r2.ebuild
+++ b/net-misc/rinetd/rinetd-0.62-r2.ebuild
@@ -1,33 +1,38 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=8
inherit toolchain-funcs
DESCRIPTION="redirects TCP connections from one IP address and port to another"
-HOMEPAGE="http://www.boutell.com/rinetd/"
-SRC_URI="http://www.boutell.com/rinetd/http/rinetd.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+S="${WORKDIR}/${PN}"
-LICENSE="GPL-2"
+LICENSE="GPL-2+ GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE=""
-
-S=${WORKDIR}/${PN}
src_prepare() {
default
- sed -i -e "s:gcc:$(tc-getCC) \$(CFLAGS) \$(LDFLAGS):" Makefile
+
+ sed -i '/gcc rinetd/d' Makefile || die
}
src_compile() {
- emake CFLAGS="${CFLAGS} -DLINUX" LDFLAGS="${LDFLAGS}"
+ tc-export CC
+
+ emake CFLAGS="${CFLAGS} -DLINUX"
}
src_install() {
dosbin rinetd
- newinitd "${FILESDIR}"/rinetd.rc rinetd
doman rinetd.8
- dodoc CHANGES README index.html
+ einstalldocs
+
+ docinto html
+ dodoc index.html
+
+ newinitd "${FILESDIR}"/rinetd.rc rinetd
}