summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2022-09-29 09:43:36 +0100
committerMatthew Smith <matthew@gentoo.org>2022-09-29 09:43:36 +0100
commite5db6fcb9be32c83b9614457f91ba62e3f7a436f (patch)
tree982af3f2e5b05aec9aa026b420efbef1b9e5b4fa /net-misc/putty
parentnet-misc/putty: fix USE=-gssapi build (diff)
downloadgentoo-e5db6fcb9be32c83b9614457f91ba62e3f7a436f.tar.gz
gentoo-e5db6fcb9be32c83b9614457f91ba62e3f7a436f.tar.bz2
gentoo-e5db6fcb9be32c83b9614457f91ba62e3f7a436f.zip
net-misc/putty: update live ebuild
* Remove USE=ipv6 * Fix USE=-gssapi build Signed-off-by: Matthew Smith <matthew@gentoo.org>
Diffstat (limited to 'net-misc/putty')
-rw-r--r--net-misc/putty/putty-9999.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/net-misc/putty/putty-9999.ebuild b/net-misc/putty/putty-9999.ebuild
index be3a4064accf..737dcfe68966 100644
--- a/net-misc/putty/putty-9999.ebuild
+++ b/net-misc/putty/putty-9999.ebuild
@@ -12,12 +12,12 @@ if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="https://git.tartarus.org/simon/putty.git"
else
SRC_URI+=" https://the.earth.li/~sgtatham/${PN}/${PV}/${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+ KEYWORDS="~alpha amd64 ~arm64 ~hppa ppc ppc64 sparc x86"
fi
LICENSE="MIT"
SLOT="0"
-IUSE="debug doc +gtk gtk2 ipv6 gssapi"
+IUSE="debug doc +gtk gtk2 gssapi"
RDEPEND="
!net-misc/pssh
@@ -44,6 +44,11 @@ REQUIRED_USE="
gtk2? ( gtk )
"
+PATCHES=(
+ # Bug #873355
+ "${FILESDIR}"/putty-0.77-nogssapi.patch
+)
+
src_unpack() {
[[ ${PV} == *9999 ]] && git-r3_src_unpack
default
@@ -55,7 +60,7 @@ src_configure() {
-DPUTTY_DEBUG="$(usex debug)"
-DPUTTY_GSSAPI="$(usex gssapi DYNAMIC OFF)"
-DPUTTY_GTK_VERSION=$(usex gtk $(usex gtk2 2 3 ) '')
- -DPUTTY_IPV6="$(usex ipv6)"
+ -DPUTTY_IPV6=yes
)
cmake_src_configure
}