summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2023-04-26 23:56:06 -0500
committerWilliam Hubbs <williamh@gentoo.org>2023-04-26 23:56:16 -0500
commitb9f61c684de73b4c7c7f3e5552b29b5bb9b01da8 (patch)
tree090ee7e238466253f808735db8ffa13311f35021 /net-libs
parentnet-libs/nodejs: style for 20.0.0 (diff)
downloadgentoo-b9f61c684de73b4c7c7f3e5552b29b5bb9b01da8.tar.gz
gentoo-b9f61c684de73b4c7c7f3e5552b29b5bb9b01da8.tar.bz2
gentoo-b9f61c684de73b4c7c7f3e5552b29b5bb9b01da8.zip
net-libs/nodejs: sync src_test for 16.20.0 and 18.16.0
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/nodejs/nodejs-16.20.0.ebuild22
-rw-r--r--net-libs/nodejs/nodejs-18.16.0.ebuild23
2 files changed, 20 insertions, 25 deletions
diff --git a/net-libs/nodejs/nodejs-16.20.0.ebuild b/net-libs/nodejs/nodejs-16.20.0.ebuild
index f7e831387ba3..674133fd6675 100644
--- a/net-libs/nodejs/nodejs-16.20.0.ebuild
+++ b/net-libs/nodejs/nodejs-16.20.0.ebuild
@@ -93,13 +93,6 @@ src_prepare() {
# We need to disable mprotect on two files when it builds Bug 694100.
use pax-kernel && PATCHES+=( "${FILESDIR}"/${PN}-16.4.2-paxmarking.patch )
- # All this test does is check if the npm CLI produces warnings of any sort,
- # failing if it does. Overkill, much? Especially given one possible warning
- # is that there is a newer version of npm available upstream (yes, it does
- # use the network if available), thus making it a real possibility for this
- # test to begin failing one day even though it was fine before.
- rm -f test/parallel/test-release-npm.js
-
default
}
@@ -222,11 +215,16 @@ src_install() {
}
src_test() {
- if has usersandbox ${FEATURES}; then
- rm -f "${S}"/test/parallel/test-fs-mkdir.js
- ewarn "You are emerging ${PN} with 'usersandbox' enabled. Excluding tests known to fail in this mode." \
- "For full test coverage, emerge =${CATEGORY}/${PF} with 'FEATURES=-usersandbox'."
- fi
+ local drop_tests=(
+ test/parallel/test-dns-setserver-when-querying.js
+ test/parallel/test-fs-mkdir.js
+ test/parallel/test-fs-utimes-y2K38.js
+ test/parallel/test-release-npm.js
+ test/parallel/test-socket-write-after-fin-error.js
+ test/parallel/test-strace-openat-openssl.js
+ test/sequential/test-util-debug.js
+ )
+ rm "${drop_tests[@]}" || die "disabling tests failed"
out/${BUILDTYPE}/cctest || die
"${EPYTHON}" tools/test.py --mode=${BUILDTYPE,,} --flaky-tests=dontcare -J message parallel sequential || die
diff --git a/net-libs/nodejs/nodejs-18.16.0.ebuild b/net-libs/nodejs/nodejs-18.16.0.ebuild
index f9a22254f9d2..8d12026d01b2 100644
--- a/net-libs/nodejs/nodejs-18.16.0.ebuild
+++ b/net-libs/nodejs/nodejs-18.16.0.ebuild
@@ -110,13 +110,6 @@ src_prepare() {
# We need to disable mprotect on two files when it builds Bug 694100.
use pax-kernel && PATCHES+=( "${FILESDIR}"/${P}-paxmarking.patch )
- # All this test does is check if the npm CLI produces warnings of any sort,
- # failing if it does. Overkill, much? Especially given one possible warning
- # is that there is a newer version of npm available upstream (yes, it does
- # use the network if available), thus making it a real possibility for this
- # test to begin failing one day even though it was fine before.
- rm -f test/parallel/test-release-npm.js
-
default
}
@@ -240,12 +233,16 @@ src_install() {
}
src_test() {
- rm -f "${S}"/tests/parallel/test-dns-setserver-when-querying.js
- if has usersandbox ${FEATURES}; then
- rm -f "${S}"/test/parallel/test-fs-mkdir.js
- ewarn "You are emerging ${PN} with 'usersandbox' enabled. Excluding tests known to fail in this mode." \
- "For full test coverage, emerge =${CATEGORY}/${PF} with 'FEATURES=-usersandbox'."
- fi
+ local drop_tests=(
+ test/parallel/test-dns-setserver-when-querying.js
+ test/parallel/test-fs-mkdir.js
+ test/parallel/test-fs-utimes-y2K38.js
+ test/parallel/test-release-npm.js
+ test/parallel/test-socket-write-after-fin-error.js
+ test/parallel/test-strace-openat-openssl.js
+ test/sequential/test-util-debug.js
+ )
+ rm "${drop_tests[@]}" || die "disabling tests failed"
out/${BUILDTYPE}/cctest || die
"${EPYTHON}" tools/test.py --mode=${BUILDTYPE,,} --flaky-tests=dontcare -J message parallel sequential || die