summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2023-04-26 22:29:00 -0500
committerWilliam Hubbs <williamh@gentoo.org>2023-04-26 22:29:44 -0500
commit5e272ad02172a48053d753b72df857bfc0bf9c62 (patch)
treea23cf7600e43f4469ce35dbb8e7f93e41d316519 /net-libs
parentsys-devel/gcc: Stabilize 10.4.1_p20230302 x86, #904932 (diff)
downloadgentoo-5e272ad02172a48053d753b72df857bfc0bf9c62.tar.gz
gentoo-5e272ad02172a48053d753b72df857bfc0bf9c62.tar.bz2
gentoo-5e272ad02172a48053d753b72df857bfc0bf9c62.zip
net-libs/nodejs: clean up src_test for 20.0.0
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/nodejs/nodejs-20.0.0.ebuild26
1 files changed, 10 insertions, 16 deletions
diff --git a/net-libs/nodejs/nodejs-20.0.0.ebuild b/net-libs/nodejs/nodejs-20.0.0.ebuild
index bf5712fb6e39..82214bdb90ec 100644
--- a/net-libs/nodejs/nodejs-20.0.0.ebuild
+++ b/net-libs/nodejs/nodejs-20.0.0.ebuild
@@ -108,14 +108,6 @@ src_prepare() {
# We need to disable mprotect on two files when it builds Bug 694100.
use pax-kernel && PATCHES+=( "${FILESDIR}"/${PN}-18.16.0-paxmarking.patch )
-
- # All this test does is check if the npm CLI produces warnings of any sort,
- # failing if it does. Overkill, much? Especially given one possible warning
- # is that there is a newer version of npm available upstream (yes, it does
- # use the network if available), thus making it a real possibility for this
- # test to begin failing one day even though it was fine before.
- rm -f test/parallel/test-release-npm.js
-
default
}
@@ -238,14 +230,16 @@ src_install() {
}
src_test() {
- rm \
- "${S}"/test/parallel/test-dns-setserver-when-querying.js \
- "${S}"/test/parallel/test-strace-openat-openssl.js || die
- if has usersandbox ${FEATURES}; then
- rm -f "${S}"/test/parallel/test-fs-mkdir.js
- ewarn "You are emerging ${PN} with 'usersandbox' enabled. Excluding tests known to fail in this mode." \
- "For full test coverage, emerge =${CATEGORY}/${PF} with 'FEATURES=-usersandbox'."
- fi
+ local drop_tests=(
+ test/parallel/test-dns-setserver-when-querying.js
+ test/parallel/test-fs-mkdir.js
+ test/parallel/test-fs-utimes-y2K38
+ test/parallel/test-release-npm.js
+ test/parallel/test-socket-write-after-fin-errorr.js
+ test/parallel/test-strace-openat-openssl.js
+ test/sequential/test-util-debug.js
+ )
+ rm "${drop_tests[@]}" || die "disabling tests failed"
out/${BUILDTYPE}/cctest || die
"${EPYTHON}" tools/test.py --mode=${BUILDTYPE,,} --flaky-tests=dontcare -J message parallel sequential || die