summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-02-08 15:27:43 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-02-08 15:27:43 +0100
commit9518033653e310f8c03473ae530c9eef6f5c42b8 (patch)
tree564806025222b20cfc1642aded077a1463fff93e /net-im
parentdev-python/spyder-terminal: drop version 1.2.0 (diff)
downloadgentoo-9518033653e310f8c03473ae530c9eef6f5c42b8.tar.gz
gentoo-9518033653e310f8c03473ae530c9eef6f5c42b8.tar.bz2
gentoo-9518033653e310f8c03473ae530c9eef6f5c42b8.zip
net-im/rocketchat-desktop-bin: add version 3.7.7
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/rocketchat-desktop-bin/Manifest1
-rw-r--r--net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.7.7.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/net-im/rocketchat-desktop-bin/Manifest b/net-im/rocketchat-desktop-bin/Manifest
index 74ec8da46d32..917427531e2b 100644
--- a/net-im/rocketchat-desktop-bin/Manifest
+++ b/net-im/rocketchat-desktop-bin/Manifest
@@ -1 +1,2 @@
DIST rocketchat-3.7.6.x86_64.rpm 72058676 BLAKE2B adc5dcf4366c679cda4e55fdcffefa3284f82e4e0616229ee3fbece519da81a9e71f24c3a04a7301d4b754292a09e09c13221c9e3b2ece65d2ba266655da5b43 SHA512 2d29cbdf9fa1e18eec7687edaea1ebe1b8005aa550df68cec91bb04f91f7fa65dd54b08b3de2ff1f5442fcf97d5b12e5d134123bed6c3e9cbaf6069ffc7a1e5f
+DIST rocketchat-3.7.7.x86_64.rpm 88749684 BLAKE2B 18e5f0cbd6a7dc7885f7a956a3ce8be6973c69120780fec96d1e12d9c4c25972d070b37d211947e744d3ca486d0117fe0754db232ad067b9a6f81a0185b44cff SHA512 3ebd78f20ae4a7a1458039f786444474f0fc52715f1238d5c1e806982d517d5582f963028f67abf279ba50f36212bb25e114346e4e8611a7546c61a17a3395a4
diff --git a/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.7.7.ebuild b/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.7.7.ebuild
new file mode 100644
index 000000000000..9953c00c594d
--- /dev/null
+++ b/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.7.7.ebuild
@@ -0,0 +1,55 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit rpm xdg
+
+DESCRIPTION="The Ultimate Open Source Web Chat Platform"
+HOMEPAGE="https://rocket.chat"
+SRC_URI="https://github.com/RocketChat/Rocket.Chat.Electron/releases/download/${PV}/rocketchat-${PV}.x86_64.rpm"
+
+KEYWORDS="-* ~amd64"
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ app-accessibility/at-spi2-atk:2
+ dev-libs/atk
+ dev-libs/expat
+ dev-libs/libappindicator
+ dev-libs/nspr
+ dev-libs/nss
+ media-fonts/noto-emoji
+ media-libs/alsa-lib
+ net-print/cups
+ sys-libs/glibc
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libnotify
+ x11-libs/libxcb
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libxkbcommon
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-libs/libXScrnSaver
+ x11-libs/pango
+"
+
+QA_PREBUILT="opt/Rocket.Chat/*"
+
+S="${WORKDIR}"
+
+src_install() {
+ # remove files useless for Gentoo
+ rm -r usr/lib || die
+ mv "${S}"/* "${ED}" || die
+}