summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-im/tkabber
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-im/tkabber')
-rw-r--r--net-im/tkabber/Manifest2
-rw-r--r--net-im/tkabber/metadata.xml9
-rw-r--r--net-im/tkabber/tkabber-0.11.1-r1.ebuild49
3 files changed, 60 insertions, 0 deletions
diff --git a/net-im/tkabber/Manifest b/net-im/tkabber/Manifest
new file mode 100644
index 000000000000..a30a25b13606
--- /dev/null
+++ b/net-im/tkabber/Manifest
@@ -0,0 +1,2 @@
+DIST tkabber-0.11.1.tar.gz 1026405 SHA256 9b12b726b609297254e7b0c5e500d415a6517bd6c951d53e7b429dca4a29bba7 SHA512 a28f4f9d2873366b4ffc6153e08d21e77dd0178fea13d894e79ce941779d8e4c97e48b572cbfd8c6c25c0636f6c8d8ca8d9b081aaccbb8e6d809de3228bdd268 WHIRLPOOL 07d45bed685067966cf514388831e6ad455ca3e15d9e1a90d03b03e8980dad9ce6376e891e6e453456f61819b592cd5db13d0eb351f99835b149cdf5bd724070
+DIST tkabber-plugins-0.11.1.tar.gz 615335 SHA256 ffad9602ef0383ffc209b6c8f235170270c98def3a5e4a5481714da6378eb94b
diff --git a/net-im/tkabber/metadata.xml b/net-im/tkabber/metadata.xml
new file mode 100644
index 000000000000..6b3ba828596a
--- /dev/null
+++ b/net-im/tkabber/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-im</herd>
+<longdescription>Tkabber is a Free and Open Source client for the Jabber instant messaging system. It's writen in Tcl/Tk, and works on many platforms.</longdescription>
+<use>
+ <flag name='plugins'>Enables installation the extra plugins</flag>
+</use>
+</pkgmetadata>
diff --git a/net-im/tkabber/tkabber-0.11.1-r1.ebuild b/net-im/tkabber/tkabber-0.11.1-r1.ebuild
new file mode 100644
index 000000000000..6140c6cc4c6b
--- /dev/null
+++ b/net-im/tkabber/tkabber-0.11.1-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="A jabber client written in Tcl/Tk"
+HOMEPAGE="http://tkabber.jabber.ru/"
+SRC_URI="
+ http://files.jabber.ru/tkabber/${P}.tar.gz
+ plugins? ( http://files.jabber.ru/tkabber/tkabber-plugins-${PV}.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="plugins ssl"
+
+DEPEND="
+ >=dev-lang/tcl-8.3.3:0=
+ >=dev-lang/tk-8.3.3:0=
+ >=dev-tcltk/tcllib-1.3
+ >=dev-tcltk/bwidget-1.3
+ >=dev-tcltk/tkXwin-1.0
+ >=dev-tcltk/tkimg-1.2
+ >=dev-tcltk/tktray-1.1
+ ssl? ( >=dev-tcltk/tls-1.4.1 )
+"
+RDEPEND="${DEPEND}"
+
+# Disabled because it depends on gpgme 0.3.x
+# crypt? ( >=dev-tcltk/tclgpgme-1.0 )
+
+src_compile() {
+ # dont run make, because the Makefile is broken with all=install
+ :
+}
+
+src_install() {
+ emake install DESTDIR="${D}" PREFIX=/usr \
+ DOCDIR="/usr/share/doc/${P}"
+
+ dodoc AUTHORS ChangeLog INSTALL README
+
+ if use plugins; then
+ cd "${WORKDIR}/tkabber-plugins-${PV}"
+ emake install DESTDIR="${D}" PREFIX=/usr \
+ DOCDIR="/usr/share/doc/${P}"
+ fi
+}