summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2018-11-03 15:37:14 +0100
committerMichał Górny <mgorny@gentoo.org>2018-11-03 22:58:33 +0100
commit890d21c407d92cfff49db52a782c0ae7e3acb52c (patch)
tree54bed6e5264d87e79c649fc4e12478b143566542 /net-im/libcommuni
parentnet-im/libcommuni: bump to version 3.5.0_p20180116 (diff)
downloadgentoo-890d21c407d92cfff49db52a782c0ae7e3acb52c.tar.gz
gentoo-890d21c407d92cfff49db52a782c0ae7e3acb52c.tar.bz2
gentoo-890d21c407d92cfff49db52a782c0ae7e3acb52c.zip
net-im/libcommuni: drop old version
Bug: https://bugs.gentoo.org/669866 Signed-off-by: Conrad Kostecki <conrad@kostecki.com> Package-Manager: Portage-2.3.51, Repoman-2.3.11 Closes: https://github.com/gentoo/gentoo/pull/10266 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-im/libcommuni')
-rw-r--r--net-im/libcommuni/Manifest1
-rw-r--r--net-im/libcommuni/files/uchardet.pri17
-rw-r--r--net-im/libcommuni/libcommuni-3.5.0.ebuild74
3 files changed, 0 insertions, 92 deletions
diff --git a/net-im/libcommuni/Manifest b/net-im/libcommuni/Manifest
index 8f4a37519e0c..7670d11af66f 100644
--- a/net-im/libcommuni/Manifest
+++ b/net-im/libcommuni/Manifest
@@ -1,2 +1 @@
-DIST libcommuni-3.5.0.tar.gz 646734 BLAKE2B 81e2c783625a0befe2d364423e862967bc76e8a66e9b5d7f2f94f46f46530d54b030bfd3a48d7877532092c607295cff5a77ecd8bb669112d53507a1ea18c5b0 SHA512 4d62f7e5edd32b9121f2b69d15a4022ad5d6cf7136dc48d0a1ca4bd413b3334533d7734d6939906fa3426f8db9bc255696107ecada19875c60ce59990b54dee4
DIST libcommuni-3.5.0_p20180116.tar.gz 471286 BLAKE2B 9f89a5eea2444c207b54f6b820c7cef89ff2e578d34ad751fdbfe558af2bcf0e52238ef63b244fb321baa7716c0119ca084c547cc0161a08b46af4c9d604dd0e SHA512 f7ce9c92acbd67b3d75b9b7fc1cef55796a3d44294024da591c7b0c21fc065ec484dbc6a4c83af96fcb6fd6e725a7b6ed4219bd09e2aa0de303b82d64741efba
diff --git a/net-im/libcommuni/files/uchardet.pri b/net-im/libcommuni/files/uchardet.pri
deleted file mode 100644
index d22393b76d26..000000000000
--- a/net-im/libcommuni/files/uchardet.pri
+++ /dev/null
@@ -1,17 +0,0 @@
-######################################################################
-# Communi
-######################################################################
-
-include(../pkg.pri)
-
-pkgExists(uchardet) {
- CONFIG += link_pkgconfig
- PKGCONFIG += uchardet
-}
-
-isEmpty(PKGCONFIG) {
- error("UChardet support has been enabled, but the UChardet installation has not been found. Did you emerged app-i18n/uchardet?")
-} else {
- LIBS += -luchardet
- INCPATH += -isystem /usr/include/uchardet
-}
diff --git a/net-im/libcommuni/libcommuni-3.5.0.ebuild b/net-im/libcommuni/libcommuni-3.5.0.ebuild
deleted file mode 100644
index 166369b11ab3..000000000000
--- a/net-im/libcommuni/libcommuni-3.5.0.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit qmake-utils
-
-DESCRIPTION="A cross-platform IRC framework written with Qt"
-HOMEPAGE="http://communi.github.io/"
-SRC_URI="https://github.com/communi/libcommuni/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="qml test +uchardet"
-
-# Compiling with USE="test" is currently broken with dev-libs/icu
-# See: https://github.com/communi/libcommuni/issues/60
-REQUIRED_USE="test? ( uchardet )"
-
-RDEPEND="dev-qt/qtcore:5
- dev-qt/qtdeclarative:5
- uchardet? ( app-i18n/uchardet )
- !uchardet? ( dev-libs/icu:= )"
-
-DEPEND="test? ( dev-qt/qttest:5 )
- ${RDEPEND}"
-
-RESTRICT="!test? ( test )"
-
-src_prepare() {
- default
-
- # Don't use bundled uchardet, use instead app-i18n/uchardet
- rm -rf src/3rdparty/uchardet-0.0.1/* || die
- cp "${FILESDIR}"/uchardet.pri src/3rdparty/uchardet-0.0.1/uchardet.pri || die
-}
-
-src_configure() {
- local myqmakeargs=( libcommuni.pro
- # Disables compile run-time benchmarks, as they don't make any sense
- -config no_benchmarks
- # Disables examples, as no new files are installed
- -config no_examples
- # Is needed for fixing the QA Notice: The following files contain insecure RUNPATHs
- -config no_rpath
- # Compile libcommuni always in Release mode, as Debug seems to do nothing
- -config release
- # Don't silence all compile messages
- -config verbose
- -config $(usex qml '' 'no_')install_imports
- -config $(usex qml '' 'no_')install_qml
- -config $(usex test '' 'no_')tests
- -config $(usex uchardet 'no_' '')icu
- -config $(usex uchardet '' 'no_')uchardet )
-
- eqmake5 "${myqmakeargs[@]}"
-}
-
-src_test() {
- # This is a hack to delete the existing LD_LIBRARY_PATH and set a new one,
- # otherwise a test will fail, because it uses the system installed lib instead of the new compiled lib.
- # The test will fail, when libcommuni is emerged with USE="uchardet" and
- # libcommuni is already installed with USE="-uchardat", or the other way around.
- find "${S}" -type f -name 'target_wrapper.sh' -exec sed -i -e "/.*LD_LIBRARY_PATH.*/d" {} \; || die
- local -x LD_LIBRARY_PATH="${S}/lib"
-
- default
-}
-
-src_install() {
- emake install INSTALL_ROOT="${D}"
- einstalldocs
-}