summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-07-27 23:26:54 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-07-28 03:53:17 +0200
commitc98875e1bcd07b1ac1d4d29be4208711de0b4ea7 (patch)
tree394cca965858dfb1986720cfdb0c0ef6409bcf95 /net-im/choqok
parentapp-editors/kile: kile-2.9.92_p20190716 snapshot bump, EAPI-7 (diff)
downloadgentoo-c98875e1bcd07b1ac1d4d29be4208711de0b4ea7.tar.gz
gentoo-c98875e1bcd07b1ac1d4d29be4208711de0b4ea7.tar.bz2
gentoo-c98875e1bcd07b1ac1d4d29be4208711de0b4ea7.zip
net-im/choqok: 1.6.0_p20190726 snapshot bump, EAPI-7
Contains fetched translations and handbook using upstream's tarme.rb Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-im/choqok')
-rw-r--r--net-im/choqok/Manifest1
-rw-r--r--net-im/choqok/choqok-1.6.0_p20190726.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/net-im/choqok/Manifest b/net-im/choqok/Manifest
index 6e55d2a05bb8..8c7fc28d989c 100644
--- a/net-im/choqok/Manifest
+++ b/net-im/choqok/Manifest
@@ -1 +1,2 @@
DIST choqok-1.6.0.tar.xz 1170748 BLAKE2B 11d1546d9bdad12012860ad4b21ea988d21ce822e7afb246d65b27b7fe28620f390ee97e00e594102b173ade304adcce208a9092909ab0d3801fecfdcc309e61 SHA512 78c03689e40978213f2f9462780fe47507a2778985d4d5b940cab004f0ac52becfa76d7dbaa886df958134c65b27255e49ac68ddbb2a434131fffe9ca9280cbc
+DIST choqok-1.6.0_p20190726.tar.xz 1184148 BLAKE2B c0c0459de362aa58337ab2d0c4ea03ff516de87bded48f73c47aa48ed791cfeb82c4085c4d333bff4ac1489a27e038da29d5419569aacb17366dc119e776dd67 SHA512 6471d9b37cc78fd3a14cc970512db3a8d44b21d49efb503917a57332f229c34ed735edfea6a74d6c25d8ab8d153331226effd677405d447c4a2faea3e396decf
diff --git a/net-im/choqok/choqok-1.6.0_p20190726.ebuild b/net-im/choqok/choqok-1.6.0_p20190726.ebuild
new file mode 100644
index 000000000000..a24edf12236e
--- /dev/null
+++ b/net-im/choqok/choqok-1.6.0_p20190726.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_HANDBOOK="forceoptional"
+inherit kde5
+
+DESCRIPTION="Free/Open Source micro-blogging client by KDE"
+HOMEPAGE="https://choqok.kde.org/"
+SRC_URI="https://dev.gentoo.org/~asturm/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~x86"
+IUSE="attica konqueror telepathy"
+
+DEPEND="
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kemoticons)
+ $(add_frameworks_dep kglobalaccel)
+ $(add_frameworks_dep kguiaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep knotifyconfig)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep sonnet)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetworkauth)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ app-crypt/qca[qt5(+)]
+ attica? ( $(add_frameworks_dep attica) )
+ konqueror? (
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kdewebkit)
+ >=dev-qt/qtwebkit-5.212.0_pre20180120:5
+ )
+ telepathy? ( net-libs/telepathy-qt[qt5(+)] )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package attica KF5Attica)
+ $(cmake-utils_use_find_package konqueror KF5Parts)
+ $(cmake-utils_use_find_package konqueror KF5WebKit)
+ $(cmake-utils_use_find_package telepathy TelepathyQt5)
+ )
+
+ kde5_src_configure
+}