summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-10 17:09:09 +0100
committerSam James <sam@gentoo.org>2022-10-10 17:18:46 +0100
commit8efc0e6128d196453d205efc85925349919535b6 (patch)
treef52195f7529dc310a82d80757a4182f390bdba45 /net-analyzer/wireshark
parentmedia-gfx/fotoxx: add 22.35 (diff)
downloadgentoo-8efc0e6128d196453d205efc85925349919535b6.tar.gz
gentoo-8efc0e6128d196453d205efc85925349919535b6.tar.bz2
gentoo-8efc0e6128d196453d205efc85925349919535b6.zip
net-analyzer/wireshark: Drop USE=plugin-ifdemo (which needs Qt 6)
No real point and we have too many USE flags for Wireshark anyway. Closes: https://bugs.gentoo.org/835962 Closes: https://bugs.gentoo.org/876304 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer/wireshark')
-rw-r--r--net-analyzer/wireshark/wireshark-4.0.0.ebuild9
-rw-r--r--net-analyzer/wireshark/wireshark-9999.ebuild9
2 files changed, 10 insertions, 8 deletions
diff --git a/net-analyzer/wireshark/wireshark-4.0.0.ebuild b/net-analyzer/wireshark/wireshark-4.0.0.ebuild
index 04f139078c66..34d454166c63 100644
--- a/net-analyzer/wireshark/wireshark-4.0.0.ebuild
+++ b/net-analyzer/wireshark/wireshark-4.0.0.ebuild
@@ -27,12 +27,13 @@ LICENSE="GPL-2"
SLOT="0/${PV}"
IUSE="androiddump bcg729 brotli +capinfos +captype ciscodump +dftest doc dpauxmon"
IUSE+=" +dumpcap +editcap +gui http2 ilbc kerberos libxml2 lto lua lz4 maxminddb"
-IUSE+=" +mergecap +minizip +netlink opus +plugins plugin-ifdemo +pcap qt6 +randpkt"
+IUSE+=" +mergecap +minizip +netlink opus +plugins +pcap qt6 +randpkt"
IUSE+=" +randpktdump +reordercap sbc selinux +sharkd smi snappy spandsp sshdump ssl"
IUSE+=" sdjournal test +text2pcap tfshark +tshark +udpdump zlib +zstd"
-REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )
- plugin-ifdemo? ( plugins )"
+REQUIRED_USE="
+ lua? ( ${LUA_REQUIRED_USE} )
+"
RESTRICT="!test? ( test )"
@@ -207,7 +208,7 @@ src_configure() {
-DENABLE_OPUS=$(usex opus)
-DENABLE_PCAP=$(usex pcap)
-DENABLE_PLUGINS=$(usex plugins)
- -DENABLE_PLUGIN_IFDEMO=$(usex plugin-ifdemo)
+ -DENABLE_PLUGIN_IFDEMO=OFF
-DENABLE_SBC=$(usex sbc)
-DENABLE_SMI=$(usex smi)
-DENABLE_SNAPPY=$(usex snappy)
diff --git a/net-analyzer/wireshark/wireshark-9999.ebuild b/net-analyzer/wireshark/wireshark-9999.ebuild
index 04f139078c66..34d454166c63 100644
--- a/net-analyzer/wireshark/wireshark-9999.ebuild
+++ b/net-analyzer/wireshark/wireshark-9999.ebuild
@@ -27,12 +27,13 @@ LICENSE="GPL-2"
SLOT="0/${PV}"
IUSE="androiddump bcg729 brotli +capinfos +captype ciscodump +dftest doc dpauxmon"
IUSE+=" +dumpcap +editcap +gui http2 ilbc kerberos libxml2 lto lua lz4 maxminddb"
-IUSE+=" +mergecap +minizip +netlink opus +plugins plugin-ifdemo +pcap qt6 +randpkt"
+IUSE+=" +mergecap +minizip +netlink opus +plugins +pcap qt6 +randpkt"
IUSE+=" +randpktdump +reordercap sbc selinux +sharkd smi snappy spandsp sshdump ssl"
IUSE+=" sdjournal test +text2pcap tfshark +tshark +udpdump zlib +zstd"
-REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )
- plugin-ifdemo? ( plugins )"
+REQUIRED_USE="
+ lua? ( ${LUA_REQUIRED_USE} )
+"
RESTRICT="!test? ( test )"
@@ -207,7 +208,7 @@ src_configure() {
-DENABLE_OPUS=$(usex opus)
-DENABLE_PCAP=$(usex pcap)
-DENABLE_PLUGINS=$(usex plugins)
- -DENABLE_PLUGIN_IFDEMO=$(usex plugin-ifdemo)
+ -DENABLE_PLUGIN_IFDEMO=OFF
-DENABLE_SBC=$(usex sbc)
-DENABLE_SMI=$(usex smi)
-DENABLE_SNAPPY=$(usex snappy)