summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRémi Cardona <remi@gentoo.org>2021-05-08 19:58:03 +0200
committerRémi Cardona <remi@gentoo.org>2021-05-08 19:58:44 +0200
commit87d9d3175dcbcb7b9aecb9a50bd896cdc8b6feab (patch)
treed5762752ec2cc7db0e67e1dbce97b63efca42439 /media-sound
parentdev-libs/libreport: Version bump to 2.15.1 (diff)
downloadgentoo-87d9d3175dcbcb7b9aecb9a50bd896cdc8b6feab.tar.gz
gentoo-87d9d3175dcbcb7b9aecb9a50bd896cdc8b6feab.tar.bz2
gentoo-87d9d3175dcbcb7b9aecb9a50bd896cdc8b6feab.zip
media-sound/mixxx: add patch to fix build with scons 4.1
Closes: https://bugs.gentoo.org/767838 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Rémi Cardona <remi@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/mixxx/files/mixxx-2.2.4-fix-scons-compat.patch24
-rw-r--r--media-sound/mixxx/mixxx-2.2.4.ebuild3
2 files changed, 26 insertions, 1 deletions
diff --git a/media-sound/mixxx/files/mixxx-2.2.4-fix-scons-compat.patch b/media-sound/mixxx/files/mixxx-2.2.4-fix-scons-compat.patch
new file mode 100644
index 000000000000..816d888a734d
--- /dev/null
+++ b/media-sound/mixxx/files/mixxx-2.2.4-fix-scons-compat.patch
@@ -0,0 +1,24 @@
+diff -dNur a/build/qt4.py b/build/qt4.py
+--- a/build/qt4.py 2020-05-15 23:26:10.000000000 +0200
++++ b/build/qt4.py 2021-03-17 11:13:58.867445884 +0100
+@@ -42,7 +42,7 @@
+ import SCons.Tool
+ import SCons.Util
+
+-class ToolQt4Warning(SCons.Warnings.Warning):
++class ToolQt4Warning(SCons.Warnings.SConsWarning):
+ pass
+
+ class GeneratedMocFileNotIncluded(ToolQt4Warning):
+diff -dNur a/build/qt5.py b/build/qt5.py
+--- a/build/qt5.py 2020-05-15 23:26:10.000000000 +0200
++++ b/build/qt5.py 2021-03-17 11:12:39.568689777 +0100
+@@ -43,7 +43,7 @@
+ import SCons.Tool
+ import SCons.Util
+
+-class ToolQt5Warning(SCons.Warnings.Warning):
++class ToolQt5Warning(SCons.Warnings.SConsWarning):
+ pass
+
+ class GeneratedMocFileNotIncluded(ToolQt5Warning):
diff --git a/media-sound/mixxx/mixxx-2.2.4.ebuild b/media-sound/mixxx/mixxx-2.2.4.ebuild
index 5e8d641266f4..da8c58ae71b9 100644
--- a/media-sound/mixxx/mixxx-2.2.4.ebuild
+++ b/media-sound/mixxx/mixxx-2.2.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -84,6 +84,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-2.0.0-docs.patch
"${FILESDIR}"/${PN}-2.2.3-qt-5.14.patch
"${FILESDIR}"/${PN}-2.2.4-metadata.patch
+ "${FILESDIR}"/${PN}-2.2.4-fix-scons-compat.patch
)
src_prepare() {