summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/hydrogen
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/hydrogen')
-rw-r--r--media-sound/hydrogen/Manifest1
-rw-r--r--media-sound/hydrogen/files/hydrogen-0.9.5-gcc47.patch27
-rw-r--r--media-sound/hydrogen/files/hydrogen-0.9.5-use_lrdf_pkgconfig.patch23
-rw-r--r--media-sound/hydrogen/hydrogen-0.9.5.ebuild69
-rw-r--r--media-sound/hydrogen/metadata.xml11
5 files changed, 131 insertions, 0 deletions
diff --git a/media-sound/hydrogen/Manifest b/media-sound/hydrogen/Manifest
new file mode 100644
index 000000000000..ba52e77ee698
--- /dev/null
+++ b/media-sound/hydrogen/Manifest
@@ -0,0 +1 @@
+DIST hydrogen-0.9.5.tar.gz 5239702 SHA256 963c73ef911ec9e7589e502d17df3b794dd027d7e99a36b5115a0bb51389d9c3 SHA512 0053f0cb301c541326b66eb416dc548561a973ade993c055e7bc2acbdf28732e627a605061c8b487644026510f5b8395946bba209ddfd19230c960e9bb619f97 WHIRLPOOL 326a6716b150103fd0f40e5277d775875083a255cbea8c34fd0392dde2642410c7830c55c1bba0f62322c2f0fc68f5ca85dfe3fd6a8231223112ad89e3709c9f
diff --git a/media-sound/hydrogen/files/hydrogen-0.9.5-gcc47.patch b/media-sound/hydrogen/files/hydrogen-0.9.5-gcc47.patch
new file mode 100644
index 000000000000..3ea43e36e3cd
--- /dev/null
+++ b/media-sound/hydrogen/files/hydrogen-0.9.5-gcc47.patch
@@ -0,0 +1,27 @@
+Build with gcc 4.7
+https://bugs.gentoo.org/show_bug.cgi?id=421913
+
+Index: hydrogen-0.9.5/gui/src/MainForm.cpp
+===================================================================
+--- hydrogen-0.9.5.orig/gui/src/MainForm.cpp
++++ hydrogen-0.9.5/gui/src/MainForm.cpp
+@@ -70,6 +70,7 @@ using namespace H2Core;
+
+ #include <memory>
+ #include <cassert>
++#include <unistd.h>
+
+ using namespace std;
+ using namespace H2Core;
+Index: hydrogen-0.9.5/gui/src/SongEditor/SongEditor.cpp
+===================================================================
+--- hydrogen-0.9.5.orig/gui/src/SongEditor/SongEditor.cpp
++++ hydrogen-0.9.5/gui/src/SongEditor/SongEditor.cpp
+@@ -21,6 +21,7 @@
+ */
+
+ #include <assert.h>
++#include <unistd.h>
+ #include <algorithm>
+ #include <memory>
+
diff --git a/media-sound/hydrogen/files/hydrogen-0.9.5-use_lrdf_pkgconfig.patch b/media-sound/hydrogen/files/hydrogen-0.9.5-use_lrdf_pkgconfig.patch
new file mode 100644
index 000000000000..6c862eac5836
--- /dev/null
+++ b/media-sound/hydrogen/files/hydrogen-0.9.5-use_lrdf_pkgconfig.patch
@@ -0,0 +1,23 @@
+conf.CheckCHeader lrdf.h check fails because of missing -I/usr/include/raptor2, use pkg-config instead
+
+--- Sconstruct
++++ Sconstruct
+@@ -268,7 +268,8 @@
+ env.Append( LIBPATH = 'C:\Program Files\GnuWin32\lib' )
+ env.Append( LIBS = [ "pthread" ] )
+
+- if str(env['lrdf']) == "1": env.Append( LIBS = ["lrdf"] )
++ if str(env['lrdf']) == "1":
++ env.ParseConfig('pkg-config --cflags --libs lrdf')
+ if str(env['jack']) == "1": env.Append( LIBS = ["jack"])
+ if str(env['alsa']) == "1": env.Append( LIBS = ["asound"])
+ if str(env['libarchive']) == "1": env.Append( LIBS = ["archive"])
+@@ -449,7 +450,7 @@
+ Exit(1)
+
+ #lrdf: categorizing of ladspa effects
+-if str(env['lrdf']) == "1" and not conf.CheckCHeader('lrdf.h'):
++if str(env['lrdf']) == "1" and not conf.CheckPKG('lrdf >= 0.4.0'):
+ print 'lrdf must be installed!'
+ Exit(1)
+
diff --git a/media-sound/hydrogen/hydrogen-0.9.5.ebuild b/media-sound/hydrogen/hydrogen-0.9.5.ebuild
new file mode 100644
index 000000000000..da33cd3648e2
--- /dev/null
+++ b/media-sound/hydrogen/hydrogen-0.9.5.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils multilib flag-o-matic toolchain-funcs
+
+DESCRIPTION="Advanced drum machine"
+HOMEPAGE="http://www.hydrogen-music.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2 ZLIB"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE="alsa +archive jack ladspa lash oss portaudio"
+
+RDEPEND="dev-qt/qtgui:4 dev-qt/qtcore:4
+ archive? ( app-arch/libarchive )
+ !archive? ( >=dev-libs/libtar-1.2.11-r3 )
+ >=media-libs/libsndfile-1.0.18
+ alsa? ( media-libs/alsa-lib )
+ jack? ( media-sound/jack-audio-connection-kit )
+ ladspa? ( media-libs/liblrdf )
+ lash? ( media-sound/lash )
+ portaudio? ( >=media-libs/portaudio-19_pre )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ dev-util/scons"
+
+src_prepare() {
+ sed -i -e '/cppflags +=/d' Sconstruct || die
+ epatch \
+ patches/portaudio.patch \
+ "${FILESDIR}"/${P}-use_lrdf_pkgconfig.patch \
+ "${FILESDIR}"/${P}-gcc47.patch
+}
+
+src_compile() {
+ # FIXME: The -I/usr/include/raptor2 gets lost in middle of build
+ # despite -use_lrdf_pkgconfig.patch
+ use ladspa && append-flags $($(tc-getPKG_CONFIG) --cflags lrdf)
+
+ export QTDIR="/usr/$(get_libdir)"
+ local myconf='portmidi=0' #90614
+
+ use alsa || myconf+=' alsa=0'
+ use archive && myconf+=' libarchive=1'
+ use jack || myconf+=' jack=0'
+ use ladspa || myconf+=' lrdf=0'
+ use lash && myconf+=' lash=1'
+ use oss || myconf+=' oss=0'
+ use portaudio && myconf+=' portaudio=1'
+
+ scons \
+ prefix=/usr \
+ DESTDIR="${D}" \
+ optflags="${CXXFLAGS}" \
+ ${myconf} || die
+}
+
+src_install() {
+ dobin hydrogen
+ insinto /usr/share/hydrogen
+ doins -r data
+ doicon data/img/gray/h2-icon.svg
+ domenu hydrogen.desktop
+ dosym /usr/share/hydrogen/data/doc /usr/share/doc/${PF}/html
+ dodoc AUTHORS ChangeLog README.txt
+}
diff --git a/media-sound/hydrogen/metadata.xml b/media-sound/hydrogen/metadata.xml
new file mode 100644
index 000000000000..d77759037425
--- /dev/null
+++ b/media-sound/hydrogen/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proaudio</herd>
+ <use>
+ <flag name="archive">Use libarchive instead of libtar</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">hydrogen</remote-id>
+ </upstream>
+</pkgmetadata>