summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-plugins/vdr-pilot/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-plugins/vdr-pilot/files')
-rw-r--r--media-plugins/vdr-pilot/files/vdr-pilot-0.0.8-includes.diff11
-rw-r--r--media-plugins/vdr-pilot/files/vdr-pilot-0.0.9-gcc-4.1.diff44
-rw-r--r--media-plugins/vdr-pilot/files/vdr-pilot-0.0.9-german.diff147
-rw-r--r--media-plugins/vdr-pilot/files/vdr-pilot-0.0.9-vdr-1.6.0.diff25
4 files changed, 227 insertions, 0 deletions
diff --git a/media-plugins/vdr-pilot/files/vdr-pilot-0.0.8-includes.diff b/media-plugins/vdr-pilot/files/vdr-pilot-0.0.8-includes.diff
new file mode 100644
index 000000000000..9a6123d9db9d
--- /dev/null
+++ b/media-plugins/vdr-pilot/files/vdr-pilot-0.0.8-includes.diff
@@ -0,0 +1,11 @@
+diff -ru pilot-0.0.8-orig/pilotosd.h pilot-0.0.8/pilotosd.h
+--- pilot-0.0.8-orig/pilotosd.h 2005-10-17 13:01:27.000000000 +0200
++++ pilot-0.0.8/pilotosd.h 2005-10-17 13:01:53.000000000 +0200
+@@ -2,6 +2,7 @@
+ #define __PILOTOSD_H
+
+ #include <vdr/osd.h>
++#include <vdr/device.h>
+ #include <vdr/menuitems.h>
+ #include <ctype.h>
+ #include "pilotbmp.h"
diff --git a/media-plugins/vdr-pilot/files/vdr-pilot-0.0.9-gcc-4.1.diff b/media-plugins/vdr-pilot/files/vdr-pilot-0.0.9-gcc-4.1.diff
new file mode 100644
index 000000000000..4079e0aa4490
--- /dev/null
+++ b/media-plugins/vdr-pilot/files/vdr-pilot-0.0.9-gcc-4.1.diff
@@ -0,0 +1,44 @@
+diff -ru pilot-0.0.9-orig/pilotosd.c pilot-0.0.9/pilotosd.c
+--- pilot-0.0.9-orig/pilotosd.c 2008-04-02 15:45:18.597448151 +0200
++++ pilot-0.0.9/pilotosd.c 2008-04-02 15:46:45.507442460 +0200
+@@ -34,7 +34,7 @@
+ {
+ delete osd;
+ }
+-void cPilotOsd::DrawSymbol(int x, int y, char *SymbolName[], tColor ColorFg)
++void cPilotOsd::DrawSymbol(int x, int y, const char *SymbolName[], tColor ColorFg)
+ {
+ cBitmap bm(SymbolName);
+ osd->DrawBitmap(x, y, bm, ColorFg, pal[0]);
+diff -ru pilot-0.0.9-orig/pilotosd.h pilot-0.0.9/pilotosd.h
+--- pilot-0.0.9-orig/pilotosd.h 2008-04-02 15:45:18.597448151 +0200
++++ pilot-0.0.9/pilotosd.h 2008-04-02 15:46:30.908163317 +0200
+@@ -11,7 +11,7 @@
+
+ class cPilotOsd : public cOsdObject {
+ private:
+- void DrawSymbol(int x, int y, char *SymbolName[], tColor color);
++ void DrawSymbol(int x, int y, const char *SymbolName[], tColor color);
+ cOsd *osd;
+ int pal[16];
+ int lastTime;
+diff -ru pilot-0.0.9-orig/symbols/down.xpm pilot-0.0.9/symbols/down.xpm
+--- pilot-0.0.9-orig/symbols/down.xpm 2008-04-02 15:45:18.597448151 +0200
++++ pilot-0.0.9/symbols/down.xpm 2008-04-02 15:45:47.057442667 +0200
+@@ -1,5 +1,5 @@
+ /* XPM */
+-static char * down_xpm[] = {
++static const char * down_xpm[] = {
+ "22 26 2 1",
+ ". c #FFFFFF",
+ "* c #000000",
+diff -ru pilot-0.0.9-orig/symbols/up.xpm pilot-0.0.9/symbols/up.xpm
+--- pilot-0.0.9-orig/symbols/up.xpm 2008-04-02 15:45:18.597448151 +0200
++++ pilot-0.0.9/symbols/up.xpm 2008-04-02 15:45:53.807442292 +0200
+@@ -1,5 +1,5 @@
+ /* XPM */
+-static char * up_xpm[] = {
++static const char * up_xpm[] = {
+ "22 26 2 1",
+ ". c #FFFFFF",
+ "* c #000000",
diff --git a/media-plugins/vdr-pilot/files/vdr-pilot-0.0.9-german.diff b/media-plugins/vdr-pilot/files/vdr-pilot-0.0.9-german.diff
new file mode 100644
index 000000000000..b1862254074d
--- /dev/null
+++ b/media-plugins/vdr-pilot/files/vdr-pilot-0.0.9-german.diff
@@ -0,0 +1,147 @@
+diff -ru pilot-0.0.9-orig/i18n.h pilot-0.0.9/i18n.h
+--- pilot-0.0.9-orig/i18n.h 2006-11-16 13:39:10.000000000 +0100
++++ pilot-0.0.9/i18n.h 2006-11-16 14:00:19.000000000 +0100
+@@ -38,7 +38,7 @@
+ * French translations provided by Maxime Guilbot <maxime.guilbot@orange.fr>
+ */
+ { "Pilot", // ENGLISH
+- "", // TODO
++ "Pilot", // GERMAN
+ "", // TODO
+ "", // TODO
+ "", // TODO
+@@ -60,7 +60,7 @@
+ "", // TODO
+ },
+ { "A zapping co-pilot", // ENGLISH
+- "", // TODO
++ "Ein Zap-Copilot", // GERMAN
+ "", // TODO
+ "", // TODO
+ "", // TODO
+@@ -82,7 +82,7 @@
+ "", // TODO
+ },
+ { "Red", // ENGLISH
+- "", // TODO
++ "Rot", // GERMAN
+ "", // TODO
+ "", // TODO
+ "", // TODO
+@@ -104,7 +104,7 @@
+ "", // TODO
+ },
+ { "Green", // ENGLISH
+- "", // TODO
++ "Grün", // GERMAN
+ "", // TODO
+ "", // TODO
+ "", // TODO
+@@ -126,7 +126,7 @@
+ "", // TODO
+ },
+ { "Blue", // ENGLISH
+- "", // TODO
++ "Blau", // GERMAN
+ "", // TODO
+ "", // TODO
+ "", // TODO
+@@ -258,7 +258,7 @@
+ "", // TODO
+ },
+ { "RemoveChannel",
+- "Kanal löschen", // GER
++ "Kanal löschen", // GERMAN
+ "", // TODO
+ "Rimuovi Canale", // ITALIAN
+ "Kanaal wegneemen", // NL
+@@ -280,7 +280,7 @@
+ "", // TODO
+ },
+ { "Background opacity",
+- "Rand transparenz", // TODO
++ "Hintergrund-Deckkraft", // GERMAN
+ "", // TODO
+ "Alpha Bordo 1", // ITALIAN
+ "", // TODO
+@@ -302,7 +302,7 @@
+ "", // TODO
+ },
+ { "Text opacity",
+- "", // TODO
++ "Text-Deckkraft", // GERMAN
+ "", // TODO
+ "Alpha Bordo 2", // ITALIAN
+ "", // TODO
+@@ -324,7 +324,7 @@
+ "", // TODO
+ },
+ { "Border opacity",
+- "Alpha Rand", // GER
++ "Rand-Deckkraft", // GER
+ "", // TODO
+ "AlphaBordo", // ITALIAN
+ "Alpha kant", // NL
+@@ -346,7 +346,7 @@
+ "", // TODO
+ },
+ { "Sort by",
+- "", // TODO
++ "Sortieren nach", // GERMAN
+ "", // TODO
+ "", // TODO
+ "", // TODO
+@@ -368,7 +368,7 @@
+ "", // TODO
+ },
+ { "None",
+- "", // TODO
++ "Nichts", // GERMAN
+ "", // TODO
+ "", // TODO
+ "", // TODO
+@@ -390,7 +390,7 @@
+ "", // TODO
+ },
+ { "Name",
+- "", // TODO
++ "Name", // GERMAN
+ "", // TODO
+ "", // TODO
+ "", // TODO
+@@ -412,7 +412,7 @@
+ "", // TODO
+ },
+ { "As entered",
+- "", // TODO
++ "Wie eingegeben", // GERMAN
+ "", // TODO
+ "", // TODO
+ "", // TODO
+@@ -434,7 +434,7 @@
+ "", // TODO
+ },
+ { "Close on OK",
+- "", // TODO
++ "Schließen mit OK", // GERMAN
+ "", // TODO
+ "", // TODO
+ "", // TODO
+@@ -456,7 +456,7 @@
+ "", // TODO
+ },
+ { "Number of channels",
+- "", // TODO
++ "Anzahl der Kanäle", // GERMAN
+ "", // TODO
+ "", // TODO
+ "", // TODO
+@@ -478,7 +478,7 @@
+ "", // TODO
+ },
+ { "Use DXR3",
+- "", // TODO
++ "DXR3 benutzen", // TODO
+ "", // TODO
+ "", // TODO
+ "", // TODO
diff --git a/media-plugins/vdr-pilot/files/vdr-pilot-0.0.9-vdr-1.6.0.diff b/media-plugins/vdr-pilot/files/vdr-pilot-0.0.9-vdr-1.6.0.diff
new file mode 100644
index 000000000000..e13a1392c540
--- /dev/null
+++ b/media-plugins/vdr-pilot/files/vdr-pilot-0.0.9-vdr-1.6.0.diff
@@ -0,0 +1,25 @@
+diff -ru pilot-0.0.9-orig/Makefile pilot-0.0.9/Makefile
+--- pilot-0.0.9-orig/Makefile 2008-04-02 15:37:55.657442868 +0200
++++ pilot-0.0.9/Makefile 2008-04-02 15:38:27.187445656 +0200
+@@ -47,7 +47,7 @@
+
+ ### The object files (add further files here):
+
+-OBJS = $(PLUGIN).o pilotosd.o pilotbmp.o pilotsetup.o
++OBJS = $(PLUGIN).o pilotosd.o pilotsetup.o
+
+ ### Implicit rules:
+
+Dateien pilot-0.0.9-orig/pilot.o und pilot-0.0.9/pilot.o sind verschieden.
+diff -ru pilot-0.0.9-orig/pilotosd.h pilot-0.0.9/pilotosd.h
+--- pilot-0.0.9-orig/pilotosd.h 2008-04-02 15:37:55.657442868 +0200
++++ pilot-0.0.9/pilotosd.h 2008-04-02 15:38:32.497447004 +0200
+@@ -4,7 +4,6 @@
+ #include <vdr/osd.h>
+ #include <vdr/menuitems.h>
+ #include <ctype.h>
+-#include "pilotbmp.h"
+
+ static const cFont *font = cFont::GetFont(fontOsd);
+ static const int LINEHEIGHT = font->Height();
+