summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-03-08 11:50:45 +0100
committerLars Wendler <polynomial-c@gentoo.org>2018-03-08 11:51:05 +0100
commit76e845dd41d5e9ea35eb5bf2f7288af8c2b3f8cb (patch)
tree962d8d2499dc4ec738d85fedbe4f3409fe1f42e0 /media-libs/soxr
parentmedia-libs/fdk-aac: Removed old. (diff)
downloadgentoo-76e845dd41d5e9ea35eb5bf2f7288af8c2b3f8cb.tar.gz
gentoo-76e845dd41d5e9ea35eb5bf2f7288af8c2b3f8cb.tar.bz2
gentoo-76e845dd41d5e9ea35eb5bf2f7288af8c2b3f8cb.zip
media-libs/soxr: Bump to version 0.1.3
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'media-libs/soxr')
-rw-r--r--media-libs/soxr/Manifest1
-rw-r--r--media-libs/soxr/soxr-0.1.3.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/media-libs/soxr/Manifest b/media-libs/soxr/Manifest
index 40bccf823919..fc0ba7abb87c 100644
--- a/media-libs/soxr/Manifest
+++ b/media-libs/soxr/Manifest
@@ -1,2 +1,3 @@
DIST soxr-0.1.1-Source.tar.xz 80716 BLAKE2B 40da97d0f3fe7544976b8735c685796038639bdcf35d17709d4d92b32b8f3550054d8d632c4bcfb785cb6152f890ae8e8184dd8c028c31422d78689c498c01b2 SHA512 377d9c0bb72cd673f89021a86da18861d35ab52f773afd97b6b5f7a2fa8e78865f3484cab4b795ceafacbbb34be6b77efeaaed75c66a839d5e891d70f00d6679
DIST soxr-0.1.2-Source.tar.xz 83760 BLAKE2B b54e31599a3eb94902af21749ba92c79ea4edf9a82de5c83581c7968182c22a80c86fbcd7f0bbd823b45adbd52570a7b4accf6bc75df31bb0a76b2b4e4703572 SHA512 ee902c1bc713e05b748f917d78222b68b5fe01d43f405e0954c21ce4d1ee494d01000caa79f696cb8d202c662a4c4d958b332dae034d6f929e0480abf27cd07c
+DIST soxr-0.1.3-Source.tar.xz 94384 BLAKE2B 5b7078f71404b9ef83917dcabc0c99cf17fd625d3e033d1b934382a7b60e55e359931a6ab53f8adaf955c0d811d6cbf231cd6a226549560b3506a3867e845607 SHA512 f4883ed298d5650399283238aac3dbe78d605b988246bea51fa343d4a8ce5ce97c6e143f6c3f50a3ff81795d9c19e7a07217c586d4020f6ced102aceac46aaa8
diff --git a/media-libs/soxr/soxr-0.1.3.ebuild b/media-libs/soxr/soxr-0.1.3.ebuild
new file mode 100644
index 000000000000..7d9c21dddcd8
--- /dev/null
+++ b/media-libs/soxr/soxr-0.1.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-multilib
+
+MY_P="${P}-Source"
+DESCRIPTION="The SoX Resampler library"
+HOMEPAGE="https://sourceforge.net/p/soxr/wiki/Home/"
+SRC_URI="mirror://sourceforge/soxr/${MY_P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
+IUSE="examples test"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+DOCS=( "README" "TODO" "NEWS" "AUTHORS" )
+PATCHES=(
+ "${FILESDIR}/nodoc.patch"
+)
+# CMakeLists.txt builds examples if either test or examples USE flag is enabled.
+REQUIRED_USE="test? ( examples )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_EXAMPLES="$(usex examples)"
+ -DBUILD_TESTS="$(usex test)"
+ )
+ if use examples ; then
+ mycmakeargs+=(
+ -DDOC_INSTALL_DIR="/usr/share/doc/${PF}"
+ )
+ fi
+ cmake-multilib_src_configure
+}
+
+src_install() {
+ cmake-multilib_src_install
+ if use examples ; then
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}