summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Parborg <darkdefende@gmail.com>2022-04-07 19:00:56 +0200
committerJoonas Niilola <juippis@gentoo.org>2022-04-17 17:56:31 +0300
commitf4720520b02bb22c06804df992ff2448ee48ec13 (patch)
treeb07829ec1460fcaadcba3f4900d1c24593d7f2c4 /media-libs/partio
parentmedia-gfx/blender: add 3.1.2 (diff)
downloadgentoo-f4720520b02bb22c06804df992ff2448ee48ec13.tar.gz
gentoo-f4720520b02bb22c06804df992ff2448ee48ec13.tar.bz2
gentoo-f4720520b02bb22c06804df992ff2448ee48ec13.zip
media-libs/partio: Version bump to 1.14.6
Also update webpage URL to a currently valid one. Closes: https://bugs.gentoo.org/835147 Signed-off-by: Sebastian Parborg <darkdefende@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/24946 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-libs/partio')
-rw-r--r--media-libs/partio/Manifest1
-rw-r--r--media-libs/partio/partio-1.14.6.ebuild50
-rw-r--r--media-libs/partio/partio-9999.ebuild2
3 files changed, 52 insertions, 1 deletions
diff --git a/media-libs/partio/Manifest b/media-libs/partio/Manifest
index 951d245bfb7e..61c59064a387 100644
--- a/media-libs/partio/Manifest
+++ b/media-libs/partio/Manifest
@@ -1 +1,2 @@
DIST partio-1.10.1.tar.gz 333129 BLAKE2B 82d1dd36e9854e221af036d386ecdc558ac032ad7cd720403787ddc83ac236f05fd86e8c07ade07ca93b06a12ac2b834c96a6d43265e396934e44a815df003d3 SHA512 7d3c6449ebd1e8b8a29298a3119acfd1036970b287e9cd5f288a63c7e2b3bf451e9e1ba8fc72f203e225eb2b062d59cd7373817ccc6467de67427d02c0b12477
+DIST partio-1.14.6.tar.gz 336527 BLAKE2B 60c9c6ad9d5a7b58967e7633180d4f8d399bd129cc7b76fc4329b3d191ce0d381df7f977d5ec11ccedbdbcd8afa0fde2f946960f08a242338c2f674b4c94343e SHA512 5479d00b3124e8e06abbc65b1cdc01cdac37b9207c0615029e488baa0835e4ad545be2fb07dda5b4541dd846115059aaca5950ff904bddec6bb1fd72180ebcc0
diff --git a/media-libs/partio/partio-1.14.6.ebuild b/media-libs/partio/partio-1.14.6.ebuild
new file mode 100644
index 000000000000..56e1661b9618
--- /dev/null
+++ b/media-libs/partio/partio-1.14.6.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+inherit cmake python-single-r1
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/wdas/partio.git"
+else
+ SRC_URI="https://github.com/wdas/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+DESCRIPTION="Library for particle IO and manipulation"
+HOMEPAGE="http://partio.us/"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="doc"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ media-libs/freeglut
+ sys-libs/zlib:=
+ virtual/opengl
+"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+ dev-lang/swig
+ doc? (
+ app-doc/doxygen
+ dev-texlive/texlive-bibtexextra
+ dev-texlive/texlive-fontsextra
+ dev-texlive/texlive-fontutils
+ dev-texlive/texlive-latex
+ dev-texlive/texlive-latexextra
+ )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package doc Doxygen)
+ )
+ cmake_src_configure
+}
diff --git a/media-libs/partio/partio-9999.ebuild b/media-libs/partio/partio-9999.ebuild
index e5a82c3417e2..baf68b18c313 100644
--- a/media-libs/partio/partio-9999.ebuild
+++ b/media-libs/partio/partio-9999.ebuild
@@ -15,7 +15,7 @@ else
fi
DESCRIPTION="Library for particle IO and manipulation"
-HOMEPAGE="https://www.disneyanimation.com/technology/partio.html"
+HOMEPAGE="http://partio.us/"
LICENSE="BSD"
SLOT="0"