summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Parborg <darkdefende@gmail.com>2022-02-17 19:34:48 +0100
committerSam James <sam@gentoo.org>2022-02-18 02:36:58 +0000
commit1de82f166b57f466bd2dc6f91c90d075214296bd (patch)
treeb66665f88ee3a4beb73e8adf7a3a26b60fc131cb /media-libs/embree
parentapp-backup/burp: add missing queue-standalone dep for musl (diff)
downloadgentoo-1de82f166b57f466bd2dc6f91c90d075214296bd.tar.gz
gentoo-1de82f166b57f466bd2dc6f91c90d075214296bd.tar.bz2
gentoo-1de82f166b57f466bd2dc6f91c90d075214296bd.zip
media-libs/embree: Remove static-lib useflag
It could cause build issues with the Blender ebuild when using older CPUs. It will also fail to build with newer TBB versions. It doesn't bring any real benifit to build static libs for Blender currently either. (The only package in portage that uses embree) Closes: https://bugs.gentoo.org/828447 Closes: https://bugs.gentoo.org/831377 Signed-off-by: Sebastian Parborg <darkdefende@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/embree')
-rw-r--r--media-libs/embree/embree-3.13.0-r2.ebuild4
-rw-r--r--media-libs/embree/embree-3.13.2.ebuild4
2 files changed, 4 insertions, 4 deletions
diff --git a/media-libs/embree/embree-3.13.0-r2.ebuild b/media-libs/embree/embree-3.13.0-r2.ebuild
index 136ad000762f..8c864d288c9c 100644
--- a/media-libs/embree/embree-3.13.0-r2.ebuild
+++ b/media-libs/embree/embree-3.13.0-r2.ebuild
@@ -14,7 +14,7 @@ SLOT="3"
KEYWORDS="amd64 ~arm ~arm64 ~ppc64 ~x86"
X86_CPU_FLAGS=( sse2:sse2 sse4_2:sse4_2 avx:avx avx2:avx2 avx512dq:avx512dq )
CPU_FLAGS=( ${X86_CPU_FLAGS[@]/#/cpu_flags_x86_} )
-IUSE="+compact-polys ispc +raymask ssp +tbb tutorial static-libs ${CPU_FLAGS[@]%:*}"
+IUSE="+compact-polys ispc +raymask ssp +tbb tutorial ${CPU_FLAGS[@]%:*}"
RESTRICT="mirror"
BDEPEND="
@@ -93,7 +93,7 @@ src_configure() {
-DEMBREE_RAY_MASK=$(usex raymask)
-DEMBREE_RAY_PACKETS=ON # default
-DEMBREE_STACK_PROTECTOR=$(usex ssp)
- -DEMBREE_STATIC_LIB=$(usex static-libs)
+ -DEMBREE_STATIC_LIB=OFF
-DEMBREE_STAT_COUNTERS=OFF
-DEMBREE_TASKING_SYSTEM:STRING=$(usex tbb "TBB" "INTERNAL")
-DEMBREE_TUTORIALS=$(usex tutorial) )
diff --git a/media-libs/embree/embree-3.13.2.ebuild b/media-libs/embree/embree-3.13.2.ebuild
index 94efef93e9b9..6e9dad8b03c4 100644
--- a/media-libs/embree/embree-3.13.2.ebuild
+++ b/media-libs/embree/embree-3.13.2.ebuild
@@ -14,7 +14,7 @@ SLOT="3"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
X86_CPU_FLAGS=( sse2:sse2 sse4_2:sse4_2 avx:avx avx2:avx2 avx512dq:avx512dq )
CPU_FLAGS=( cpu_flags_arm_neon ${X86_CPU_FLAGS[@]/#/cpu_flags_x86_} )
-IUSE="+compact-polys ispc +raymask ssp +tbb tutorial static-libs ${CPU_FLAGS[@]%:*}"
+IUSE="+compact-polys ispc +raymask ssp +tbb tutorial ${CPU_FLAGS[@]%:*}"
# Let's be explicit here even though we could simplify it.
REQUIRED_USE="amd64? ( cpu_flags_x86_sse2 ) x86? ( cpu_flags_x86_sse2 )"
@@ -111,7 +111,7 @@ src_configure() {
# default
-DEMBREE_RAY_PACKETS=ON
-DEMBREE_STACK_PROTECTOR=$(usex ssp)
- -DEMBREE_STATIC_LIB=$(usex static-libs)
+ -DEMBREE_STATIC_LIB=OFF
-DEMBREE_STAT_COUNTERS=OFF
-DEMBREE_TASKING_SYSTEM:STRING=$(usex tbb "TBB" "INTERNAL")
-DEMBREE_TUTORIALS=$(usex tutorial))