summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-05-10 22:02:11 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-05-10 22:02:36 +0300
commitf4ce95be3cbf3875f5a238245b7c2ac9853b718e (patch)
treea59028fdc42c089bb94617ec0ccb198302bf3bd4 /media-libs/cimg
parentsys-kernel/gentoo-sources: netfilter patch for CVE-2023-32233 (diff)
downloadgentoo-f4ce95be3cbf3875f5a238245b7c2ac9853b718e.tar.gz
gentoo-f4ce95be3cbf3875f5a238245b7c2ac9853b718e.tar.bz2
gentoo-f4ce95be3cbf3875f5a238245b7c2ac9853b718e.zip
media-libs/cimg: add 3.2.4, EAPI=8
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'media-libs/cimg')
-rw-r--r--media-libs/cimg/Manifest1
-rw-r--r--media-libs/cimg/cimg-3.2.4.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/media-libs/cimg/Manifest b/media-libs/cimg/Manifest
index 3a0e0afd8cba..aea931d340ec 100644
--- a/media-libs/cimg/Manifest
+++ b/media-libs/cimg/Manifest
@@ -1 +1,2 @@
DIST cimg-2.9.3.tar.gz 11222797 BLAKE2B c2135a0219305dafde642198888f5a813f7c73a34dbb015b271cbfd601a4265fe0495cbd74a0ac502cbbd1b8ead49687a945d35d7eaffe5127cbdc9c67664c14 SHA512 038cfa0dbb8beeffa53cc84491988bfee27b0e3e74c3f802185669be5ddc85f0ab002a6bce0e57e3692aa6380715436078cbcccadb0e2b34442db50fc19c1aed
+DIST cimg-3.2.4.tar.gz 12660194 BLAKE2B f30f24e388a066a6923a72be00055449862cc643bbe870e55198718e185d2fe9213cb8f19cb83c68fe6ff5ea4e93c2529f70c7256b2d022b304cb2b020f0db11 SHA512 71cbf5161a7778a14e105d8aa41bf0431303b6f4a0f4982d3788903b0505f5ae96be9515c67ea6a52e0e76fdcb25efe3cfd7684980545d078ff41e10dbb4fbb6
diff --git a/media-libs/cimg/cimg-3.2.4.ebuild b/media-libs/cimg/cimg-3.2.4.ebuild
new file mode 100644
index 000000000000..5ea343966cc1
--- /dev/null
+++ b/media-libs/cimg/cimg-3.2.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="C++ template image processing toolkit"
+HOMEPAGE="https://cimg.eu/ https://github.com/dtschump/CImg"
+SRC_URI="https://github.com/dtschump/CImg/archive/v.${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/CImg-v.${PV}"
+
+LICENSE="CeCILL-2 CeCILL-C"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+src_install() {
+ doheader CImg.h
+ dodoc README.txt
+
+ use doc && dodoc -r html
+ if use examples; then
+ dodoc -r examples
+ docompress -x "/usr/share/doc/${PF}/examples"
+ fi
+}