summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jordan <immoloism@gmail.com>2024-04-06 16:48:59 +0100
committerArthur Zamarin <arthurzam@gentoo.org>2024-04-09 20:28:46 +0300
commited4c5f6e87df57849b5d6398499e520a5b6b0c89 (patch)
tree619914e8ca03efb1476dba9bd091c3ac20068d4e /mate-extra
parentmate-extra/mate-system-monitor: drop 1.27.0 (diff)
downloadgentoo-ed4c5f6e87df57849b5d6398499e520a5b6b0c89.tar.gz
gentoo-ed4c5f6e87df57849b5d6398499e520a5b6b0c89.tar.bz2
gentoo-ed4c5f6e87df57849b5d6398499e520a5b6b0c89.zip
mate-extra/mate-system-monitor: add 1.28.0
Signed-off-by: Ian Jordan <immoloism@gmail.com> Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'mate-extra')
-rw-r--r--mate-extra/mate-system-monitor/Manifest1
-rw-r--r--mate-extra/mate-system-monitor/mate-system-monitor-1.28.0.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/mate-extra/mate-system-monitor/Manifest b/mate-extra/mate-system-monitor/Manifest
index 50739b02bbf8..da3311852305 100644
--- a/mate-extra/mate-system-monitor/Manifest
+++ b/mate-extra/mate-system-monitor/Manifest
@@ -1,2 +1,3 @@
DIST mate-system-monitor-1.26.2.tar.xz 2515076 BLAKE2B ca5aa8c80b2b6291a0b0867e4c9cfc93ed0b507cf502dde459a0d04ab9ec3ea59373defd6ecd1b98c903b4adc643c45472d8c9da3c5604d3225c38f0f7c59d1a SHA512 a57052a7f72923ab84aeb584ae2f5c4d9857076ca6cac21ef0e30551d84cdeaa4226fc324c9efc3e06a57ccfcb2fc17ac283aa64f636127a9cd645dbe36690e9
DIST mate-system-monitor-1.26.3.tar.xz 2516144 BLAKE2B 2bb471152ce1c0739eb4ddc9140878f8830b93216182b6960af996c06f57035c22f3d5ddac37bfc0e5b59742250e823eb8c6de2c00be22c39cf8a2d3e7256e66 SHA512 81158393ca57e7f6cba142341aaae4af475331803d7f304afad8ea634670691a385083dd3ff4f0479fa50bbda2bd0a036656c2aca3dc03e0dc9eeb99db7fec41
+DIST mate-system-monitor-1.28.0.tar.xz 2518132 BLAKE2B 375f89b87b79dac58a50ea139995872aa0cba208c9559d819d46e30dd3871d1d5d3bfdf6611e098daedc7e56d7f26ecefcf10b79c642740189a27900c6015b59 SHA512 238b2a2ac927cef78a67421499eaa983f875f90f0eeee4f1dcb175627784da2c2de24d2e8831f26f05779974a842962880a0dfb4eaf4e297ba41a5c1e82d9fce
diff --git a/mate-extra/mate-system-monitor/mate-system-monitor-1.28.0.ebuild b/mate-extra/mate-system-monitor/mate-system-monitor-1.28.0.ebuild
new file mode 100644
index 000000000000..33bee63b0332
--- /dev/null
+++ b/mate-extra/mate-system-monitor/mate-system-monitor-1.28.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit mate toolchain-funcs
+
+MINOR=$(($(ver_cut 2) % 2))
+if [[ ${MINOR} -eq 0 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+fi
+
+DESCRIPTION="The MATE System Monitor"
+
+LICENSE="FDL-1.1+ GPL-2+ LGPL-2+"
+SLOT="0"
+IUSE="elogind systemd wnck"
+
+REQUIRED_USE="?? ( elogind systemd )"
+
+COMMON_DEPEND="
+ >=dev-cpp/glibmm-2.26:2
+ >=dev-cpp/gtkmm-3.8:3.0
+ >=dev-libs/glib-2.56:2
+ dev-libs/libsigc++:2
+ >=dev-libs/libxml2-2:2
+ >=gnome-base/libgtop-2.37.2:2=
+ >=gnome-base/librsvg-2.35:2
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.22:3
+ >=x11-libs/libwnck-3.0:3
+ elogind? ( sys-auth/elogind )
+ systemd? ( sys-apps/systemd )
+"
+
+RDEPEND="${COMMON_DEPEND}
+ >=sys-auth/polkit-0.97:0
+ virtual/libintl
+"
+
+DEPEND="${COMMON_DEPEND}
+ app-text/yelp-tools
+ >=sys-devel/gettext-0.19.8
+ >=dev-build/autoconf-2.63:*
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myconf=()
+
+ if use elogind || use systemd; then
+ myconf+=( --enable-systemd )
+ if use elogind; then
+ local pkgconfig="$(tc-getPKG_CONFIG)"
+ myconf+=(
+ SYSTEMD_CFLAGS="$(${pkgconfig} --cflags 'libelogind')"
+ SYSTEMD_LIBS="$(${pkgconfig} --libs 'libelogind')"
+ )
+ fi
+ else
+ myconf+=( --disable-systemd )
+ fi
+
+ mate_src_configure "${myconf[@]}" \
+ $(use_enable wnck)
+}