summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-07-19 22:46:20 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-07-20 15:46:07 +0200
commit6a975aeadd63b85f685eb9f1cac1d03b88ffbcd7 (patch)
tree51b61c87b40614877cfc4371f1a9cc071b91274f /mail-client
parentdev-libs/cudnn: 6.0 has NonsolvableDepsInStable, so it's broken (diff)
downloadgentoo-6a975aeadd63b85f685eb9f1cac1d03b88ffbcd7.tar.gz
gentoo-6a975aeadd63b85f685eb9f1cac1d03b88ffbcd7.tar.bz2
gentoo-6a975aeadd63b85f685eb9f1cac1d03b88ffbcd7.zip
mail-client/thunderbird: check requirements only for non-binary merges
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/thunderbird/thunderbird-68.10.0.ebuild66
1 files changed, 35 insertions, 31 deletions
diff --git a/mail-client/thunderbird/thunderbird-68.10.0.ebuild b/mail-client/thunderbird/thunderbird-68.10.0.ebuild
index 5da743f127c7..684386fa5412 100644
--- a/mail-client/thunderbird/thunderbird-68.10.0.ebuild
+++ b/mail-client/thunderbird/thunderbird-68.10.0.ebuild
@@ -216,43 +216,51 @@ llvm_check_deps() {
}
pkg_pretend() {
- if use pgo ; then
- if ! has usersandbox $FEATURES ; then
- die "You must enable usersandbox as X server can not run as root!"
+ if [[ ${MERGE_TYPE} != binary ]] ; then
+ if use pgo ; then
+ if ! has usersandbox $FEATURES ; then
+ die "You must enable usersandbox as X server can not run as root!"
+ fi
fi
- fi
- # Ensure we have enough disk space to compile
- if use pgo || use lto || use debug || use test ; then
- CHECKREQS_DISK_BUILD="8G"
- else
- CHECKREQS_DISK_BUILD="4500M"
- fi
+ # Ensure we have enough disk space to compile
+ if use pgo || use lto || use debug || use test ; then
+ CHECKREQS_DISK_BUILD="8G"
+ else
+ CHECKREQS_DISK_BUILD="4500M"
+ fi
- check-reqs_pkg_pretend
+ check-reqs_pkg_pretend
+ fi
}
pkg_setup() {
moz_pkgsetup
- # Ensure we have enough disk space to compile
- if use pgo || use lto || use debug || use test ; then
- CHECKREQS_DISK_BUILD="8G"
- else
- CHECKREQS_DISK_BUILD="4500M"
- fi
+ if [[ ${MERGE_TYPE} != binary ]] ; then
+ # Ensure we have enough disk space to compile
+ if use pgo || use lto || use debug || use test ; then
+ CHECKREQS_DISK_BUILD="8G"
+ else
+ CHECKREQS_DISK_BUILD="4500M"
+ fi
+
+ check-reqs_pkg_setup
- check-reqs_pkg_setup
+ # Avoid PGO profiling problems due to enviroment leakage
+ # These should *always* be cleaned up anyway
+ unset DBUS_SESSION_BUS_ADDRESS \
+ DISPLAY \
+ ORBIT_SOCKETDIR \
+ SESSION_MANAGER \
+ XDG_CACHE_HOME \
+ XDG_SESSION_COOKIE \
+ XAUTHORITY
- # Avoid PGO profiling problems due to enviroment leakage
- # These should *always* be cleaned up anyway
- unset DBUS_SESSION_BUS_ADDRESS \
- DISPLAY \
- ORBIT_SOCKETDIR \
- SESSION_MANAGER \
- XDG_CACHE_HOME \
- XDG_SESSION_COOKIE \
- XAUTHORITY
+ addpredict /proc/self/oom_score_adj
+
+ llvm_pkg_setup
+ fi
if ! use bindist ; then
einfo
@@ -261,10 +269,6 @@ pkg_setup() {
elog "a legal problem with Mozilla Foundation."
elog "You can disable it by emerging ${PN} _with_ the bindist USE-flag."
fi
-
- addpredict /proc/self/oom_score_adj
-
- llvm_pkg_setup
}
src_unpack() {