summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-24 13:34:08 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-24 13:35:17 +0100
commitcc3e60d17c11df4484cd99da9520d7128697599a (patch)
tree21238f43bd971a79adb20f27cda81a00075c0754 /llvm-core
parentllvm-runtimes/offload: Keyword 19.1.6 ppc64, #946609 (diff)
downloadgentoo-cc3e60d17c11df4484cd99da9520d7128697599a.tar.gz
gentoo-cc3e60d17c11df4484cd99da9520d7128697599a.tar.bz2
gentoo-cc3e60d17c11df4484cd99da9520d7128697599a.zip
llvm-core/clang-runtime: Add USE=offload to 19.1.6-r1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'llvm-core')
-rw-r--r--llvm-core/clang-runtime/clang-runtime-19.1.6-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/llvm-core/clang-runtime/clang-runtime-19.1.6-r1.ebuild b/llvm-core/clang-runtime/clang-runtime-19.1.6-r1.ebuild
new file mode 100644
index 000000000000..f18c95266d96
--- /dev/null
+++ b/llvm-core/clang-runtime/clang-runtime-19.1.6-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-build toolchain-funcs
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="https://clang.llvm.org/"
+
+LICENSE="metapackage"
+SLOT="${PV%%.*}"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~arm64-macos ~ppc-macos ~x64-macos"
+IUSE="+compiler-rt libcxx offload openmp +sanitize"
+REQUIRED_USE="sanitize? ( compiler-rt )"
+
+RDEPEND="
+ compiler-rt? (
+ ~llvm-runtimes/compiler-rt-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
+ sanitize? (
+ ~llvm-runtimes/compiler-rt-sanitizers-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
+ )
+ )
+ libcxx? ( >=llvm-runtimes/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ openmp? (
+ >=llvm-runtimes/openmp-${PV}[${MULTILIB_USEDEP}]
+ offload? (
+ >=llvm-runtimes/offload-${PV}
+ )
+ )
+"
+
+pkg_pretend() {
+ if tc-is-clang; then
+ ewarn "You seem to be using clang as a system compiler. As of clang-16,"
+ ewarn "upstream has turned a few warnings that commonly occur during"
+ ewarn "configure script runs into errors by default. This causes some"
+ ewarn "configure tests to start failing, sometimes resulting in silent"
+ ewarn "breakage, missing functionality or runtime misbehavior. It is"
+ ewarn "not yet clear whether the change will remain or be reverted."
+ ewarn
+ ewarn "For more information, please see:"
+ ewarn "https://discourse.llvm.org/t/configure-script-breakage-with-the-new-werror-implicit-function-declaration/65213"
+ fi
+}