summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /kde-plasma/kio-extras
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'kde-plasma/kio-extras')
-rw-r--r--kde-plasma/kio-extras/Manifest1
-rw-r--r--kde-plasma/kio-extras/kio-extras-5.3.2.ebuild86
-rw-r--r--kde-plasma/kio-extras/metadata.xml9
3 files changed, 96 insertions, 0 deletions
diff --git a/kde-plasma/kio-extras/Manifest b/kde-plasma/kio-extras/Manifest
new file mode 100644
index 000000000000..5cdecf2cf16c
--- /dev/null
+++ b/kde-plasma/kio-extras/Manifest
@@ -0,0 +1 @@
+DIST kio-extras-5.3.2.tar.xz 613172 SHA256 7cc90553fc6a003e776ee5417e437007cc97d37f774edc92e21bdf5a0710d7ed SHA512 6019d70141528fbf57618305edde0feff9158ea7d7319ff01b7f1a6cccccc0dc5813b5dbd53d77b5d7046960007181a92ceed5b5f53d29df29edfa071eea1cde WHIRLPOOL bd73ef3b013e2948894c5cc98f452faee5309f1d1ef10b31bd3d5a5045c6a417cf92e9b22f29f5c3edfc912349a3ba53b6761814ac05bc8f81d2f608fda6ba49
diff --git a/kde-plasma/kio-extras/kio-extras-5.3.2.ebuild b/kde-plasma/kio-extras/kio-extras-5.3.2.ebuild
new file mode 100644
index 000000000000..23a3d51fc4c0
--- /dev/null
+++ b/kde-plasma/kio-extras/kio-extras-5.3.2.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_HANDBOOK="true"
+KDE_TEST="true"
+VIRTUALX_REQUIRED="test"
+inherit fdo-mime kde5
+
+DESCRIPTION="KIO plugins present a filesystem-like view of arbitrary data"
+HOMEPAGE="https://projects.kde.org/projects/kde/workspace/kio-extras"
+KEYWORDS="~amd64"
+IUSE="exif mtp phonon samba +sftp slp"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep karchive 'bzip2,lzma')
+ $(add_frameworks_dep kbookmarks)
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kdelibs4support)
+ $(add_frameworks_dep kdnssd)
+ $(add_frameworks_dep kguiaddons)
+ $(add_frameworks_dep khtml)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kpty)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep solid)
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ virtual/jpeg:0
+ exif? ( media-gfx/exiv2:= )
+ mtp? ( media-libs/libmtp:= )
+ phonon? ( media-libs/phonon[qt5] )
+ samba? ( || ( <net-fs/samba-4.0.0_alpha1[smbclient] >=net-fs/samba-4.0.0_alpha1[client] ) )
+ sftp? ( >=net-libs/libssh-0.6.0:=[sftp] )
+ slp? ( net-libs/openslp )
+"
+RDEPEND="${COMMON_DEPEND}
+ $(add_frameworks_dep kded)
+ !kde-apps/kdebase-kioslaves:4[-minimal(-)]
+ !kde-apps/kcontrol:4
+ !kde-base/kdebase-kioslaves:4[-minimal(-)]
+ !kde-base/kio-extras
+"
+DEPEND="${COMMON_DEPEND}
+ x11-misc/shared-mime-info
+"
+
+# requires running kde environment
+RESTRICT="test"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package exif Exiv2)
+ $(cmake-utils_use_find_package mtp)
+ $(cmake-utils_use_find_package phonon Phonon4Qt5)
+ $(cmake-utils_use_find_package samba)
+ $(cmake-utils_use_find_package sftp LibSSH)
+ $(cmake-utils_use_find_package slp)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ kde5_pkg_postinst
+ fdo-mime_mime_database_update
+}
diff --git a/kde-plasma/kio-extras/metadata.xml b/kde-plasma/kio-extras/metadata.xml
new file mode 100644
index 000000000000..f7d7c71bd55d
--- /dev/null
+++ b/kde-plasma/kio-extras/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kde</herd>
+ <use>
+ <flag name="phonon">Enable file audio preview plugin using <pkg>media-libs/phonon</pkg></flag>
+ <flag name="sftp">Enable SFTP protocol support using <pkg>net-libs/libssh</pkg></flag>
+ </use>
+</pkgmetadata>