summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-02-10 14:28:40 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-02-11 23:00:24 +0100
commit8e9254c5dac34b290d80baa283964bf5802d6630 (patch)
treee74c0d8d4491416d64de7802e3937452a509b1f1 /kde-apps/thumbnailers/thumbnailers-17.12.2.ebuild
parentkde-frameworks: Add KDE Frameworks 5.43.0 (diff)
downloadgentoo-8e9254c5dac34b290d80baa283964bf5802d6630.tar.gz
gentoo-8e9254c5dac34b290d80baa283964bf5802d6630.tar.bz2
gentoo-8e9254c5dac34b290d80baa283964bf5802d6630.zip
kde-apps: Add KDE Applications 17.12.2
Bug: https://bugs.gentoo.org/642854 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'kde-apps/thumbnailers/thumbnailers-17.12.2.ebuild')
-rw-r--r--kde-apps/thumbnailers/thumbnailers-17.12.2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/kde-apps/thumbnailers/thumbnailers-17.12.2.ebuild b/kde-apps/thumbnailers/thumbnailers-17.12.2.ebuild
new file mode 100644
index 000000000000..ff1362dbc75b
--- /dev/null
+++ b/kde-apps/thumbnailers/thumbnailers-17.12.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_BLOCK_SLOT4=false
+KMNAME="kdegraphics-thumbnailers"
+inherit kde5
+
+DESCRIPTION="Thumbnail generators for PDF/PS and RAW files"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~x86"
+IUSE="raw"
+
+DEPEND="
+ $(add_frameworks_dep kio)
+ $(add_qt_dep qtgui)
+ raw? (
+ $(add_kdeapps_dep libkdcraw)
+ $(add_kdeapps_dep libkexiv2)
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package raw KF5KExiv2)
+ $(cmake-utils_use_find_package raw KF5KDcraw)
+ )
+
+ kde5_src_configure
+}