summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-12 18:25:02 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-12 18:28:13 +0100
commit0a04dbe4bdce4ba9c45b21310d7a26c95b2530ac (patch)
tree0e4a9ab3a24db08d0f6c7b61b0d5821e99bd4497 /kde-apps/pimcommon
parentecm.eclass: cmake-utils_use_find_package -> cmake_use_find_package (diff)
downloadgentoo-0a04dbe4bdce4ba9c45b21310d7a26c95b2530ac.tar.gz
gentoo-0a04dbe4bdce4ba9c45b21310d7a26c95b2530ac.tar.bz2
gentoo-0a04dbe4bdce4ba9c45b21310d7a26c95b2530ac.zip
kde-apps: Add KDE Release Service 19.12.0
Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/pimcommon')
-rw-r--r--kde-apps/pimcommon/Manifest1
-rw-r--r--kde-apps/pimcommon/pimcommon-19.12.0.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/kde-apps/pimcommon/Manifest b/kde-apps/pimcommon/Manifest
index 511b4436844f..c7b90b24cf18 100644
--- a/kde-apps/pimcommon/Manifest
+++ b/kde-apps/pimcommon/Manifest
@@ -1 +1,2 @@
DIST pimcommon-19.08.3.tar.xz 293596 BLAKE2B 31326e8df1cce64849f4cd4672aac2df94709416347ad1cd616db2132ff8537f34034574e015ec54b08917dcccd128f2af8fc2d08a54cad8bf1ba0d9e6f7fafe SHA512 844d36c8ed63ec4de7d5feafd637e1d6b87725e77910839365e9a1e8cfdfd2f46e6e64b42a1ca3837a95b2f7a194fde46d5068b0609d5806fea9295b94c1a2b1
+DIST pimcommon-19.12.0.tar.xz 294760 BLAKE2B 47025b188d3c602d1dfb1fe47b80086255501b794af22d6ffd071fe8d3183ba7e9e95e306dd0ef500c417d84af5fe977a041ca5739708326b0c5e8fcaa04b878 SHA512 e3f23d63777c33986385f3def720d145029ef61ef1df5e3b6ee733a2610b1f4b6f034307622e88a5b6be602431e001cc17f8613ae7da7ce940009b7e66849f0c
diff --git a/kde-apps/pimcommon/pimcommon-19.12.0.ebuild b/kde-apps/pimcommon/pimcommon-19.12.0.ebuild
new file mode 100644
index 000000000000..ec0b275ef7a1
--- /dev/null
+++ b/kde-apps/pimcommon/pimcommon-19.12.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_DESIGNERPLUGIN="true"
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.63.0
+QTMIN=5.12.3
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Common PIM libraries"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+BDEPEND="
+ dev-libs/libxslt
+"
+COMMON_DEPEND="
+ >=kde-frameworks/karchive-${KFMIN}:5
+ >=kde-frameworks/kcodecs-${KFMIN}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcontacts-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kitemmodels-${KFMIN}:5
+ >=kde-frameworks/kjobwidgets-${KFMIN}:5
+ >=kde-frameworks/knewstuff-${KFMIN}:5
+ >=kde-frameworks/kservice-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ >=kde-frameworks/purpose-${KFMIN}:5
+ >=kde-apps/akonadi-${PVCUT}:5
+ >=kde-apps/akonadi-contacts-${PVCUT}:5
+ >=kde-apps/kimap-${PVCUT}:5
+ >=kde-apps/kpimtextedit-${PVCUT}:5
+ >=kde-apps/libkdepim-${PVCUT}:5
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtprintsupport-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+"
+DEPEND="${COMMON_DEPEND}
+ test? ( >=kde-apps/kmime-${PVCUT}:5 )
+"
+RDEPEND="${COMMON_DEPEND}
+ !kde-apps/kdepim-common-libs:4
+ !kde-apps/kdepim-l10n
+"
+
+src_test() {
+ # bugs 641730, 661330
+ local myctestargs=(
+ -E "(autocorrectiontest|pimcommon-translator-translatortest)"
+ )
+
+ ecm_src_test
+}