summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Strizhkin <strdenis02@gmail.com>2024-05-02 02:05:30 +0000
committerJoonas Niilola <juippis@gentoo.org>2024-06-07 16:15:05 +0300
commit07016606ee064c5268e66133e4442b31090fe2b1 (patch)
treee54f586e6cfcd7ce45a49844e24ef03022e09a72 /gui-apps
parentdev-lang/jint: bump to 3.1.2 (diff)
downloadgentoo-07016606ee064c5268e66133e4442b31090fe2b1.tar.gz
gentoo-07016606ee064c5268e66133e4442b31090fe2b1.tar.bz2
gentoo-07016606ee064c5268e66133e4442b31090fe2b1.zip
gui-apps/wmenu: add 9999
Signed-off-by: Denis Strizhkin <strdenis02@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/36512 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/wmenu/wmenu-9999.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/gui-apps/wmenu/wmenu-9999.ebuild b/gui-apps/wmenu/wmenu-9999.ebuild
new file mode 100644
index 000000000000..4c0ed59e653f
--- /dev/null
+++ b/gui-apps/wmenu/wmenu-9999.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="dynamic menu for wlroots compositors, maintains the look and feel of dmenu"
+HOMEPAGE="https://sr.ht/~adnano/wmenu/"
+
+if [[ "${PV}" == *9999* ]]; then
+ EGIT_REPO_URI="https://git.sr.ht/~adnano/wmenu"
+ inherit git-r3
+else
+ SRC_URI="https://git.sr.ht/~adnano/wmenu/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+BDEPEND="
+ app-text/scdoc
+ dev-util/wayland-scanner
+"
+RDEPEND="
+ x11-libs/cairo
+ x11-libs/pango
+ dev-libs/wayland
+ x11-libs/libxkbcommon
+"
+DEPEND="
+ ${RDEPEND}
+ dev-libs/wayland-protocols
+"