summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-04-16 20:41:44 -0400
committerMatt Turner <mattst88@gentoo.org>2023-04-16 20:41:44 -0400
commit0fc4059083f13eb4e0fe8974cbff7569e6ee97ce (patch)
tree83abe940b584fe4f158f4fe83a2af5058d81bc17 /gnome-extra
parentgui-libs/vte: Version bump to 0.72.1 (diff)
downloadgentoo-0fc4059083f13eb4e0fe8974cbff7569e6ee97ce.tar.gz
gentoo-0fc4059083f13eb4e0fe8974cbff7569e6ee97ce.tar.bz2
gentoo-0fc4059083f13eb4e0fe8974cbff7569e6ee97ce.zip
gnome-extra/gucharmap: Version bump to 15.0.4
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gucharmap/Manifest1
-rw-r--r--gnome-extra/gucharmap/gucharmap-15.0.4.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/gnome-extra/gucharmap/Manifest b/gnome-extra/gucharmap/Manifest
index 8bb4c9e7a271..75c0821b12c0 100644
--- a/gnome-extra/gucharmap/Manifest
+++ b/gnome-extra/gucharmap/Manifest
@@ -1,3 +1,4 @@
DIST gucharmap-15.0.2.tar.bz2 1480065 BLAKE2B 9fa5c024d05b25da2ec5d8a93efd2428ca0e47e88e3c5e701995664a548775ae6061fbe1bc4671c15595151a68a3e186544f671b683231461f9be02a86caf11e SHA512 5b345cd0cfe5c588ae062f402c66b45fbbdd03705c4c4900a2314ff19562279436712e19d7143d87cbf6db49e10cba825dd37c0a57aba8b1c1fd9a3e7dbe363e
DIST gucharmap-15.0.3.tar.bz2 1480191 BLAKE2B 9cb551099982286305b24afc8c5d134f61a937e22641d254c0ce60de73b02d9fdb2d4a6c7f6c760bce0ef4e434ead07db0a8f1a14c7ef3a5d8a8ea9ab5af5a33 SHA512 017bd747bfce02c10d6a8f4528ff90f0e99f19e037704d706af73f8751c2ecb3d3ebd01e1d0499d910a368b2b0707cc91d48d7943a3157f0f20522be7ce769c6
+DIST gucharmap-15.0.4.tar.bz2 1453197 BLAKE2B 718890e466e19934b012a79deefc2174edba6de59bd9a374dee5e8cf396fd0a06ae8e4db4cfb223d43284d59be87344310e4cb94e1e45ae158e0213e7bfa06f5 SHA512 280fb164f2d850f9b4a8e54c24d0bc461e0abe2e53f34a6f2f0098397c04856091c6f730cfa9451de5b676b569e2a43bcf2a9dfe160f916b00622ec5535c1e94
DIST gucharmap-3.0.1.tar.bz2 3275481 BLAKE2B 80dde7791abdc72677add9c65c59f810e6c6952116b92db34059c4c40d2657246b17844c105e68f32c86294e9b4e71e9d48e6f0522855465734d7c24e8d17608 SHA512 4d8a2276b5cb1a0b0fadca2a8522755c5884985a12d5b19341b9cefcd7f749ec1286c0271419e38ec84be7edcfa1293e7f0263eb682c75387d692792de3e1fb1
diff --git a/gnome-extra/gucharmap/gucharmap-15.0.4.ebuild b/gnome-extra/gucharmap/gucharmap-15.0.4.ebuild
new file mode 100644
index 000000000000..375128fee077
--- /dev/null
+++ b/gnome-extra/gucharmap/gucharmap-15.0.4.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit gnome2-utils meson python-any-r1 vala xdg
+
+DESCRIPTION="Unicode character map viewer and library"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gucharmap"
+SRC_URI="https://gitlab.gnome.org/GNOME/${PN}/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-3+"
+SLOT="2.90"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+UNICODE_VERSION="15.0"
+
+IUSE="+introspection gtk-doc vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND="media-libs/freetype:2
+ >=dev-libs/glib-2.32:2
+ >=x11-libs/gtk+-3.22:3[introspection?]
+ >=dev-libs/libpcre2-10.21:=
+ =app-i18n/unicode-data-${UNICODE_VERSION}*
+ >=x11-libs/pango-1.42.4-r2[introspection?]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ app-text/docbook-xml-dtd:4.1.2
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ gtk-doc? ( >=dev-util/gtk-doc-1 )
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+ vala? ( $(vala_depend) )
+"
+
+PATCHES=(
+ "${FILESDIR}"/14.0.1-install-user-help.patch
+ "${FILESDIR}"/15.0.1-fix-file-conflicts.patch
+)
+
+src_prepare() {
+ default
+ use vala && vala_setup
+ xdg_environment_reset
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dcharmap=true
+ -Ddbg=false # in 14.0.1 all this does is pass -ggdb3
+ $(meson_use gtk-doc docs)
+ $(meson_use introspection gir)
+ -Dgtk3=true
+ -Ducd_path="${EPREFIX}/usr/share/unicode-data"
+ $(meson_use vala vapi)
+ )
+
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}