summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-07-02 18:27:14 +0200
committerDavid Seifert <soap@gentoo.org>2022-07-02 18:27:14 +0200
commitf01e19fdb330c79c74b77d6e2afdced750a7e909 (patch)
tree67f60fd440ffd32da9a3db8c7b80e3b75b753c0c /gnome-extra/nautilus-dropbox
parentapp-emulation/86Box: drop 3.5 (diff)
downloadgentoo-f01e19fdb330c79c74b77d6e2afdced750a7e909.tar.gz
gentoo-f01e19fdb330c79c74b77d6e2afdced750a7e909.tar.bz2
gentoo-f01e19fdb330c79c74b77d6e2afdced750a7e909.zip
gnome-extra/nautilus-dropbox: enable py3.10
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'gnome-extra/nautilus-dropbox')
-rw-r--r--gnome-extra/nautilus-dropbox/nautilus-dropbox-2020.03.04.ebuild16
1 files changed, 7 insertions, 9 deletions
diff --git a/gnome-extra/nautilus-dropbox/nautilus-dropbox-2020.03.04.ebuild b/gnome-extra/nautilus-dropbox/nautilus-dropbox-2020.03.04.ebuild
index 76ae97342d8f..c07e55dfe255 100644
--- a/gnome-extra/nautilus-dropbox/nautilus-dropbox-2020.03.04.ebuild
+++ b/gnome-extra/nautilus-dropbox/nautilus-dropbox-2020.03.04.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
+EAPI=7
-PYTHON_COMPAT=( python3_{8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit autotools python-single-r1 xdg-utils
@@ -15,17 +15,15 @@ LICENSE="GPL-3 CC-BY-ND-3.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="debug"
-
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-RDEPEND="${PYTHON_DEPS}
+RDEPEND="
+ ${PYTHON_DEPS}
$(python_gen_cond_dep 'dev-python/pygobject:3[${PYTHON_USEDEP}]' )
dev-libs/glib:2
gnome-base/nautilus
net-misc/dropbox"
-
DEPEND="${RDEPEND}"
-
BDEPEND="
$(python_gen_cond_dep 'dev-python/docutils[${PYTHON_USEDEP}]' )
virtual/pkgconfig"
@@ -54,8 +52,8 @@ src_install() {
default
# removes files which conflicts with system dropbox
- rm -r "${D}/usr/share/applications" || die
- rm -r "${D}/usr/bin" || die
+ rm -r "${ED}"/usr/share/applications || die
+ rm -r "${ED}"/usr/bin || die
}
pkg_postinst() {