summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-09-15 22:26:20 -0400
committerMatt Turner <mattst88@gentoo.org>2022-09-15 22:40:34 -0400
commit7d80f2635d5a986259be529edb5a242a4453d64a (patch)
tree4d371012119143be6aac7054e9a9aba0010d906e /gnome-extra/gucharmap
parentapp-i18n/unicode-data: Version bump to 15.0.0 (diff)
downloadgentoo-7d80f2635d5a986259be529edb5a242a4453d64a.tar.gz
gentoo-7d80f2635d5a986259be529edb5a242a4453d64a.tar.bz2
gentoo-7d80f2635d5a986259be529edb5a242a4453d64a.zip
gnome-extra/gucharmap: Version bump to 15.0.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-extra/gucharmap')
-rw-r--r--gnome-extra/gucharmap/Manifest1
-rw-r--r--gnome-extra/gucharmap/gucharmap-15.0.0.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/gnome-extra/gucharmap/Manifest b/gnome-extra/gucharmap/Manifest
index 5b887964e2f4..8f7c708ab961 100644
--- a/gnome-extra/gucharmap/Manifest
+++ b/gnome-extra/gucharmap/Manifest
@@ -1,2 +1,3 @@
DIST gucharmap-14.0.3.tar.gz 1931686 BLAKE2B e72b46450ad97a49519014882cbfd5792a07daf782fdf0d80e4b9221537548a57d3b43dc2b421f3f72d3b0adfee6f11c53304b4468c78b766ffee9536efebba2 SHA512 cb43265a2b54231c15331c299ed10bba8bb83bdc1860ee50764bed8a40ce1421f49edfeb7fa5814c8aac6c23f80936a966346849db83ddf7f94a370adeffc6c8
+DIST gucharmap-15.0.0.tar.gz 1936653 BLAKE2B 4ff592bca75a08e19921c2b08c19ea2693b4652986f2cf77536cf3e056353cf9bfe44e66e15b402552f5ab1b97631f53e07ac10b530164b0ba1d479f70d2b4c2 SHA512 b72f4bf5b6b4d922c91bd1fb58070a5bcdc4364f96144db7446c8a94045158bc3c9e549f1bd3db3f27bb22e6b83a130c73cbd7c737c49a2bb0e2a6a5c8756a66
DIST gucharmap-3.0.1.tar.bz2 3275481 BLAKE2B 80dde7791abdc72677add9c65c59f810e6c6952116b92db34059c4c40d2657246b17844c105e68f32c86294e9b4e71e9d48e6f0522855465734d7c24e8d17608 SHA512 4d8a2276b5cb1a0b0fadca2a8522755c5884985a12d5b19341b9cefcd7f749ec1286c0271419e38ec84be7edcfa1293e7f0263eb682c75387d692792de3e1fb1
diff --git a/gnome-extra/gucharmap/gucharmap-15.0.0.ebuild b/gnome-extra/gucharmap/gucharmap-15.0.0.ebuild
new file mode 100644
index 000000000000..c894bbc415a1
--- /dev/null
+++ b/gnome-extra/gucharmap/gucharmap-15.0.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit gnome2-utils meson python-any-r1 vala xdg
+
+DESCRIPTION="Unicode character map viewer and library"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gucharmap https://gitlab.gnome.org/GNOME/gucharmap/"
+SRC_URI="https://gitlab.gnome.org/GNOME/${PN}/-/archive/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="2.90"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+UNICODE_VERSION="14.0"
+
+IUSE="+introspection gtk-doc vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND="media-libs/freetype:2
+ >=dev-libs/glib-2.32:2
+ >=x11-libs/gtk+-3.22:3[introspection?]
+ >=dev-libs/libpcre2-10.21:=
+ =app-i18n/unicode-data-${UNICODE_VERSION}*
+ >=x11-libs/pango-1.42.4-r2[introspection?]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ app-text/docbook-xml-dtd:4.1.2
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ gtk-doc? ( >=dev-util/gtk-doc-1 )
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+ vala? ( $(vala_depend) )
+"
+
+PATCHES=(
+ "${FILESDIR}"/14.0.1-install-user-help.patch
+ "${FILESDIR}"/14.0.1-fix-file-conflicts.patch
+)
+
+src_prepare() {
+ default
+ use vala && vala_setup
+ xdg_environment_reset
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dcharmap=true
+ -Ddbg=false # in 14.0.1 all this does is pass -ggdb3
+ $(meson_use gtk-doc docs)
+ $(meson_use introspection gir)
+ -Dgtk3=true
+ -Ducd_path="${EPREFIX}/usr/share/unicode-data"
+ $(meson_use vala vapi)
+ )
+
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}