summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPascal Jäger <pascal.jaeger@leimstift.de>2022-10-03 13:47:56 +0200
committerMatt Turner <mattst88@gentoo.org>2022-10-13 21:21:30 -0400
commitb4682c4f0bafa90fd2deb958dddcdb9e11ed27d4 (patch)
tree07a1dbd40954edb57f82c277c551e144eaba8fa8 /gnome-extra/evolution-data-server
parentgnome-extra/gnome-calendar: Version bump to 43.0 (diff)
downloadgentoo-b4682c4f0bafa90fd2deb958dddcdb9e11ed27d4.tar.gz
gentoo-b4682c4f0bafa90fd2deb958dddcdb9e11ed27d4.tar.bz2
gentoo-b4682c4f0bafa90fd2deb958dddcdb9e11ed27d4.zip
gnome-extra/evolution-data-server: build with GTK4 support
Closes: https://github.com/gentoo/gentoo/pull/27322 Signed-off-by: Pascal Jäger <pascal.jaeger@leimstift.de> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-extra/evolution-data-server')
-rw-r--r--gnome-extra/evolution-data-server/evolution-data-server-3.46.0-r1.ebuild (renamed from gnome-extra/evolution-data-server/evolution-data-server-3.46.0.ebuild)19
1 files changed, 12 insertions, 7 deletions
diff --git a/gnome-extra/evolution-data-server/evolution-data-server-3.46.0.ebuild b/gnome-extra/evolution-data-server/evolution-data-server-3.46.0-r1.ebuild
index b68a4f11c621..54af15fb111a 100644
--- a/gnome-extra/evolution-data-server/evolution-data-server-3.46.0.ebuild
+++ b/gnome-extra/evolution-data-server/evolution-data-server-3.46.0-r1.ebuild
@@ -13,7 +13,10 @@ LICENSE="|| ( LGPL-2 LGPL-3 ) BSD Sleepycat"
SLOT="0/63-26-20" # subslot = libcamel-1.2/libedataserver-1.2/libebook-1.2.so soname version
IUSE="berkdb +gnome-online-accounts +gtk gtk-doc +introspection ldap kerberos oauth vala +weather"
-REQUIRED_USE="vala? ( introspection )"
+REQUIRED_USE="
+ oauth? ( gtk )
+ vala? ( introspection )
+"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
@@ -37,10 +40,13 @@ RDEPEND="
berkdb? ( >=sys-libs/db-4:= )
gtk? (
>=x11-libs/gtk+-3.20:3
+ >=gui-libs/gtk-4.4:4
>=media-libs/libcanberra-0.25[gtk3]
- )
- oauth? (
- >=net-libs/webkit-gtk-2.34.0:4.1
+
+ oauth? (
+ >=net-libs/webkit-gtk-2.34.0:4.1
+ >=net-libs/webkit-gtk-2.36.0:5
+ )
)
gnome-online-accounts? ( >=net-libs/gnome-online-accounts-3.8:= )
introspection? ( >=dev-libs/gobject-introspection-0.9.12:= )
@@ -103,8 +109,10 @@ src_configure() {
-DWITH_PHONENUMBER=OFF
-DENABLE_SMIME=ON
-DENABLE_GTK=$(usex gtk)
+ -DENABLE_GTK4=$(usex gtk)
-DENABLE_CANBERRA=$(usex gtk)
-DENABLE_OAUTH2_WEBKITGTK=$(usex oauth)
+ -DENABLE_OAUTH2_WEBKITGTK4=$(usex oauth)
-DENABLE_EXAMPLES=OFF
-DENABLE_GOA=$(usex gnome-online-accounts)
-DWITH_LIBDB=$(usex berkdb "${EPREFIX}"/usr OFF)
@@ -113,10 +121,7 @@ src_configure() {
-DENABLE_WEATHER=$(usex weather)
-DENABLE_LARGEFILE=ON
-DENABLE_VALA_BINDINGS=$(usex vala)
- # Explicitly turn gtk4 off because gtk4webkit is not available yet
- -DENABLE_GTK4=off
)
-
cmake_src_configure
}